Solved

Exchange 2010 Public Folder Auto Reply using Outlook 2007 not working

Posted on 2010-08-26
16
4,251 Views
Last Modified: 2012-06-21
Hi,

I hope someone can help with this issue as I am loosing hair trying to find the fix!

My Set-Up:
Exchange 2010 Standard with Public Folders
I have FULL rights to all public fodler (owner, contact etc)
I have Send as permissions to all public fodlers
I rebooted my PC
I am using
OL 2007

I right click on a public folder called test
I click on the Administration tab
I click on Folder Assistant
I click on Add Rule
I tick the box called "Reply With"
I click on Template
I create the response "Thank you for your email"
I click on the cross and try to save/enable the template
It asks me if I want it to firefor all incoming messages and I say yes
I click on OK and get an erro "changes to therule cannot be saved"

To try and resolve this message, I tried the following:

Save the template before I click on the X as an oft file - same error when I try and OK out of the Folder Assistant

Change the Auto Reply from HTML to Plain txt - same error

No matter what stpes I have taken to resolve the issue, I have the exact same issue. Please can someone help?

Thanks

Jay
0
Comment
Question by:bestchoiceit
  • 7
  • 3
  • 2
  • +2
16 Comments
 
LVL 8

Expert Comment

by:Mkris9
ID: 33529822
Try adding a Send-As Permission for the user that is creating the rule.
0
 
LVL 8

Expert Comment

by:Mkris9
ID: 33529826
i mean send as permission on the mail enabled public folder.
0
 

Author Comment

by:bestchoiceit
ID: 33530116
Mr Mkris9

Done that already. So for example, I am known as jadmin in AD. the public folder is called Test. In Exchange 2010, I go into the Test Public Folder and add me with Send As permissions.

But the above did not help.

Jay

0
 

Author Comment

by:bestchoiceit
ID: 33540370
I'll be calling Microsoft about this issue today. Tried to set an auto reply for a PF from Outlook 2003, 2007 and 2010 - same error.
0
 
LVL 2

Expert Comment

by:heensit
ID: 33546567
Hi, I'm having the same problem.
I can save a delete rule, but it won't save the reply rule.
I don't get any errors, just when I reopen the folder assistant, the reply rule is gone...
If you hear anything from MS, can you please post it here?
Thanks in advance
0
 

Accepted Solution

by:
bestchoiceit earned 0 total points
ID: 33548506
Hi Heensit,

The issue has now been resolved.

Here is the fix:

•      To resolve the issue, we need to provide user following permission
¿  Owner permission on Public Folder
¿  "Receive as" permission on Exchange Administrative Group
 
Here is an example
-------------------------
¿  Create public Folder (Pub04)
¿  Mail enable the public folder
¿  Created a new mailbox test04 (Using the EMC)
¿  Provide Owner permision to test04 on pub04 public folder by running below command
Add-publicFolderClientPermission \pub04 -AccessRights Owner -User test04
¿  Go to Adsiedit and follow below step to provide "Receive as" permission on Exchange Administrative Group (FY DIBOHF23SPDLT)
•        Go to Configuration ¿ services ¿ Microsoft Exchange ¿ Org Name ¿ Administrative Groups ¿ Exchange Administrative Group (FY DIBOHF23SPDLT)
•        Go to properties of Exchange Administrative Group and select Security tab
•        Select "Advanced" option for security tab
•        Select Add and choose test04 users, it should open up another window to provide permissions
•        Make sure under "Apply to" section we have "This object and all descendant objects"
•        Check "Receive as" permission and select apply
¿  Log in to client machine with test04 account and try to create rule with Reply With template option

Please let me know if you need any further help,

Jay
0
 
LVL 2

Expert Comment

by:heensit
ID: 33548616
Nope it's not working :(
When I create a rule and select reply, make a template, click save and ok, the apply button stays grey.
When I then click again on folder assistant, the newly created rule is already gone.

I did however also clear the dney option on the receive as for severale groups where this user is part of (domain admins, enterprise admin, public folder admin, ...)
0
Too many email signature updates to deal with?

Do you feel like you are taking up all of your time constantly visiting users’ desks to make changes to email signatures? Wish you could manage all signatures from one central location, easily design them and deploy them quickly to users? Well, there is an easy way!

 

Author Comment

by:bestchoiceit
ID: 33549408
Heensit,

Assuming you have this issue on Exchange 2010, would you like me to take a look at your server for you?

Jay
0
 
LVL 2

Expert Comment

by:heensit
ID: 33549642
It is tempting, but what would you like to see/do and how ;-)

Maybe it is because I'm working with Outlook 2010 via Outlook anywhere, that I don't get any errors?
Maybe it's better to use one off calls I still have at MS? ;-)
0
 

Author Comment

by:bestchoiceit
ID: 33550269
Hi Heensit,

I would use a tool that you would set up for me - i.e you RDP to your Exchange server and setup Teamviewer - thus I can connect and you can see what I am doing.

If you have MS support, that is also one way to go.

Essentially, to be able to set the Reply With rule on a Public Folder, it wouold appear you need 3 things in place:

1. Full rights to the PF for the users who will set up the Reply With
2. SendAs permissions on that PF for the user who will set up the Reply With
3. Receive As permissions via ADSI edit

Again, let me know if you need further assistance as this issue bugged the hell out of me too!

Jay
0
 
LVL 1

Expert Comment

by:riddhim-dhawan
ID: 33670469
May be this helps !!!  
But I had the sendas permissions issue on mailboxes. After days of research we discoverd this is also due to Offline address Book outlook cached mode.
If this related to particular mailboxes advice users to disable chached mode and re-enable it. ( This does something to OAB as well).
How often does the OAB refresh?
0
 

Author Comment

by:bestchoiceit
ID: 34640135
Hi

Why delete??? I asked a question and provided my own soloution! This may help someone in the future...

Jay
0
 

Author Closing Comment

by:bestchoiceit
ID: 34680244
No updates added to this post for a while and issue has been resolved.
0
 

Expert Comment

by:mvanbeek
ID: 35838573
This is a major problem and the fix provided is a VERY dangerous hack. A valid solution should work for any user given permission via either Outlook, the Exchange Management Console or the Exchange Management Shell.
0

Featured Post

Promote certifications in your email signature

Has your company recently won an award or achieved a certification? They'll no doubt want to show it off. Email signature images used to promote certifications & awards can instantly establish credibility with a recipient and provide you with numerous benefits.

Join & Write a Comment

Check out this infographic on what you need to make a good email signature that will work perfectly for your organization.
Marketers need statistics and metrics like everybody else needs oxygen. In this article we explain how to enable marketing campaign statistics for Microsoft Exchange mail.
In this video we show how to create a Distribution Group in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >>…
In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now