Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 911
  • Last Modified:

Batch File Server 2008

Hello Experts,

I have a batch file that starts up different programs with a delay in between. Some of these programs launch from C: some one them launch from UNC (\\servername\etc) the UNCs are fine but everyone of the C: I get an error that says "The current directory is invalid." I tried adding a C: at the beginning of the batch file but that didnt help. Any ideas?

By thw way this is Server 2008 Foundation I am using, this SAME batch file executes on WinXP with NO problems.
0
triphen
Asked:
triphen
  • 4
  • 4
1 Solution
 
zmorvikCommented:
When you execute a UNC your current directory is changing to that network location.

After each UNC call add:
c:
cd\

without seeing more of the batch file, those are my first thoughts.
0
 
triphenAuthor Commented:
The very first app to start is C:, that one already gives the error. So i dont think its that,
0
 
triphenAuthor Commented:
Here is the batch file
@echo off
ping -n 12 127.0.0.1 > NUL
start /D"C:\Program Files\SQL Anywhere 10\win32" /MIN /B db10.exe C:\SQL\SQLBASE10.db -n SQLbase -x TCPIP -ti 0 -c 128M -qp

@echo off
ping -n 8 127.0.0.1 > NUL
start /D"\\server\folder" /MIN /B Manager.exe

@echo off
ping -n 5 127.0.0.1 > NUL
start /D"\\server\folder" /MIN /B AuthManager.exe

@echo off
ping -n 5 127.0.0.1 > NUL
start /D"\\server\folder" /MIN /B Stock.exe

@echo off
ping -n 5 127.0.0.1 > NUL
start /D"C:\folder\Data\Server" /MIN /B RepSrv.exe

Open in new window

0
Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

 
zmorvikCommented:
For testing, REM the @echo off

put a PAUSE after the ping and the start line.

Something else to try, just after the @echo off, add
C:

I believe because it is starting from the network, it is essentially starting from UNC

One thing to try is on this 2008 server, change/create this registry key:
[HKEY_CURRENT_USER\Software\Microsoft\Command Processor]
"DisableUNCCheck"=dword:00000001
0
 
triphenAuthor Commented:
Same thing, I added the C: and the Reg Dword.....any other ideas?
0
 
zmorvikCommented:
what if you copy the batch file to a local folder and run it there?  Is that the entire batch file or only part of it?

I tried on a 2008 R2 machine with the batch file stored both locally and on the network and it ran with this code inside:

REM @echo off
ping -n 2 127.0.0.1 > NUL
start /D"C:\Program Files (x86)\Microsoft Office\Office12" /MIN /B WINWORD.exe

I did not try adding to a user login script to test when a user logs in, but I can.

What about the PAUSE?  Does it fail on the ping as well or only on the start?
0
 
triphenAuthor Commented:
ERRRRRRRR, I just saw the problem..

Program Files (x86) vs Program Files :)

Blonde moment.....thats why it works in XP :)
0
 
zmorvikCommented:
Excellent!  So glad you noticed that.  I should have asked 32 or 64 bit as well.  Glad it's working!
0

Featured Post

Receive 1:1 tech help

Solve your biggest tech problems alongside global tech experts with 1:1 help.

  • 4
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now