Solved

How do I configure port-channel trunk ports between a Dell 6248 and ESX 3.5

Posted on 2010-08-26
16
3,735 Views
Last Modified: 2012-09-18
I have four virtual machines and each need to be in their own VLAN. I have the 6248 configured for VLANs. I had a separate NIC for each virtual machine and everything worked fine. I now want to use two NICs on the ESX to handle the traffic for all four VLANs. I have set the VLAN IDs on the virtual NICs and I have configured the virtual switch to load balance using "Route based on ip hash". On the 6248 I have configured port-channel 1 and set the switchport mode to trunk and allowed the VLANs I want to use. One the ethernet ports I have added them to channel-group 1 mode auto.

If I do a Show Interfaces Port-channel 1 it shows both interfaces as being Inactive.  What else do I need to configure to get this to work?

Thanks
0
Comment
Question by:neothink
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 6
16 Comments
 
LVL 28

Expert Comment

by:bgoering
ID: 33535826
Take a look at this EE thread: http://www.experts-exchange.com/Networking/Misc/Q_25096361.html

Sounds like what you are trying to do

Good Luck
0
 

Author Comment

by:neothink
ID: 33535974
Thanks for the link but it doesn't mention VLANs which is what I need.
0
 
LVL 28

Expert Comment

by:bgoering
ID: 33536106
Hmmm, something like this should work. It wil create vlan 10 as "native" vlan, 100, 101, and 102 as tagged

Interface  port-channel 1
description lag_1
switchport mode general
switchport general pvid 10
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan remove 1
switchport general allowed vlan add 10 untagged
switchport general allowed vlan add 100 tagged
switchport general allowed vlan add 101 tagged
switchport general allowed vlan add 102 tagged
exit
interface ethernet 1/g2
channel-group 1 mode auto
exit
interface ethernet 1/g3
channel-group 1 mode auto
exit

Let me know - its been a while since I looked at Dell switches (more cisco stuff now)
0
Business Impact of IT Communications

What are the business impacts of how well businesses communicate during an IT incident? Targeting, speed, and transparency all matter. Find out more in this infographic.

 
LVL 28

Expert Comment

by:bgoering
ID: 33536171
if mode general isn't supported on your switch - try with mode trunk, if you want vlan 1 to be native, change pvid 10 to pvid 1, get rid off vlan remove 1 - you shouldn't have to add vlan 1 untagged as it is default.

Good luck
0
 

Author Comment

by:neothink
ID: 33628273
I know my ESX network is working correctly because if I remove the switch and just use one patch cable to connect the two NICs, I can ping both sides. Using the switch as it is currently configured, I can't ping to the other side.

I have moved into a lab so I can try commands without messing up my working network. Here is my config so far. Obviously there is no IP routing taking place yet. Currently I am just testing with VLAN 214.

!Current Configuration:
!System Description "PowerConnect 6248, 2.2.0.3, VxWorks5.5.1"
!System Software Version 2.2.0.3
!
configure
vlan database
vlan  10,20,101-120,201-280
exit
stack
member 1 2
member 2 2
member 3 2
member 4 2
exit
ip address 192.168.2.1 255.255.255.0
interface vlan 214
name "Regular VLAN14"
routing
ip address  10.127.179.209  255.255.255.248
ip ospf cost 10
exit


!
interface ethernet 1/g1
channel-group 1 mode auto
exit
!
interface ethernet 1/g2
channel-group 1 mode auto
exit
!
interface ethernet 1/g3
channel-group 1 mode auto
exit
!
interface port-channel 1
description 'lag_1'
switchport mode general
switchport general pvid 10
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 10
switchport general allowed vlan add 101-102,205,214,219-220 tagged
switchport general allowed vlan remove 1


exit
exit
0
 

Author Comment

by:neothink
ID: 33629168
I think I have this all figured out.  I'll let you know if/when I do.
0
 

Author Comment

by:neothink
ID: 33648402
OK, I have the trunk ports figured out.

configure
interface ethernet 1/g1
switchport mode trunk
switchport trunk allowed vlan add 205,214,219-220
switchport trunk allowed vlan remove 1
exit
interface ethernet 1/g2
switchport mode trunk
switchport trunk allowed vlan add 205,214,219-220
switchport trunk allowed vlan remove 1
exit
interface ethernet 2/g1
switchport mode trunk
switchport trunk allowed vlan add 205,214,219-220
switchport trunk allowed vlan remove 1
exit
interface ethernet 2/g2
switchport mode trunk
switchport trunk allowed vlan add 205,214,219-220
switchport trunk allowed vlan remove 1
exit
exit

When I try to configure the channel-groups, the network hangs.

configure
interface ethernet 1/g1
channel-group 1 mode on
exit
interface ethernet 1/g2
channel-group 2 mode on
exit
interface ethernet 2/g1
channel-group 1 mode on
exit
interface ethernet 2/g2
channel-group 2 mode on
exit
exit


any ideas?
0
 
LVL 28

Expert Comment

by:bgoering
ID: 33648470
It looks like all four ports configured the same so far as allowed VLANs. What does your ESX look like? Do you have one vSwitch with 4 physical NICs? If so you just need 1 channel group, not 2.

Please post screen shot of ESX Network config page and a diagram of what vmnics on ESX are plugged into what ports on switch.
0
 

Author Comment

by:neothink
ID: 33648509
I have two ESX servers each running four virtual vyatta routers. The vyatta routers are clustered across the network. Each ESX has a vSwitch with two physical NICs so I thought each vSwitch would need their own channel group.

I can post screen shots if you need more info.
0
 
LVL 28

Expert Comment

by:bgoering
ID: 33648594
Screen shots never hurt. And yes, you would need a port channel for each ESX server. Now on the ESX are you trying to pass through all the VLAN tagging to the Vyatta routers? Or do you want ESX to handle the decoding of the VLAN tags. Or possibly both?
0
 

Author Comment

by:neothink
ID: 33648758
Each Vyatta is its own network if you will so it doesn't need to worry about the tagging.  I just need the vSwitch and the Dell stack to handle the tagging.

Once I added the following commands, everything works as it should.

interface port-channel 1
switchport mode trunk
switchport trunk allowed vlan add 205,214,219-220
switchport trunk allowed vlan remove 1
exit
!
interface port-channel 2
switchport mode trunk
switchport trunk allowed vlan add 205,214,219-220
switchport trunk allowed vlan remove 1
exit


So the correct order on the switch is create the trunk ports, create the port-channel groups, add the channel groups to the ethernet ports.  or at least I think that is the way it is.  I'm going to try it in my production environment and see what happens.
0
 
LVL 28

Expert Comment

by:bgoering
ID: 33649104
Well silly me didn't even notice the port-channel was missing on your previous post. Guess I saw it there on earlier post and just "assummed"

Glad you are getting there :)
0
 

Accepted Solution

by:
neothink earned 0 total points
ID: 33649230
Well it is now working in production.  It seemed from your post that I only needed to define the trunks/vlans in the port-channel but it looks like they need to be defined on the ethernet port and the port-channel.

Thanks for the help.  :)
0
 
LVL 70

Expert Comment

by:Qlemo
ID: 34459487
This question has been classified as abandoned and is being closed as part of the Cleanup Program.  See my comment at the end of the question for more details.
0

Featured Post

Three Reasons Why Backup is Strategic

Backup is strategic to your business because your data is strategic to your business. Without backup, your business will fail. This white paper explains why it is vital for you to design and immediately execute a backup strategy to protect 100 percent of your data.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

If we need to check who deleted a Virtual Machine from our vCenter. Looking this task in logs can be painful and spend lot of time, so the best way to check this is in the vCenter DB. Just connect to vCenter DB(default DB should be VCDB and using…
When converting a physical machine to a virtual machine using VMware vCenter Converter Standalone or vCenter Converter Enterprise, if an adapter type is not selected during the initial customization the resulting virtual machine may contain an IDE d…
Teach the user how to install ESXi 5.5 and configure the management network System Requirements: ESXi Installation:  Management Network Configuration: Management Network Testing:
Teach the user how to install log collectors and how to configure ESXi 5.5 for remote logging Open console session and mount vCenter Server installer: Install vSphere Core Dump Collector: Install vSphere Syslog Collector: Open vSphere Client: Config…

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question