Solved

Adding Static Route to VLAN - HP2610

Posted on 2010-08-26
7
1,989 Views
Last Modified: 2012-05-10
I have 3 Vlans on my HP ProCurve 2610:

172.16.x.x - LAN
192.x.x.x -VOIP
10.x.x.x - other network

I have currently have 1 static route so traffic can get to the internet no matter which vlan it's on:
ip route 0.0.0.0 0.0.0.0 172.16.0.1

The Default GW on my 172 network is my 2610.

I need to add a static route on my 10.x.x.x vlan  so that applications trying to get to 2 servers on the 10.x network from the 172 network know where to go. Currently I add a static route on my XP machines but would like to just add it on the switch so I don't have to add it locally.

I need to add a static route
0
Comment
Question by:pwtadm
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
  • 2
7 Comments
 
LVL 4

Accepted Solution

by:
bhartwell earned 250 total points
ID: 33536953
first make sure you have enabled routing on the 2610, use the ip routing command, and then make sure that the clients default gateway is the ip of the particular vlan it is on. That should do the trick for you. So if host A is on the 172 vlan, the host's gateway should point to that 172 vlan IP, and the host's on the 10 network should have their gateways point to the 10 vlan ip address.
0
 
LVL 2

Expert Comment

by:fs40490
ID: 33537470
You should not need to add a static route.  If you configure routing on the router, then all should route correctly between the directly connected networks.  The reason is that all directly connected networks should be in the routing table automatically.

0
 

Author Comment

by:pwtadm
ID: 33538462
Thanks bhartwell.

ip routing is enabled. now since I have port 24 on the 2610 plugged into a switch on the 10.X network I marked that port as tagged on both the 172 and 10 vlans, is this correct as well?
0
Revamp Your Training Process

Drastically shorten your training time with WalkMe's advanced online training solution that Guides your trainees to action.

 
LVL 2

Assisted Solution

by:fs40490
fs40490 earned 250 total points
ID: 33538720
There should be no reason to tag it with both VLANs.  What you should do is show the routing table to ensure that the routing instance is building the routing table with both of your networks and an external static that you configured.
0
 
LVL 4

Expert Comment

by:bhartwell
ID: 33543577
I found this post somehwere and this person had a very similar issue as yours. One thing he realized he did that may have screwed things up was setting the IP's of the VLAN's prior to enabling IP Routing. Something about the way the switch works is that IP Routing needs to be enabled from the get go. Here was the summary of the post i saw with his resolution to the problem, hope this helps:
Mystery is finally solved........

The mistake I made, was configuring IP addresses to vlan interfaces before turning on IP routing This is not evident when you display the config with the "show run command". It simply shows IP routing turned on, and all the vlan interface addresses.

So I blew away the config (erase startup) rebooted the beast. And first config command issued was "IP routing". The switch is now operates / thinks as a "Lite router" not L2 switch. Next you apply ip addressing to vlans, port assignments etc and finally any static IP routes.

The box works a treat on the test bench.... Can ping and trace route across all subnets. In my example, Vlan 1 is used for manangement only, and vlan 2 and 3 are active subnets. Listed below are revised config commands / steps in appropriate order (Commands issued from console port):

Login
config
erase startup-config
box "reboot"
Login again

config
hostname Lite_Router
ip routing
no dhcp-relay

vlan 1
untagged 25-28
ip address 192.168.1.254 255.255.255.0
exit

vlan 2
name Data
untagged 1-12
ip address 192.168.2.254 255.255.255.0
exit

vlan 3
name Voice
untagged 13-24
ip address 192.168.3.254 255.255.255.0
exit

write memory
exit

Open in new window

0
 
LVL 4

Expert Comment

by:bhartwell
ID: 33543796
This link from HP should give you a pretty good understanding for the use of tagged vs untagged

http://forums11.itrc.hp.com/service/forums/questionanswer.do?threadId=1129101
0
 

Author Closing Comment

by:pwtadm
ID: 33546615
I did have to mark the port as untagged for both vlan1 and vlan3, fs40490 was correct
0

Featured Post

Announcing the Most Valuable Experts of 2016

MVEs are more concerned with the satisfaction of those they help than with the considerable points they can earn. They are the types of people you feel privileged to call colleagues. Join us in honoring this amazing group of Experts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When you try to share a printer , you may receive one of the following error messages. Error message when you use the Add Printer Wizard to share a printer: Windows could not share your printer. Operation could not be completed (Error 0x000006…
This article explains the fundamentals of industrial networking which ultimately is the backbone network which is providing communications for process devices like robots and other not so interesting stuff.
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…
Suggested Courses
Course of the Month5 days, 9 hours left to enroll

627 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question