• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 797
  • Last Modified:

OpenLDAP Password

I am currently building a test LDAP server in the lab and I when I installed slapd it did not prompt me for a password.  I am not sure if they changed it or maybe it doesn't like Lucid Lynx.  I looked in the ldap.conf file and found nothing as well as the olcDatabase and found zip.  I have been cruising for answers but come up with nothing.
2 Solutions

Found this: "You're not asked anymore to provide a password when the package is installed and issuing the "dpkg-reconfigure slapd"  only resets openldap to the skeleton configuration. You will have to  set up the openldap database, root dn and acl's yourself using the root  account (or sudo) in order to configure openldap."

Read this for a possible solution: http://www.howtoforge.com/install-and-configure-openldap-on-ubuntu-karmic-koala

Regards, Tobias
If you're talking about the rootpw, then you use the slappasswd command to create the password, *after* the openldap is installed.

Configuration of openldap is stored in the directory nowadays so you do not need to edit the config files anymore, but instead modify the appropriate settings in the directory check  this link for more info and some examples: https://help.ubuntu.com/10.04/serverguide/C/openldap-server.html

219comAuthor Commented:
Thanks guys
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get 10% Off Your First Squarespace Website

Ready to showcase your work, publish content or promote your business online? With Squarespace’s award-winning templates and 24/7 customer service, getting started is simple. Head to Squarespace.com and use offer code ‘EXPERTS’ to get 10% off your first purchase.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now