Solved

firefox and shockwave flash are not compatible?  it locks up

Posted on 2010-08-26
25
1,053 Views
Last Modified: 2013-12-07
im using windows 7 with firefox 3.6.8 and whenever i have shockwave flash 10.0.45.2 enabled it locks up firefox.  is there a way to resolve this?
0
Comment
Question by:matteogallo
  • 13
  • 10
  • +1
25 Comments
 
LVL 2

Expert Comment

by:Pagefright
Comment Utility
Could you try installing another browser like Chrome to see if Flash works with it.  This way we can isolate the problem to possibly your version of Firefox or Flash.

If Chrome works with flash then try installing a earlier version of Firefox and see if that works.   Report back your findings and we can move on from there.

Also, try running Firefox as an administrator by right clicking it and selecting that option.  Let us know if that did anything.

0
 

Author Comment

by:matteogallo
Comment Utility
i "upgraded" to shockwave flash 10.1.82.76 and still have problems.  it seems that if flash plugin is enabled then "plugin-container.exe" uses up lots of cpu and im locked up.  if i disable flash firefox runs fine.  

i tried IE and it works when flash is EITHER enabled or disabled....but idk why i should even be trying that when i am disabling it as a firefox plug in...how would that affect another browser anyways?
0
 
LVL 3

Expert Comment

by:csalaski
Comment Utility
I'm using win7 with Firefox 3.6.6 with flash 10.0.45.2 and it works. It's possible that your version of Firefox is not getting along with flash. Mozilla lists 883 bugs between Firefox and Flash.  https://bugzilla.mozilla.org/buglist.cgi?query_format=specific&order=relevance+desc&bug_status=__open__&product=Firefox&content=flash

Try Mozillas plug in checker here.  http://www.mozilla.com/en-US/plugincheck/

Some troubleshooting procedures to find where the fault lies and resolve issues is here.  http://support.mozilla.com/en-US/kb/Troubleshooting+plugins
0
 
LVL 30

Expert Comment

by:mtz1of4
Comment Utility
matteogallo,
what other Add-ons do you have installed? Please list.
Also, can you give us a page where your ff is locking up? To see if I can replicate the behavior.
The plugin-container.exe you noticed is supposed to keep the Flash page sandboxed away from the rest of the browser so that if the flash crashes, it won't take out the rest of the browser.
See http://kb.mozillazine.org/Plugin-container_and_out-of-process_plugins for more info.
and
http://support.mozilla.com/en-US/kb/What+is+plugin-container

http://support.mozilla.com/en-US/kb/Managing+the+Flash+plugin
0
 

Author Comment

by:matteogallo
Comment Utility
ok i will try those suggestions and report back...im away til wednesday...THANKS!!!
0
 

Author Comment

by:matteogallo
Comment Utility
here's an image that shows the add-ons im running
addons.png
0
 
LVL 30

Expert Comment

by:mtz1of4
Comment Utility
Flash installs to different browsers differently.  One install doesn't work for all browsers.

How about trying a New Firefox Profile? 9 times out of ten it works.

http://support.mozilla.com/en-US/kb/Basic+Troubleshooting?bl=n&s=standard%20diagnostic

0
 
LVL 30

Expert Comment

by:mtz1of4
Comment Utility
by the way, you gave us your Plugins, not your add-ons.
0
 

Author Comment

by:matteogallo
Comment Utility
i tried a new profile.  ive attached the an image of the plug-ins for the default profile as well as the new profile.  the new profile still runs extremely slow when i have shock wave flash 10 enabled.  
extensions-default.png
extensions-NEW.png
0
 
LVL 30

Expert Comment

by:mtz1of4
Comment Utility
Extremely slow or crashes?  What page are you accessing for the Flash?  If you're on Google and it's slow then it's not a flash problem.   Perhaps it's your AV program choking on Flash or Scripts.  Did you check csaliskis link regarding Mozilla Test page for Plugins?
0
 

Author Comment

by:matteogallo
Comment Utility
it gets so slow that it takes a minute or two to load anything that uses flash (if i have flash enabled) and it still wont play the video even if the audio works after a while.  i can take a minute or two just to be able to close the window that is trying to use flash (if flash is enabled).  mostly utube but anything that uses flash wont work.  i disabled my antivirus and it didnt help anything.  i tried the test for plugins and it either says "up to date" or unknown plugin

it isnt slow on google

0
 
LVL 30

Expert Comment

by:mtz1of4
Comment Utility
System specs please. And how do you access internet - wired, wireless, DSL, Cable - if wireless, do you control the Router?  What security programs do you have installed on this machine? And do you see the same sysmptoms if you disable each one, one at a time.  Flash has been known to have some security issues, perhaps one of your programs is handling it badly.  I thought youtube was using something other than Flash now. Unless you truly meant utube (I've never been to that site)
0
What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

 
LVL 30

Expert Comment

by:mtz1of4
Comment Utility
my bad, youtube is still using flash.


Is your video card driver updated?
Adobe has troubleshooting here.
http://www.adobe.com/support/flashplayer/
and

http://kb2.adobe.com/cps/822/cpsid_82252.html
0
 
LVL 30

Expert Comment

by:mtz1of4
Comment Utility
What happens when you go to Youtube, right click on one of the playing videos, and select Take SpeedTest?
Check this page
http://www.youtube.com/my_speed#
0
 

Author Comment

by:matteogallo
Comment Utility
speed test
speedtest.png
0
 

Author Comment

by:matteogallo
Comment Utility
even though it took a while for the video to load and start playing, once it finally did i took speed test and it that is the "result"  .  its says that there weren't any videos played back from my location
0
 

Author Comment

by:matteogallo
Comment Utility
i checked to be sure i was running 32 bit firefox (although i have a 64 bit system.....that worked perfectly fine for 1 year or so).  checking that i was running 32 bit FF wasn't an issue as u cant download flash on a 64 bit browser...so it cant be the culprit.

as i mentioned before, flash works when i use IE

attached is an image of what appears to be confirmation that my video card is fine,,,(although i think that point has been determined as my videos play fine in IE so i assume if my video driver was the issue then it would show up as a problem in IE as well.)
0
 

Author Comment

by:matteogallo
Comment Utility

wireless system in which i control the router.  system specs attached.  i use avast, (although i have disabled it with same results).  yes, sorry, i meant youtube
system.png
0
 
LVL 30

Accepted Solution

by:
mtz1of4 earned 500 total points
Comment Utility
ok, you're really starting to stump me.  

Let's try something.
Do you have a Guest account on this machine, or a different Account?
Can you log into it and run Firefox and visit youtube.

My thought is you've obviously got something interfering and I see you have a ton of programs running there that MIGHT be causing some issue, so we'll have to start at just the basic Machine, a new fresh profile( like the guest account), see if it works.  If it does, then we can start shutting down programs half at a time in your Profile to see if we can pinpoint the issue(s).

Your security program(s) should still be running in the Guest account, so if it is causing issues we'll know, however I also use Avast Pro and I haven't had these types of problems.  You don't have Avast sandboxing Flash or Firefox, do you?  You can check under Real-Time Shields->Process Virtualization then hit Expert Settings and look at Internet Access.
I don't believe this is available if using free version.

0
 

Author Comment

by:matteogallo
Comment Utility
YES it works in the guest account. i dont have avast sandbox.  most, maybe all the programs that are running in my user account are installed in the guest account as well.  
0
 
LVL 30

Expert Comment

by:mtz1of4
Comment Utility
correct, they are installed, but they may not be running.  Now we need to determine where the conflict is.
in your normal profile, hit the Windows key, type msconfig and hit Enter. go to the startup tab and start by disabling half of the entries in that tab,restart and test.  if it works properly, we can re-enable half of those that you disabled, reboot and test, keep going until we figure out what is causing the issue.  once we determine what programs are conflicting, we can look at options to adjust settings so they  can work together.
0
 

Author Comment

by:matteogallo
Comment Utility
so i tried disabling half, and that didnt solve the problem....i did the rest...still same problem.  i also tried disabling all the services running (except MS services)...and still nothing....doesnt make sense at all huh?
0
 

Assisted Solution

by:matteogallo
matteogallo earned 0 total points
Comment Utility
i had to resort to moving everything to a new user name and starting from scratch
0
 
LVL 30

Expert Comment

by:mtz1of4
Comment Utility
Glad to have at least pointed you towards a fix.
0
 

Author Comment

by:matteogallo
Comment Utility
yes u did, thanks
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

I have been doing hardcore actionscripting for some time; and needless to say I have faced a lot of problems in just understanding others' code rather than understanding what the code executes. A programmer's life can become hell when there are a lo…
SSL stands for “Secure Sockets Layer” and an SSL certificate is a critical component to keeping your website safe, secured, and compliant. Any ecommerce website must have an SSL certificate to ensure the safe handling of sensitive information like…
The goal of the tutorial is to teach the user how to use the auto adjust feature and what the different options do. When your video is not working right you can choose the auto adjust feature to help choose your settings.
The goal of the tutorial is to teach the user how to select which audio input to use. Once you have an audio input plugged into the laptop or computer, you will go into the audio input settings and choose which audio input you want to use.

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now