Solved

Mutual Redistribution

Posted on 2010-08-27
15
530 Views
Last Modified: 2012-08-13
Can anyone give me a basic example config of mutual redistribution from rip to ospf?  I am trying to learn this but every example I have tried I have problems with the routes not showing.
0
Comment
Question by:B1izzard
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 7
15 Comments
 
LVL 9

Expert Comment

by:ffleisma
ID: 33539889
I've taken a look at the example on the link, probably your not seeing the RIP routes on "R1" as these are seen as connected routes.

Try and check your show ip route on R2, it should reflect the redistributed routes from RIP.
0
 
LVL 9

Expert Comment

by:ffleisma
ID: 33540073
I've attached an example I've simulted in GNS for your reference.

Hope it hepls :-)
Redistribute-RIP-OSPF-example.jpg
Show-Run-for-routers.xls
0
 

Author Comment

by:B1izzard
ID: 33545489
Wow.  What a fabulously perfect example!   That was exactly what I was looking for.  I scoured the internet and couldn't find anything that was this straightforward and actually worked.  I would give you 1000 point if I could.

One last question.  When I entered
r2(config-router)# redistribute rip
I got this:
Only classful networks will be redistributed

After that on r2, I entered:
router rip
ver 2

Will adding the ver 2 change things so that the above warning is no longer valid, and it will then indeed redistribute classless networks?
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 9

Expert Comment

by:ffleisma
ID: 33545649
actually to resolve that warning, you can use r2(config-router)# redistribute rip subnets, meaning redistribute both classful and classless subnets.

the ver 2 on router rip only concerns with what rip version you are running, ver 1 - which is a classful routing protocol and ver 2 -  which is a classless routing protocol. i see where this could create a confusion.

hope this helps :-) glad to help man!
0
 

Author Comment

by:B1izzard
ID: 33545894
Did you use visio for the diagram?
0
 
LVL 9

Expert Comment

by:ffleisma
ID: 33546045
yes i did :-)
0
 

Author Comment

by:B1izzard
ID: 33546116
One thing I didn't catch is that I can't ping 192.168.20.1 from r1, but I can ping 192.168.12.1 from r3.  Did I mess up or is this normal?
0
 
LVL 9

Expert Comment

by:ffleisma
ID: 33546483
actually you should be able to ping 192.168.20.1 from r1, the configuration is for mutal redistribution, meaning ospf to rip and rip to ospf.

can you do a show ip route on r1? do you see route to 192.168.20.0/24? hmmm i did this on a lab and it worked just fine, i'll try and check it and update ayt!

hope it helps :-)
0
 

Author Comment

by:B1izzard
ID: 33547785
Here is all I get for r1 related to 192.168.20.0
      192.168.20.0/32 is subnetted, 1 subnets
R        192.168.20.1 [120/4] via 172.16.12.2, 00:00:01, FastEthernet0/0
0
 

Author Comment

by:B1izzard
ID: 33547820
FYI, I am using GNS3, so I don't know if perhaps it is buggy.  Here are my configs:
r1:
interface Loopback10
 ip address 192.168.10.1 255.255.255.0
interface Loopback11
 ip address 192.168.11.1 255.255.255.0
interface Loopback12
 ip address 192.168.12.1 255.255.255.0
interface FastEthernet0/0
 ip address 172.16.12.1 255.255.255.0
router rip
 version 2
 passive-interface Loopback0
 passive-interface Loopback10
 passive-interface Loopback11
 passive-interface Loopback12
 network 172.16.0.0
 network 192.168.10.0
 network 192.168.11.0
 network 192.168.12.0
 no auto-summary

r2:
interface FastEthernet0/0
 ip address 172.16.12.2 255.255.255.0
interface FastEthernet0/1
 ip address 172.16.23.2 255.255.255.0
router ospf 1
 log-adjacency-changes
 redistribute rip
 network 172.16.23.0 0.0.0.255 area 0
 default-information originate
 default-metric 10000
router rip
 version 2
 redistribute ospf 1 metric 4
 passive-interface FastEthernet0/1
 network 172.16.0.0
 no auto-summary

r3:
interface Loopback0
 ip address 172.16.3.1 255.255.255.0
interface Loopback20
 ip address 192.168.20.1 255.255.255.0
interface Loopback21
 ip address 192.168.21.1 255.255.255.0
interface Loopback22
 ip address 192.168.22.1 255.255.255.0
interface FastEthernet0/1
 ip address 172.16.23.3 255.255.255.0
router ospf 1
 log-adjacency-changes
 network 172.16.0.0 0.0.255.255 area 0
 network 192.168.0.0 0.0.255.255 area 0
0
 
LVL 9

Accepted Solution

by:
ffleisma earned 500 total points
ID: 33547903
okay, i've done the simulation again on GNS, i think i got the interface address at R2-R3 wrong, hence ospf is not even passing to R2, i've adjusted it end to end and attached the show run.

sorry about that, my bad hope this helps this time :-)
Show-Run-for-routers.xls
0
 

Author Comment

by:B1izzard
ID: 33550242
It is working for me now.  Thanks for that.  I did notice a few things I am curious about.
On r2 under router ospf 1, it has the following 2 routes:
 network 172.16.23.0 0.0.0.255 area 0
 network 172.16.0.0 0.0.255.255 area 0

Was there a specific reason or advantage to having both of these?  I took out the
network 172.16.23.0 0.0.0.255 area 0, and everything still seems to be ok.  From what I've read, the network 172.16.0.0 0.0.255.255 area 0 is utilizing summarization.  Am I correct on that?

Same for this on r3:
router ospf 1
 network 192.168.0.0 0.0.255.255 area 0
Since there are loopback 192.168.20.0, 192.168.21.0, 192.168.22.0, and you've apparently summarized them into 192.168.0.0 0.0.255.255 area 0, is there ever any advantage or reason to create them separately?  Example
r3
router ospf 1
network 192.168.20.0 0.0.0.255 area 0
network 192.168.21.0 0.0.0.255 area 0
etc...

How did you pick the metrics 4 and 20, and the default-metric of 10000?  Was this calculated to avoid routing loops?  If so, what values would you give to intentionally create a routing loop so I would know what not to use?
0
 
LVL 9

Expert Comment

by:ffleisma
ID: 33562137
actually the network command doesn't add routes, basically its a mean to enable an interface for that particular routing protocol. for example, under router ospf 1, placing the network command  network 172.16.23.0 0.0.0.255 area 0 enables ospf 1 on all interfaces with 172.16.23.X (x meaning don't care as long as 172.16.23 are matched) ip address and places them on area 0 (ospf uses a concept of areas but thats another story).

if you noticed the 0.0.0.255, it simply means, 0 meaning must match and 255 don't care.

now analyzing the two network commands below.
 network 172.16.23.0 0.0.0.255 area 0
 network 172.16.0.0 0.0.255.255 area 0

even removing the  network 172.16.23.0 0.0.0.255 area 0 command won't really affect the configuration since interfaces having 172.16.23.X will still match 172.16.x.x, makes sense?

now on what is the advantage, it could be two reasons, first maybe you would want to place 172.16.23.x on a different area hence it would be
 network 172.16.23.0 0.0.0.255 area 1
 network 172.16.0.0 0.0.255.255 area 0
or as best practice it is often suggest to use 0.0.0.0 mask, meaning match all so as you'll have better control on which interfaces you would enable the routing protocol. for example

network 172.16.23.2 0.0.0.0 area 0

regarding the metrics, those are just some choices i made, you can choose any depending on your requirements. actually 2 hops would made more sense, as the route is 2 hops away. meaning when i redistributed the ospf routes to rip, using a metric of 2 would explain to rip that the redistributed ospf routes are 2 hops away. using 20 metric was a good choice, since if ever i ran only ospf, those route would appear with a metric of 20

in other words, i just chose 4 and 20 to make things easy to configure and explain.

hope that cleared some of your queries :-)





0
 

Author Comment

by:B1izzard
ID: 33564219
Thank you for clearing that up.  Great explanations.
0
 
LVL 9

Expert Comment

by:ffleisma
ID: 33564269
no prob :-)
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
The purpose of using BGP 33 130
parental control on huwei HG658b 1 29
Public IP Address - Subnet 4 46
unable to set full duplex 100 on WAN interface 11 83
The Cisco RV042 router is a popular small network interfacing device that is often used as an internet gateway. Network administrators need to get at the management interface to make settings, change passwords, etc. This access is generally done usi…
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question