• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1636
  • Last Modified:

Not enough storage is available to process this command - when opening report builder

Hi I get this error "Not enough storage is available to process this command" when our delphi application opens a report builder report.  The problem occurs no matter which report we try to open (we have many reports).

It only happens on one PC - running Windwos XP.

It works perfectly on 60+ other PCs.

(Note I am away from my PC until Monday - Thanks in advance for any responses)
0
enigmasolutions
Asked:
enigmasolutions
  • 5
  • 5
1 Solution
 
aflarinCommented:
If you are using MS SQL, try to the latest Service Pack.

Here is list of fixes for MS SQL 2005, which has the same error:

http://support.microsoft.com/kb/921896
0
 
Geert GruwezOracle dbaCommented:
this could happen too if the program needs to store data to local disk can not access the local drive
easiest to find is to make the user local admin and test again to see if it works

then to look which folder it wants access to
usually temp or the folder of the exe (or a subfolder of the exe)
0
 
enigmasolutionsAuthor Commented:
We are using SQL 2008.

I think Geert is closer to the money.  I should have tried that first.  derrr.

It will take time - I need to get user's admin access.
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
Geert GruwezOracle dbaCommented:
money ?
you need my back account info to donate ?
0
 
enigmasolutionsAuthor Commented:
Thats weird...

I managed to find out the Administrator password for the PC.
So I logged off teh user and then logged in as Administrator.
I then went to Manage the Computer.
I then looked at Local Users and Computers.
I then opened up teh Administrators Group
And whoever set the PC up had in-fact correctly added this user to this group.
So I logged back in as that user and guess what....
... it worked straight away.

But I didn't do anything.  What the?????
0
 
Geert GruwezOracle dbaCommented:
it may have been added later on and not rebooted yet
sometimes security only comes in effect after rebooting
0
 
enigmasolutionsAuthor Commented:
Maybe.  Still it is weird.  
I am going to put it down to solar flares I think.
Thanks for your help!
0
 
enigmasolutionsAuthor Commented:
Geert, you get the points (did I say money?  I wish I had some too).  Its a tough game!
0
 
Geert GruwezOracle dbaCommented:
actually i gave a wrong comment.
Logout/Login will also apply the security policy.
Not only a reboot.
0
 
enigmasolutionsAuthor Commented:
Yep, thats exactly what happened.
0
 
Geert GruwezOracle dbaCommented:
btw, you can keep the money
i think i have a lottery ticket due ...
i hope i don't forget to go get it :)
0

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 5
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now