Solved

Remote Desktop Connection session kick off when conecting with the same credentials ?

Posted on 2010-08-27
4
6,369 Views
Last Modified: 2013-11-21
Hi,

I would like to request an assistant.

May i know why few of my windows server 2003 behave differently than the other server ?

The situation is like this,

1. First i open a remote desktop connection to this server.

2. After that i open again the same server remote desktop using the same credentials above while the first remote desktop is still connected .

3. Right after login the second RDP connection, my first RDP connection will kick off with the following error message :

"You remote desktop session has ended"
"Another user connected to the remote computer, so your connection was lost. Try connecting again, or contact technical support for assistance"

FYI, all my other server will not have this problem and will allow the second RDP connection to connect while maintaining the first RDP session.

May i know what is the setting that make the different ?

Attached is the print screen of the steps.

Appreciates anybody assistant.

Thank you.

Step1.jpg
Step2.jpg
Step3.jpg
0
Comment
Question by:smksa
4 Comments
 
LVL 39

Expert Comment

by:Krzysztof Pytko
ID: 33541587
it happens because you work in standard RDP mode "administrative mode". It's free and uses only 2 concurrent connections. If you want to work this way you need terminal services and "application mode"
0
 
LVL 2

Expert Comment

by:zsaurabh
ID: 33541617
are you connecting to console?
0
 
LVL 1

Expert Comment

by:network_admin3540
ID: 33541642
Sounds like it is set to allow a user only one remote session at a time. That can be changed via group policy; local or domain. Is this an active directory domain?

Check out this site: http://technet.microsoft.com/en-us/library/cc787315%28WS.10%29.aspx

FYI, terminal server has a limit of 3 remote sessions (including the console) when running under administrator if you do not have the correct licensing.
0
 
LVL 31

Accepted Solution

by:
Cláudio Rodrigues earned 500 total points
ID: 33542668
Logon to the machine and run TSCC.MSC.
You will see right under 'Server Settings' a setting that says 'restrict each user to one session'. Change it from Yes to No and you will be fine.

Cláudio Rodrigues
Microsoft MVP - Remote Desktop Services
Citrix CTP
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you're not part of the solution, you're part of the problem.   Tips on how to secure IoT devices, even the dumbest ones, so they can't be used as part of a DDoS botnet.  Use PRTG Network Monitor as one of the building blocks, to detect unusual…
ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question