• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1375
  • Last Modified:

Windows 7 laptop login takes "forever" when disconnected from corporate network

I have a Windows 7 Pro laptop we recently got from Dell that is working great. All except when you want to login and are at home or somewhere else that you're not directly connected to the network.

The user complained of slow logins (5-15 minutes), and when asked in the office to reproduce the issue we could not. I assume this must be something related to the computer not being directly connected to the network.

My first inclination is to remove them from the domain, but I assume there is something else I can check/tweak first before having to resort to that. What can I look at to see why this is loading slow when outside our network, and what can I do to fix that?
0
LlewellynIT
Asked:
LlewellynIT
1 Solution
 
eatmeimadanishCommented:
Is her home network using the same subnet as your local domain?  If so it could be waiting for the domain servers to respond before it logs in.  Is she setup as a static IP and not using DHCP, this could create these problems as well.
0
 
bgcpcCommented:
Seems like the laptop is trying ot contact the domain controller no matter what. I would check the group policy chached credentials to make sure it is not contacting the DC everytime.

Computer Configuration>Windows Settings>Security Settings>Local
Policies>Security Options, look at the "Interactive Logon:  Number of
previous logons to cache" setting.

Set it to anything other than 0
0
 
LlewellynITAuthor Commented:
re: bgcpc

I agree with your assessment, it seems like it is trying to get our DC. That policy in our GPO was "Not Defined" so I set it to 5. I'm going to walk across the street with it and test it.
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
GraceHelpdeskCommented:
got any login scripts?  if it's trying to run something on the network it's not SUPPOSED to hang, but we had to modify our scripts recently as we were experiencing the same problem.
0
 
LlewellynITAuthor Commented:
we do have some login scripts, mainly one that adds printers depending on where you logged into.
0
 
Fr0zTCommented:
You guys are probably on the right track here but if that fails, I will offer an alternate suggestion.

Windows 7 supports TCP Window scaling which is something that some home switches/routers do not support.  (even some bigger switches don't support it.) This could cause some network latencies, and in my experience I have seen this prevent SMB traffic from working all together.  First find out what level of TCP Window Scaling is in effect by typing:
netsh dump | find "autotuning"

You might see something like "autotuninglevel=normal".  If that is the case try disabling it with:
netsh interface tcp set global autotuninglevel=disabled

I don't remember if this requires a reboot or not but do it anyway just to be safe.  More on this here:
http://www.mydigitallife.info/2007/12/15/vista-tcp-window-scaling-auto-tuning-may-slow-down-network-performance/
0
 
LlewellynITAuthor Commented:
I just noticed we also have a group policy for laptops regarding scripts - Run Logon scripts synchronously is disabled. Not sure if that would bypass the script issue that was mentioned above.

re: fr0zt. Autotuning was set to normal, I just changed this to disabled.

Is there any other way for me to test this besides leaving the building? lol
0
 
Fr0zTCommented:
There's no other test that would be valid for all possible problems (GPO,Network etc.)
0
 
LlewellynITAuthor Commented:
Just tried a login across the street and I was ready to rock within 45 seconds. I'll report back tomorrow after the user tries it in their home.

Since I'm a dummy and I didn't test inbetween the GPO change and autodetect change I'll award to both if this solves it. :)
0
 
PrabhaherenCommented:
GPO is right solution..

And
Just turn off the WiFi before your log on process, you computer will pop up with your Desktop within few seconds.
Probing for server is not done when there is no network

I am quite successful with this option :))
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now