Solved

How do I set up Exchange to foward to an internal SMTP server?

Posted on 2010-08-27
4
865 Views
Last Modified: 2013-11-30
I have another server in the enterprise that has the simple IIS SMTP server installed on it (Server 2008 r2), and it can accept e-mails that I write by hand over telnet to port 25, so I know that it's working. Now I need our Exchange (2003) server to be able to send mails to it. I tried adding a contact in active directory with scc-scsm@scc-scsm (the name of the server with SMTP on it) as the SMTP address, but mails to it bounce back with:
You do not have permission to send to this recipient.  For assistance, contact your system administrator.
            <mailserver #5.7.1 smtp;550 5.7.1 Unable to relay for scc-scsm@scc-scsm>

The purpose of this is to allow people to submit helpdesk tickets via e-mail to this server (SMTP on the server just drops them in the drop folder as .eml files and the helpdesk software picks them up).

What do I need to change in Exchange to make it able to relay messages to this other SMTP server?
0
Comment
Question by:SeniorcareIT
  • 2
  • 2
4 Comments
 
LVL 4

Expert Comment

by:zmorvik
Comment Utility
I would check with the vendor for their documentation as this is a fairly irregular way of accomplishing a helpdesk system.

That or, if this is a free helpdesk system, possibly look into another one?

Just a though to accomplish your goal, however, would be to setup a contact in active directory with a bogus domain.  Then create an SMTP connector in Exchange for any email sent to that domain to forward to the IP address of your IIS server.

In exchange, goto Routing Groups and under First Routing Group, you will see connectors.  Create a new connector.  Set the "Forward all mail through this connector to the following smart hosts" to the IP of IIS server.  Then on the address space tab you would make sure that only one entry existed and that it was an SMTP type with the bogus domain that you defined earlier.

The thing is that I'm not certain what address you should send an email to so that IIS will pick it up.  When you are writing it by hand over telnet, you are entering the RCPT TO: command, I'm sure, so that is what I would define in the contact.

I cannot guarantee any of this will work because it is all hinged on how you got IIS to "answer" and receive an email in your telnet testing.  

Good luck!
0
 

Author Comment

by:SeniorcareIT
Comment Utility
IIS SMTP won't attempt to deliver any e-mail, and I've selected the setting in it that will just drop it in c:\inetpub\mailroot\Drop.

The helpdesk software is Microsoft System Center Service Manager, and the way it uses e-mails is to scan a folder for .eml files every 60 seconds (changable). Looking at the connectors on exchange, that looks promising as there's a checkbox for 'allow messages to be relayed to these domains', though I still can't get it to work, given the same error. I'm trying scsm.local as the domain, so the contact sends mail to scc-scsm@scsm.local, and the connector has scsm.local as the domain in its address space, forwarding to the 'smart host' at the SCSM server's IP address.

When I do it over telnet, RCPT TO:<scc-scsm> results in it outputting scc-scsm@ and the FQDN of the server, and I can send mail to that.
0
 
LVL 4

Accepted Solution

by:
zmorvik earned 125 total points
Comment Utility
Ah, ok, I understand.

I believe you have it mostly correct, you just need to setup SMTP on the IIS server "answer" to scsm.local.

Rather than re-type all of it, here is a link and a copy/paste

http://myitforum.com/cs2/blogs/scug/archive/2010/01/07/configure-scsm-email-incident-support.aspx

Setup & Configure the SCSM SMTP server

The SMTP server is a functionality on server 2008 (R2) and is configurable via the Internet Information Services (IIS) 6.0 Manager. (So don’t forget to tick this option also when installing the IIS role)

Setup of the SMTP server

    * On the computer that will host the SMTP Server service, on the Windows desktop, click Start, point to Programs, point to Administrative Tools, and then click Internet Information Services (IIS) 6.0 Manager.
    * Right-click the local computer node, select New, and then click SMTP Virtual Server.
    * In the New SMTP Virtual Server Wizard, in the Name field, type the name for the SMTP server, and then click Next. In this example, type helpdesk.demo.local.
    * On the Select IP Address page, click the drop-down list and select the IP address of the computer that is hosting the SMTP Server, and then click Next.
    * On the Select Home Directory page, click Browse and click to the folder for your home directory. For example, select C:\inetpub\mailroot. You will create a share for this folder in the next procedure.
    * On the Default Domain page, type the domain name for this virtual SMTP server, and then click Finish. The domain name you enter must match domain name that is configured on the Exchange server in previous procedure. In our example, type helpdesk.demo.local.

Create a share for the mail root folder

    * On the Windows desktop, right-click the Start button, and then click Explore.
    * In Windows Explorer, drill down to the folder that you specified as the home directory in step 5 from the previous procedure. For example, drill down to C:\inetpub\mailroot. If needed, create two sub folders, Badmail and Drop.
    * Right-click the home folder, and then click Share.
    * In the File Sharing dialog box, select the domain user that you specified for the Service Manager account, click Contributor, click Share, and then click Done.
    * You can double check this account in the SCSM console
          o In the Service Manager console, select Administration.
          o In the Administration pane, expand Administration, security, and then select “Run As Accounts”

     clip_image002

    * Make sure that the Simple Mail Transfer Protocol (SMTP) service is set to Automatic and has started

Good luck!
0
 

Author Comment

by:SeniorcareIT
Comment Utility
Ah! Yes, that did it. Apparently the default SMTP virtual server that was created wasn't sufficient to accept the mail. Making the second one (and since the default can't be deleted, changing it to port 26 and the second one to 25), seems to have made it accept e-mail. Thanks for your help.
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

Following basic email etiquette rules will help you write a professional email and achieve a good, lasting impression with your contacts.
This article explains in simple steps how to renew expiring Exchange Server Internal Transport Certificate.
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now