Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 954
  • Last Modified:

ActiveSync Stopped Working With iPhones

This was working fine until Monday, when I had another problem and had to do a repair on the server. Anyway, OWA quit working (440 Login failed problem), but ActiveSync still worked. So, I reset a bunch of settings in IIS, and got OWA working, but now ActiveSync does not work. I've tried the solution presented here:

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_26270104.html?cid=748

In fact, I had already implemented it before, but this time it did not fix the problem.

Server 2003 SP2

From https://testexchangeconnectivity.com:

ExRCA is testing Exchange ActiveSync.
 The Exchange ActiveSync test failed.
 Test Steps
 Attempting to resolve the host name mail.pridedallas.com in DNS.
 Host successfully resolved
 Additional Details
 IP(s) returned: 64.183.200.166

Testing TCP Port 443 on host mail.pridedallas.com to ensure it is listening and open.
 The port was opened successfully.
ExRCA is testing the SSL certificate to make sure it's valid.
 The certificate passed all validation requirements.
 Test Steps
 The certificate name is being validated.
 Successfully validated the certificate name
 Additional Details
 Found hostname mail.pridedallas.com in Certificate Subject Common name

Validating certificate trust for Windows Mobile Devices
 The test passed with some warnings encountered. Please expand the additional details.
 Additional Details
 Certificate is only trusted on Windows Mobile 6.0 and later. Windows Mobile 5.0 and 5.0 + MSFP devices will not be able to sync. Root = OU=Go Daddy Class 2 Certification Authority, O="The Go Daddy Group, Inc.", C=US

The certificate date is being confirmed to ensure the certificate is valid.
 Date validation passed. The certificate hasn't expired.
 Additional Details
 Certificate is valid: NotBefore = 4/27/2010 8:29:23 PM, NotAfter = 5/2/2012 11:21:26 PM"



The IIS configuration is being checked for client certificate authentication.
 Client certificate authentication wasn't detected.
 Additional Details
 Accept/Require Client Certificates not configured.

Testing Http Authentication Methods for URL https://mail.pridedallas.com/Microsoft-Server-Activesync/
 The HTTP authentication methods are correct.
 Additional Details
 Found all expected authentication methods and no disallowed methods. Methods Found: Basic

An ActiveSync session is being attempted with the server.
 Errors were encountered while testing the ActiveSync session
 Test Steps
 ExRCA is attempting to send the OPTIONS command to the server.
 OPTIONS response was successfully received and is valid
 Additional Details
 Headers received: Pragma: no-cache
Public: OPTIONS, POST
Allow: OPTIONS, POST
MS-Server-ActiveSync: 6.5.7638.1
MS-ASProtocolVersions: 1.0,2.0,2.1,2.5
MS-ASProtocolCommands: Sync,SendMail,SmartForward,SmartReply,GetAttachment,GetHierarchy,CreateCollection,DeleteCollection,MoveCollection,FolderSync,FolderCreate,FolderDelete,FolderUpdate,MoveItems,GetItemEstimate,MeetingResponse,ResolveRecipients,ValidateCert,Provision,Search,Notify
Content-Length: 0
Date: Fri, 27 Aug 2010 17:22:27 GMT
Server: Microsoft-IIS/6.0
X-Powered-By: ASP.NET



ExRCA is attempting the FolderSync command on the Exchange ActiveSync session.
 The test of the FolderSync command failed.
 Additional Details
 An HTTP 403 forbidden response was received. The response appears to have come from Unknown. Body is: <body><h2>HTTP/1.1 403 Forbidden</h2></body>

0
laurin1
Asked:
laurin1
  • 3
  • 2
1 Solution
 
laurin1Author Commented:
I'm about to reset all the directories, per this:

http://support.microsoft.com/kb/883380
0
 
Alan HardistyCommented:
That is the recommended KB for a 403 error with Exchange 2003 / Activesync.

Run through my article - which I imagine you have found based on the previous question and if you get stuck or run out of article fixes, please let me know.

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_1798.html
0
 
laurin1Author Commented:
I had done that, except for the resetting of the directories....and it worked! I need forms-based authenication, and right now, it's turned off. So, before I turn it on, do I need to do the ExchangeVDir thing?
0
 
Alan HardistyCommented:
If you need FBA enabled, follow KB 817379 and create the exchange-oma virtual directory, set Exchange to require SSL and you should be okay.
0
 
Alan HardistyCommented:
I will go through your question later on this evening and obscure your domain name / IP address to protect your identity.

Glad you are sorted.

Thanks for the points.

Alan
0

Featured Post

Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now