Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Exchange Cert and Outlook 2010-07, problem with users connecting

Posted on 2010-08-27
2
700 Views
Last Modified: 2012-05-10
Alright guys, here is another one for you. Exchange 2010 certificate and Outlook 07-10. Last week Android released a new update for their phone so naturally all my users decided to jump on the bandwagon and installed it; Bad news for me because now their phones will not connect to our exchange server from the outside. See I was using the default certificate that came along with the exchange server, labeled as MYEXCHANGESERVER.MYDOMAIN.local. So I got on the phone with the guys at Sprint (our carrier for the Android) and they tell me that I need to buy a cert for my Exchange server, seems it doesn’t like anything other than “A real certificate”, despite my arguments with Sprint about my “Legit” cert I decided to get one from Godaddy. I installed the cert and off I went, worked great. But…….. then comes the nightmare. All my outlook users start to get a message about it not trusting the new cert. Obviously because it is registered as the outside address and my internal users are connecting to Exchange from its local address. So I start the process of installing the new cert and what do you know! It doesn’t work despite the message stating that it was imported correctly. So here is my problem, at this point I have either working email on phones or an annoying message on Outlook.
Under Exchange I got into the new certificate and enabled it for everything except IIS and now the phones error out but the local users can access Outlook. Does anyone have any ideas?
Here is what I’ve done.
Went into the database of local certs (internet options – content) and tried to remove cert. No go
Went and tried to add manually pointing to the actual cert file. Says it was successful but does not list
Checked my domain cred, I am Master of everything including this PC.
Checked if I was added to local admin. I’m there
Deleted my Exchange account under “mail”, restarted Outlook and ofcourse there is no SSL cert error
Added my account and restarted Outlook, same problem
logged off and into local admin, setup outlook and!!! HEY no problem!! But its still building the ost file
What else can I look at?

0
Comment
Question by:Willsadventures
2 Comments
 
LVL 5

Accepted Solution

by:
kpoochi earned 500 total points
ID: 33544937
To make it simple..... get your phones working and let Outlook give cert error

To resolve the cert error in Outlook follow http://support.microsoft.com/kb/940726 to change the URL's to the name on the certificate.

Follow the article and you should be able to resolve the issue
0
 
LVL 3

Author Comment

by:Willsadventures
ID: 33545278
Perfect. I was look every where for that D#@N command.

Thanks buddy!
0

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Finding original email is quite difficult due to their duplicates. From this article, you will come to know why multiple duplicates of same emails appear and how to delete duplicate emails from Outlook securely and instantly while vital emails remai…
Read this checklist to learn more about the 15 things you should never include in an email signature.
This video is in connection to the article "The case of a missing mobile phone (https://www.experts-exchange.com/articles/28474/The-Case-of-a-Missing-Mobile-Phone.html)". It will help one to understand clearly the steps to track a lost android phone.
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…

828 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question