?
Solved

Problem with require('./wp-blog-header.php');  The  ./  is throwing a 500 error message.

Posted on 2010-08-27
2
Medium Priority
?
518 Views
Last Modified: 2013-12-13
Problem with require('./wp-blog-header.php');  The  ./  is throwing a 500 error message.

I am running on a Windows 2008 server, 64 bit, with IIS7.

You can see my php info at    http://www.greatersba.org/php-info.php

I have a Wordpress installation, that I discovered this issue in.  But the problem doesn't seem to be a Wordpress issue, it seems to be more of a PHP on Windows issue.

For some reason, in the information I found (when looking around) the use of    ./   is supposed to tell PHP to look in the "currrent folder" for the file that is being called, as in require('./wp-blog-header.php');  

But, with the  ./  in front, I always get a 500 error.  Even if I put just a  /   I get a 500 error.

I would like to fix this if possible so it would work normally, but since I am on a Windows 2008 server with IIS7 .. I am not sure how to get this to work properly.  Most of what I see on the net refers to Linux servers.

Can someone explain why it's not working properly on my Windows server .. and what I might be able to do or change (somewhere) so this will work (without my having to remove the    ./   in front of the file name??

Thanks,
Gary
0
Comment
Question by:njcuwebsupport
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 17

Accepted Solution

by:
jrm213jrm213 earned 2000 total points
ID: 33545517
There are a couple of possibilities in this thread that you should look into.  People with the same issue of relative paths work in subdirectory but not in root, and they are all using iis7 with php applications.

http://www.webmasterworld.com/php/3685216.htm

1. I'm not sure if this only applies to ASP/SSI, but IIS6 (not sure about 7) does have a "parent paths" option. If you select your websites and go to the Scripts Configuration menu, under the options tab "Enable Parent paths" is an option.
2.  I ran into this problem, too; giving the anonymous IIS user permissions to the parent directory fixed it.
0
 

Author Closing Comment

by:njcuwebsupport
ID: 33545754
Thanks.  Sorry for that.  Gary
0

Featured Post

Why Off-Site Backups Are The Only Way To Go

You are probably backing up your data—but how and where? Ransomware is on the rise and there are variants that specifically target backups. Read on to discover why off-site is the way to go.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Popularity Can Be Measured Sometimes we deal with questions of popularity, and we need a way to collect opinions from our clients.  This article shows a simple teaching example of how we might elect a favorite color by letting our clients vote for …
There are times when I have encountered the need to decompress a response from a PHP request. This is how it's done, but you must have control of the request and you can set the Accept-Encoding header.
Explain concepts important to validation of email addresses with regular expressions. Applies to most languages/tools that uses regular expressions. Consider email address RFCs: Look at HTML5 form input element (with type=email) regex pattern: T…
The viewer will learn how to dynamically set the form action using jQuery.
Suggested Courses

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question