Solved

sendmail refuses to use smart host

Posted on 2010-08-27
3
586 Views
Last Modified: 2013-12-18
I have a problem with the way sendmail sends messages.  By default, it uses user@host.domain.com which fails with some on the outside because of the dns lookup.

I was able to get the masquerade working so it sends as user@domain.com but fails for local users.  If a local user on domain.com was the recipient, sendmail tries to deliver locally, fails because of no local account, and generates an NDR.

I decided to use exchange for smart host.  In my test environment, I added the lines in sendmail.cf to use smarthost.  I used m4 to create then restarted sendmail.  I tested to my hotmail account and was successful.  Then I tested to my domain.com account and was delivered.  In the message headers it showed that Exchange received it from the linux box.

Here is where the problem comes in.  When I do this on my production box, the masquerade works, but will NOT use smart host.  It keeps trying to deliver locally and fails with NDR.  I have done a couple times, even copying the sendmail.cf from the test machine.  Yet after using m4 to regenerate and restarting sendmail it refuses to use smart host and is treating like a local account, refusing delivery for domain.com recipients.

Both systems are CentOS 5.5 with the same sendmail packages, on the same network, on the same switch with no firewall between each other or Exchange.  Both resolve DNS properly when I do host -t mx domain.com so I can't make sense as to why the same sendmail configuration works on one system and not the other.
0
Comment
Question by:Seth Simmons
  • 2
3 Comments
 
LVL 34

Author Comment

by:Seth Simmons
Comment Utility
I just took another production server configured the same way as the other (package profile, etc).

I made the same masquerade and smart host changes for sendmail and it's working fine.
No idea why the other production server refuses to use smart host.
0
 
LVL 28

Accepted Solution

by:
Jan Springer earned 500 total points
Comment Utility
Do you have 'domain.com' in /etc/mail/local-host-names?
0
 
LVL 34

Author Comment

by:Seth Simmons
Comment Utility
OMG...you just saved my sanity!

That was it.  I commented it out and it's using smart host.
0

Featured Post

Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

Join & Write a Comment

MS outlook is a premier email client that enable you to send and receive the e-mails with various file formats of attachments such as document files, media file, and many others formats. There is some scenario occurs when a receiver of an e-mail mes…
Import PST to Exchange using Power Shell new-mailboximportrequest command, you can simply import the PST file into Exchange mailbox or archived. To know How to import PST into Exchange  2013 read the complete article.
In this video we show how to create a User Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Mailb…
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now