Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Help setting up Cisco Router

Posted on 2010-08-27
17
Medium Priority
?
980 Views
Last Modified: 2012-06-27
Experts,

I have this Cisco 1800 Series router that I am supposed to configure for my company.  I'm pretty much a noob when it comes to this stuff, but the job was given to me when I opened my mouth and said I had taken some router classes back in college.

Anyway, I've pulled out the flash card and it is completely blank, however I do have a bunch of back up files that were given me on a usb thumb drive.  On the thumb drive I see files such as:

home.tar
common.tar
wlanui.tar
c181x-adventerprisek9-mz.124-15.XY1.bin
sdmconfig-1811-1812.cfg
securedesktop-ios-3.1.1.45-k9.pkg
sslclient-win-1.1.4.176.pkg

What exactly should I copy over to the flash card.  What are the basic files the router needs to run?
Also, I am running windows 7.  What happened to hyperterminal? How are people setting up a console connection to cisco routers from windows 7?
0
Comment
Question by:P1ST0LPETE
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 3
  • 3
  • +3
17 Comments
 
LVL 16

Assisted Solution

by:uescomp
uescomp earned 332 total points
ID: 33545946
c181x-adventerprisek9-mz.124-15.XY1.bin is the operating system, or IOS.  That should be all it needs to boot up.  You can try copying that over to the flash drive.  If that doesn't work, you would have to restore the IOS through ROMMON, you can read about how to di that at the following link:

http://articles.techrepublic.com.com/5100-10878_11-5623025.html
0
 
LVL 10

Accepted Solution

by:
qbakies earned 668 total points
ID: 33546049
Hperterminal no longer exists in Windows7.  You can see alternatives here:  http://helpdeskgeek.com/windows-7/windows-7-hyperterminal/

I recommend PuTTY:  http://www.chiark.greenend.org.uk/~sgtatham/putty/
0
 
LVL 6

Assisted Solution

by:itnetworkn
itnetworkn earned 668 total points
ID: 33546060
Use putty. It is better then hyperterminal. Do a search for it online and you will find it. Once you have logged in w/ privileged mode you should be able to run "write erase" and then issue the "reload" command. When it reboots you will be prompted if you want to go through "setup mode" to configure your router. Enter yes and then type in the config you want after each question to setup your router.
0
Nothing ever in the clear!

This technical paper will help you implement VMware’s VM encryption as well as implement Veeam encryption which together will achieve the nothing ever in the clear goal. If a bad guy steals VMs, backups or traffic they get nothing.

 
LVL 10

Author Comment

by:P1ST0LPETE
ID: 33546119
Thanks uescomp, I'll give it a go.  I justed downloaded a program called PuTTY and am able to setup a console session that way.  Watching the router go through a boot up process now on the command line since I added that ISO file to the flash card.
0
 
LVL 10

Expert Comment

by:qbakies
ID: 33546154
Going through setup mode as itnetworkn stated will get you going and probably be about all you need.  Fortunately routers are pretty simple to setup (unlike firewalls) unless you are trying to do a lot of complex routing.  If you have additional questions please ask.
0
 

Expert Comment

by:mseanmiller
ID: 33546298
I concure,

Install Putty as it's freeware. Copy all the files listed to the flash drive and reinsert the card and reboot.

The SDM "sdmconfig-1811-1812.cfg"program is to run the Cisco GUI. A little easier to use the the CLI. (Command line interface.)

Once booted up you can use the automatic setup "CLI" to step through initial configuration as long as you have the LAN and WAN IP/subnet masks and gateway addresses. passwords, etc
Then you can fire up a web browser and log into the router with the LAN IP you assign.
Write down your IP addresses and username/passwords as you go so you can gain access to the device via WWW or CLI.

Let us know if you need some basic routing lessons.
0
 
LVL 3

Assisted Solution

by:samroy2010
samroy2010 earned 332 total points
ID: 33546342
Hi,
Cisco router uses Internetwork Operating System (IOS) for functioning.Each router comes with its default IOS.They are usually stored in flash memory and have *.bin extension.

Cisco Router also needs startup configuration which is stored in NVRAM.If one is present in the NVRAM it automatically loads it else you have to configure it manually when the router boots.Its not that difficult to configure.

Windows 7 doesn't come with Hyperterminal.You can use the Windows XP hyperterminal in win7,  
From Windows XP copy:
      * hypertrm.exe from C:\Program Files\Windows NT\
      * hypertrm.dll from C:\Windows\System32\
to a same folder.

else you can try teraterm pro or putty.
0
 
LVL 10

Assisted Solution

by:qbakies
qbakies earned 668 total points
ID: 33546345
While you can use the SDM GUI I highly recommend learning the CLI.  Cisco is not well known for their user-friendly GUI design.  They have gotten better over the years but CLI is better.  Plus we can tell you verbatim statements to enter in the CLI.  If you are willing to give us actual internal IPs we can even write statements and you can just copy/paste them in PuTTY (although you wouldn't learn much that way).
0
 
LVL 10

Author Comment

by:P1ST0LPETE
ID: 33546360
Ok, think I have it running.  Was able to login and type "show run" to see the running config.  Not sure what most of it means, but I remember the "show run" command from class :-)

Ok, so here's my situation.  The place I work at is basically 2 sister companies (Company A and Company B) owned by the same owner.  Both companies are in the same building.  Anyway what they are asking me to do is setup the router to have 2 networks, 1 for each company.  Then I need to allow 2 IP addresses on Company A's network to talk with Company B's network, and visa versa.

Company A's desired Network IP 10.10.10.0
Company B's desired Network IP 10.10.20.0

Then allow 10.10.10.10 - 10.10.10.11 to have access to 10.10.20.0
and allow 10.10.20.10 - 10.10.20.11 to have access to 10.10.10.0

Back panel of the router looks like the image shown here on Cisco's site:

http://www.cisco.com/en/US/docs/routers/access/1800/1801/hardware/installation/guide/01_hw.html

Any idea how I can configure the router to do this?
0
 
LVL 10

Author Comment

by:P1ST0LPETE
ID: 33546387
Also, both need to have connection to the internet. Forgot to mention that.....
0
 
LVL 10

Author Comment

by:P1ST0LPETE
ID: 33546528
Thanks for all the reply's guys.  Had google searched and downloaded PuTTY while you guys were typing the suggestion to get it :-) - so guess i'm on the right path.

Anyway, going through the router config right now after typing in "write erase" per itnetworkn's advice.
Also, definitely willing to learn some CLI as I'm probably going to be the one managing this thing from here on out.
0
 
LVL 10

Author Comment

by:P1ST0LPETE
ID: 33546659
Going through the config setup now.  It's asking questions that I'm not sure what do so, such as:

Would you like to enter basic management setup? [yes/no]
I said yes, then it asks:
Enter community string [public]:
I have no idea what this is, so I rebooted router and said "no" to management setup.

Then after is lists all the ports on the back of the router, it asks:
Enter interface name used to connect to the management network from the above interface summary:

I have no idea what this management network is or which interface i should choose.

Anyway, they are shutting the lights down on me here in the office.  I'll be back on monday to continue this.
0
 
LVL 6

Assisted Solution

by:itnetworkn
itnetworkn earned 668 total points
ID: 33557855
community string is just referring to SNMP setup. You do not need to have it to get your router to work, so you can skip it for now and add it later.

Your interface questions are just going to ask you which port needs what IP addresses. For example, if Internet is plugged into Serial 1 then that is where you put the config at.  
0
 
LVL 10

Author Comment

by:P1ST0LPETE
ID: 33559904
After going through the System Configuration Dialog, once the router has booted up, as I sit and watch the console connection via PuTTY, I see the following lines:

IP CEF must be enabled first !
%Error opening tftp://255.255.255.255/network-confg (Timed out)
%Error opening tftp://255.255.255.255/cisconet.cfg (Timed out)
%Error opening tftp://255.255.255.255/companyname-confg (Timed out)
%Error opening tftp://255.255.255.255/network-confg (Timed out)
%Error opening tftp://255.255.255.255/companyname.cfg (Timed out)

Then it continually pops up lines like these every 30 seconds or so:

%Error opening tftp://255.255.255.255/cisconet.cfg (Timed out)
*Aug 30 15:56:18.251: %SYS-4-CONFIG_RESOLVE_FAILURE: System config parse from (tftp://255.255.255.255/cisconet.cfg) failed
%Error opening tftp://255.255.255.255/companyname-confg (Timed out)
*Aug 30 15:56:59.255: %SYS-4-CONFIG_RESOLVE_FAILURE: System config parse from (tftp://255.255.255.255/companyname-confg) failed
%Error opening tftp://255.255.255.255/companyname.cfg (Timed out)
*Aug 30 15:57:40.255: %SYS-4-CONFIG_RESOLVE_FAILURE: System config parse from (tftp://255.255.255.255/companyname.cfg) failed
%Error opening tftp://255.255.255.255/network-confg (Timed out)
*Aug 30 15:57:59.251: %SYS-4-CONFIG_RESOLVE_FAILURE: System config parse from (tftp://255.255.255.255/network-confg) failed

Not sure what these errors are about.  Anyway, here is my current config after going through the System Configuration Dialog:

!
version 12.4
service config
service timestamps debug datetime msec
service timestamps log datetime msec
no
service password-encryption
!
hostname CompanyName
!
boot-start-marker
boot-end-marker
!
enable secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxxxxx
enable password xxxxxxxx
!
no aaa new-model
!
!
!
!
no ip routing
!
!
!
!
no ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
archive
 log config
  hidekeys
!
!
!
!
!
interface FastEthernet0
 ip address 10.10.10.1 255.255.255.0
 no ip route-cache
 speed auto
 half-duplex
 no cdp enable
!
interface FastEthernet1
 no ip address
 no ip route-cache
 shutdown
 duplex auto
 speed auto
 no cdp enable
!
interface FastEthernet2
 shutdown
 no cdp enable
!
interface FastEthernet3
 shutdown
 no cdp enable
!
interface FastEthernet4
 shutdown
 no cdp enable
!
interface FastEthernet5
 shutdown
 no cdp enable
!
interface FastEthernet6
 shutdown
 no cdp enable
!
interface FastEthernet7
 shutdown
 no cdp enable
!
interface FastEthernet8
 shutdown
 no cdp enable
!
interface FastEthernet9
 shutdown
 no cdp enable
!
interface Dot11Radio0
 no ip address
 no ip route-cache
 shutdown
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
 station-role root
 no cdp enable
!
interface Dot11Radio1
 no ip address
 no ip route-cache
 shutdown
 speed basic-6.0 9.0 basic-12.0 18.0 basic-24.0 36.0 48.0 54.0
 station-role root
 no cdp enable
!
interface Vlan1
 no ip address
 no ip route-cache
 shutdown
!
interface Async1
 no ip address
 encapsulation slip
 no ip route-cache
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
snmp-server community COMPANYNAME
!
!
!
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
line 1
 modem InOut
 stopbits 1
 speed 115200
 flowcontrol hardware
line aux 0
line vty 0 4
 password powis
 login
!
no process cpu extended
no process cpu autoprofile hog
end
0
 
LVL 10

Author Comment

by:P1ST0LPETE
ID: 33560192
After further thought, I probably should NOT have assigned the 10.10.10.1 address to the Fe0 port right?

I guess what I want to do is have the outside internet come in on either Fe0 or Fe1
Then on Fe2 - Fe8 I want to have setup to operate on the 10.10.10.0 network
And on Fe9 I want to have setup to operate on the 10.10.20.0 network
With both 10.10.10.0 and 10.10.20.0 being able to connect to the internet through Fe0 or Fe1
0
 
LVL 6

Expert Comment

by:itnetworkn
ID: 33561463
I assume you do not need a WIC card for a T1 connection, and that you can plug your Internet connection into one of your FastEthernet ports. If this is correct, then yes your logic is correct you can configure it in the way you specified.
0
 
LVL 10

Author Comment

by:P1ST0LPETE
ID: 33561857
Ok, you guys got me to a good working point with setting up the router.  I'll award points and open up new specific questions for the actual configuration of stuff.
0

Featured Post

Threat Trends for MSPs to Watch

See the findings.
Despite its humble beginnings, phishing has come a long way since those first crudely constructed emails. Today, phishing sites can appear and disappear in the length of a coffee break, and it takes more than a little know-how to keep your clients secure.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

#Citrix #Netscaler #MSSQL #Load Balance
Shadow IT is coming out of the shadows as more businesses are choosing cloud-based applications. It is now a multi-cloud world for most organizations. Simultaneously, most businesses have yet to consolidate with one cloud provider or define an offic…
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…
Michael from AdRem Software outlines event notifications and Automatic Corrective Actions in network monitoring. Automatic Corrective Actions are scripts, which can automatically run upon discovery of a certain undesirable condition in your network.…
Suggested Courses

610 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question