Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 571
  • Last Modified:

How can I use active directory credentials to log on to OWA?

I have one exchange 2003 server with OWA configured.  I want to be able to log on to OWA without having to enter a username and password when I'm already logged on to a domain computer.  

If I use the server name only it will passthrough authentication just fine, for instance https://EXCH01/exchange.  However if I use http://EXCH01.MYORG.MYDOMAIN.COM/exchange it prompts me for the User/Pass.

Both instances resolve to the same internal IP address and the reason I need the FQDN to work as passthrough is because I have a wildcard certificate that would allow my users to get right into their OWA mailbox without having to click OK to proceed with that ominous red bar on top that makes you feel like you did something wrong, lol.
0
fd1906
Asked:
fd1906
  • 4
  • 2
  • 2
  • +2
1 Solution
 
sunnyc7Commented:
Please check this guide on how to configure Pass through auth for 2003
http://www.msexchange.org/tutorials/Dual-Pass-Through-Authentication-Exchange-2003-Front-EndBack-End.html
0
 
fd1906Author Commented:
Thank you for your comment but I don't have a front-end/back-end set up.
0
 
lastlostlastCommented:
Open IIS manager, Expand Default Web Site....

Go to the properties of 'Exchange virtual directory... move to 'Directory Security' tab and set the authentication to 'Integrated Windows authentication' and uncheck all other options...

P.S: You can only set 'Basic' and 'Integrated Windows Authentication' on Exchange virtual directory...

Perform an IISRESET once this is done and check OWA...

let us know how it goes.
0
Prepare for your VMware VCP6-DCV exam.

Josh Coen and Jason Langer have prepared the latest edition of VCP study guide. Both authors have been working in the IT field for more than a decade, and both hold VMware certifications. This 163-page guide covers all 10 of the exam blueprint sections.

 
fd1906Author Commented:
I tried that too... No dice.
0
 
digitapCommented:
0
 
tigermattCommented:

This all depends on the configuration of the BROWSER, not the server. The server will already be configured correctly since pass-through works for the direct URL https://servername/exchange.

You need to configure Internet Explorer to add your exch01.myorg.mydomain.com URL to the Local Intranet zone. By default, IE's security settings state that automatic logon will occur if the site is in the Local Intranet zone, but IE can't figure out that the FQDN exch01.myorg.mydomain.com is actually a server on your local Intranet (as far as it's concerned that's an Internet site).

You can assign that URL to the appropriate zone on a domain using Group Policy - look for the Site to Zone Assignment list option: http://technet.microsoft.com/en-us/library/bb457144.aspx

-Matt
0
 
fd1906Author Commented:
Matt, that makes total sense. Let me try and get back to you.
0
 
fd1906Author Commented:
That worked.  You're a genius.
0
 
sunnyc7Commented:
Matt @ good one :)
0
 
tigermattCommented:

Thanks, fd1906. Glad it worked out.
0

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

  • 4
  • 2
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now