Solved

Routing Problem in Cisco Routers ?

Posted on 2010-08-28
4
991 Views
Last Modified: 2012-05-10
Dear Cisco Experts :
I Have an Issue ( Routing Problem ) in Cisco Routers , My Network As follow :
I Have 3 Routers ( ISDN_Router , Dialup_Router , And Access_Router )

1- Dialup_Router Config :


hostname Dialup_Router
!
boot-start-marker
boot system flash
boot system flash c3845-adventerprisek9-mz.124-11.XJ4.bin
boot system flash c3845-advsecurityk9-mz.124-24.T1_4.bin
boot-end-marker
!
logging message-counter syslog
enable secret 5 $1$QAzG$NZiJsX3GgF5YuIoyCY6Wo1
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
ip cef
!
!
!
multilink bundle-name authenticated
!
!
chat-script offhook "" "ATH1" OK
chat-script callback ABORT ERROR ABORT BUSY "" "ATZ" OK "AT" OK "ATDT \T" TIMEOUT 60 CONNECT \c
virtual-template 1 pre-clone 1
!

controller SHDSL 0/0/0
 dsl-group 0 pairs  0
  shdsl annex A
  shdsl rate auto
 !
 dsl-group 1 pairs  1
  shdsl annex A
  shdsl rate auto
 !
!
!
policy-map remote
!

interface GigabitEthernet0/0
 ip address 192.168.0.253 255.255.255.0
 duplex auto
 speed auto
 media-type rj45
 no keepalive
!
interface GigabitEthernet0/1
 ip address 172.113.0.253 255.255.0.0
 ip access-group 1 in
 duplex auto
 speed auto
 media-type rj45
 no keepalive
!
interface ATM0/0/0
 no ip address
 no atm ilmi-keepalive
 pvc 8/35
  encapsulation aal5snap
  pppoe-client dial-pool-number 1
 !
!
interface ATM0/0/1
 no ip address
 no atm ilmi-keepalive
 pvc 8/35
  encapsulation aal5snap
  pppoe-client dial-pool-number 1
 !
!
interface Virtual-Template1
 no ip address
 ip mtu 1492
!
interface Async1/0
 ip unnumbered GigabitEthernet0/0
 encapsulation ppp
 ip tcp header-compression
 async dynamic address
 async mode interactive
 peer default ip address pool Router_pool
 ppp authentication chap pap
!
interface Async1/1
 ip unnumbered GigabitEthernet0/0
 encapsulation ppp
 ip tcp header-compression
 async dynamic address
 async mode interactive
 peer default ip address pool Router_pool
 ppp authentication chap pap

!
interface Dialer1
 ip unnembered GigaEthernet 0/1
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname ****@rdelc.mpls.vpn
 ppp chap password 7 ****
!
ip local pool Router_pool 192.168.0.136 192.168.0.193

ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 172.113.0.0 255.255.0.0 GigabitEthernet0/1
ip route 192.168.0.0 255.255.255.0 GigabitEthernet0/0

ip http server
no ip http secure-server
!
!
!
access-list 1 permit any
dialer-list 1 protocol ip permit
!
!
!
!
!
control-plane

2- ISDN_Router Configuration :

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ISDN_router
!
boot-start-marker
boot-end-marker
!
enable secret level 7 5 $1$Kakp$l7K8cNFFu4DAEr/jsAZg/1
enable secret 5 $1$XVo3$mRjZ8OvjGyPhOJXpmkaQQ0
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
!
ip cef
!
!
isdn switch-type basic-net3
!
password encryption aes
username test password 0 test
!
!
!
interface GigabitEthernet0/0
 ip address 192.168.0.254 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 172.113.2.1 255.255.0.0
 duplex auto
 speed auto
!
interface BRI0/0/0
 ip address 192.168.10.1 255.255.255.0
 encapsulation ppp
 dialer idle-timeout 600
 dialer string 11111111
 dialer-group 7
 isdn switch-type basic-net3
 isdn point-to-point-setup
 ppp chap hostname doma
 ppp chap password 0 doma
!
interface BRI0/1/0
 ip address 192.168.11.1 255.255.255.0
 encapsulation ppp
 dialer idle-timeout 600
 dialer string 1111111
 dialer-group 8
 isdn switch-type basic-net3
 isdn point-to-point-setup
 ppp chap hostname test
 ppp chap password 0 test
!
interface BRI0/2/0
 ip address 193.168.4.1 255.255.255.0
 encapsulation ppp
 dialer idle-timeout 600
 dialer string 56392900
 dialer-group 9
 isdn switch-type basic-net3
 isdn point-to-point-setup
 ppp chap hostname jaramana
 ppp chap password 0 jaramana
!
interface BRI0/3/0
 ip address 192.168.13.1 255.255.255.0
 encapsulation ppp
 dialer idle-timeout 600
 dialer string 57387230
 dialer-group 10
 isdn switch-type basic-net3
 isdn point-to-point-setup
 ppp chap hostname doma
 ppp chap password 0 doma
!
interface BRI1/0
 ip address 193.168.1.1 255.255.255.0
 encapsulation ppp
 dialer idle-timeout 600
 dialer string 57387230
 dialer-group 1
 isdn switch-type basic-net3
 isdn point-to-point-setup
 ppp chap hostname doma
 ppp chap password 0 doma
!
interface BRI1/1
 ip address 193.168.2.1 255.255.255.0
 encapsulation ppp
 dialer idle-timeout 600
 dialer string 67174790
 dialer-group 2
 isdn switch-type basic-net3
 isdn point-to-point-setup
 ppp chap hostname syhnaya
 ppp chap password 0 syhnaya
!
interface BRI1/2
 ip address 193.168.3.1 255.255.255.0
 encapsulation ppp
 dialer idle-timeout 600
 dialer string 1111111
 dialer-group 3
 isdn switch-type basic-net3
 isdn point-to-point-setup
 ppp chap hostname artoz
 ppp chap password 0 artoz
!
interface BRI1/3
 ip address 193.168.40.1 255.255.255.0
 encapsulation ppp
 dialer idle-timeout 600
 dialer string 111111
 dialer-group 4
 isdn switch-type basic-net3
 isdn point-to-point-setup
 ppp chap hostname jaramana
 ppp chap password 0 jaramana
!
interface BRI1/4
 ip address 193.168.5.1 255.255.255.0
 encapsulation ppp
 dialer idle-timeout 600
 dialer string 64898980
 dialer-group 5
 isdn switch-type basic-net3
 isdn point-to-point-setup
 ppp chap hostname zinab
 ppp chap password 0 zinab
!
interface BRI1/5
 ip address 193.168.6.1 255.255.255.0
 encapsulation ppp
 dialer idle-timeout 600
 dialer string 32398730
 dialer-group 6
 isdn switch-type basic-net3
 isdn point-to-point-setup
 ppp chap hostname kudsya
 ppp chap password 0 kudsya
!
interface BRI1/6
 ip address 192.168.14.1 255.255.255.0
 encapsulation ppp
 dialer idle-timeout 600
 dialer string 111111
 dialer string 57387230
 dialer string 1111111
 dialer-group 11
 isdn switch-type basic-net3
 isdn point-to-point-setup
 ppp chap hostname doma
 ppp chap password 0 doma
!
interface BRI1/7
 ip address 192.168.15.1 255.255.255.0
 encapsulation ppp
 dialer idle-timeout 600
 dialer string 111111
 dialer string 57387230
 dialer string 1111111
 dialer-group 12
 isdn switch-type basic-net3
 isdn point-to-point-setup
 ppp chap hostname doma
 ppp chap password 0 doma
!
router rip
 network 172.113.0.0
 network 192.168.0.0
 network 192.168.1.0
 network 192.168.2.0
 network 192.168.3.0
 network 192.168.4.0
 network 192.168.5.0
 network 192.168.6.0
 network 192.168.7.0
 network 192.168.8.0
 network 192.168.9.0
 network 192.168.10.0
 network 192.168.11.0
 network 192.168.12.0
 network 192.168.13.0
 network 192.168.14.0
 network 192.168.15.0
 network 193.168.1.0
 network 193.168.2.0
 network 193.168.3.0
 network 193.168.4.0
 network 193.168.5.0
 network 193.168.6.0
!

no ip classless
ip route 172.113.0.0 255.255.0.0 GigabitEthernet0/1
ip route 192.168.0.0 255.255.255.0 GigabitEthernet0/0
ip route 192.168.1.0 255.255.255.0 BRI1/0
ip route 192.168.2.0 255.255.255.0 BRI1/1
ip route 192.168.3.0 255.255.255.0 BRI1/2
ip route 192.168.4.0 255.255.255.0 BRI0/2/0
ip route 192.168.5.0 255.255.255.0 BRI1/4
ip route 192.168.6.0 255.255.255.0 BRI1/5
ip route 192.168.10.0 255.255.255.0 BRI0/0/0
ip route 192.168.11.0 255.255.255.0 BRI0/1/0
ip route 192.168.12.0 255.255.255.0 BRI1/3
ip route 192.168.13.0 255.255.255.0 BRI0/3/0
ip route 192.168.14.0 255.255.255.0 BRI1/6
ip route 192.168.15.0 255.255.255.0 BRI1/7
ip route 193.168.2.0 255.255.255.0 BRI1/1
ip route 193.168.4.0 255.255.255.0 BRI0/2/0
ip dns server
!
ip http server
!
access-list 1 permit any
access-list 2 permit any
access-list 3 permit any
access-list 7 permit any
access-list 8 permit any
access-list 9 permit any
access-list 10 permit any
access-list 11 permit any
access-list 12 permit any
access-list 13 permit any
access-list 14 permit any
access-list 15 permit any
access-list 100 permit tcp any any
access-list compiled
dialer-list 1 protocol ip permit
dialer-list 2 protocol ip permit
dialer-list 3 protocol ip permit
dialer-list 4 protocol ip permit
dialer-list 5 protocol ip permit
dialer-list 6 protocol ip permit
dialer-list 7 protocol ip permit
dialer-list 8 protocol ip permit
dialer-list 9 protocol ip permit
dialer-list 10 protocol ip permit
dialer-list 11 protocol ip permit
dialer-list 12 protocol ip permit
dialer-list 13 protocol ip permit
dialer-list 14 protocol ip permit
dialer-list 15 protocol ip permit
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
 password cisco123
 login
!
scheduler allocate 20000 1000
!
end

3- Access-Router configuration :



Cisco Router 2811

**

Building configuration...

Current configuration : 19546 bytes
!

!
hostname 2811
!
boot-start-marker
boot system flash
boot system flash c3845-adventerprisek9-mz.124-11.XJ4.bin
boot system flash c3845-advsecurityk9-mz.124-24.T1_4.bin
boot-end-marker
!
logging message-counter syslog
enable secret 5 $1$QAzG$NZiJsX3GgF5YuIoyCY6Wo1
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
ip cef
!

!

!
!
!
!
controller SHDSL 0/0/0
 Mode atm
 line -term Cpe
 line- mode 2
  shdsl annex A
  shdsl rate auto
 
 !
!
!
policy-map remote
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.6.254 255.255.255.0
 duplex auto
 speed auto
 
 no keepalive
!
interface ATM0/0/0
 no ip address
 no atm ilmi-keepalive
 pvc 8/35
  encapsulation aal5snap
  pppoe-client dial-pool-number 1

 !
!
interface Virtual-Template1
 no ip address
 ip mtu 1492
!
interface Dialer1
 ip unnembered FastEthernet 0/0
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname ****@rdelc.mpls.vpn
 ppp chap password 7 ****
!


ip route 0.0.0.0 0.0.0.0 Dialer1


ip http server
no ip http secure-server
!
!
!
access-list 1 permit any
dialer-list 1 protocol ip permit
!
!
!
!
!
control-plane
!


My Question Is :

I Need to Ping Interface (GE0/0 on ISDN_Router ) and Ping Server1 and Server2
Note :From Laptop i can ping only interface (GE0/1 on dialup_Router )

I Think i need to implement Static Route to do my job ( Is it right )

Thanks in advance






123.jpg
0
Comment
Question by:Muhammed-Rummaneh
  • 2
4 Comments
 
LVL 24

Expert Comment

by:rfc1180
ID: 33549778
with a quick inspection, no, you have a network that overlaps.

ISDN Router has a static network for 192.168.6.0:
ip route 192.168.6.0 255.255.255.0 BRI1/5

On the 2811 (The router that the lappy connects to)
You have a default route on the 2811 pointing out the dialer1 interface
The network on the 2811 lappy for the laptop is 192.168.6.0/24

Any packets sent to 192.168.0.254 will never make it back to the lappy
as there is a network already defined as being destined out another interface.

What you can do is NAT and take care of that problem.

Billy
0
 
LVL 10

Expert Comment

by:Sorenson
ID: 33570297
also set each router with the command

ip classless

rip is a classful routing by default

under router rip also add
no auto-summary

if still having problem please post sho ip route from the routers.
0
 
LVL 24

Expert Comment

by:rfc1180
ID: 33570489
>rip is a classful routing by default
>under router rip also add
>no auto-summary

you can not disable summarization on ripv1

Billy
0
 
LVL 4

Accepted Solution

by:
Muhammed-Rummaneh earned 0 total points
ID: 33759719

I Solved My Problem by disabling gateway  192.168.0.254
and add 172.113.0.253 as gateway to another card

and add static route on isdn Router

IP route 193.168.X.X 255.255.255.0 172.113.2.1

then disable Firewall on Server

Thanks
0

Featured Post

What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

Join & Write a Comment

Secure VPN Connection terminated locally by the Client.  Reason 442: Failed to enable Virtual Adapter. If you receive this error on Windows 8 or Windows 8.1 while trying to connect with the Cisco VPN Client then the solution is a simple registry f…
I've written this article to illustrate how we can implement a Dynamic Multipoint VPN (DMVPN) with both hub and spokes having a dynamically assigned non-broadcast multiple-access (NBMA) network IP (public IP). Here is the basic setup of DMVPN Pha…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

8 Experts available now in Live!

Get 1:1 Help Now