Solved

Allow only 1 Remote Desktop Connection

Posted on 2010-08-28
2
703 Views
Last Modified: 2012-05-10
Hello

I have a Virtual Server running Windows Server 2008. When I logon from one machine, it is opening a Remote Desktop Session. When I now login from another Client, it is opening a second Session, instead of taking over the first session.

How can I change that?

Thanks
0
Comment
Question by:Ruttensoft
2 Comments
 
LVL 6

Accepted Solution

by:
Joshua1909 earned 500 total points
ID: 33548731
Look into group policy under:
Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Connections\Restrict Remote Desktop Service Users to a Single Remote Desktop Services session
Enabling that will limit users to one concurrent session.
0
 
LVL 20

Expert Comment

by:n2fc
ID: 33548733
Okay
Have the server logged in locally.
Log in again using remote desktop connection.
Never log off to close the connection, always use the close button.
If you do find that it is forcing an extra session for you, then log in anyway and go to Start > Programs > Administrative Tools > Terminal Services Manager
Select your server. The session which you are currently using has the user object icon shaded green. You can connect to another session and and log another session off by right-clicking.
===========
Another option:
In the "server" field (after the server name or IP address) add the "/console" option (w/o quotes)

Even if the remote machine does not currently have a user logged into the console session the above command will connect to console session. The console session is a local logon with session ID 0. If a user is logged into the console session and the above command is run you will take over the console session. When you are ready to go  to your server make sure you DISCONNECT from the remote server NOT LOG OFF. If you log off that will end the session. After disconnecting go to server and press Ctrl + Alt + Del and login in to local (console session) and pick up where you left off. Also you must be using same user. You can't remotely login as JohnDoe with the above command then disconnect goto server and Locally logon as Administrator. This action will prompt you to logout JohnDoe and all unsaved work will be lost. And its the same if you locally logon as JohnDoe and the remotely attaching to console session as Administrator. Oh yeah, and I think that to attach to console session the user not only needs to be in Remote Desktop Users Group but also needs to be a administrator of the server.
0

Featured Post

Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Redirected folders in a windows domain can be quite useful for a number of reasons, one of them being that with redirected application data, you can give users more seamless experience when logging into different workstations.  For example, if a use…
A procedure for exporting installed hotfix details of remote computers using powershell
This tutorial will give a short introduction and overview of Backup Exec 2012 and how to navigate and perform basic functions. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as conne…
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …

810 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question