Solved

Users\FolderRedirections - Cannot access user's My Documents - You don't currently have permission to access this folder

Posted on 2010-08-28
9
1,189 Views
Last Modified: 2012-08-13
Hi,
I've recently migrated a customer from Small Business Server 2003 to Small Business Server 2008.

The User's My Documents were redirected to the new server to share \RedirectedFolders.  This corresponds to directory \Users\FolderRedirections\<username>\My Documents.

However when I try to access a user's My Documents I get the following messages :

You don't currently have permission to access this folder.

When I click 'Continue' I get:

You have been denied permission to access this folder.


Now I'm signed on with an administrator account and UAC is turned off.


So why can't I access a user's 'My Documents' ?  And what do I have to do to get access to all user's 'My Documents' ?
0
Comment
Question by:Michael Green
  • 4
  • 3
  • 2
9 Comments
 
LVL 17

Expert Comment

by:aoakeley
ID: 33548999
This will explain the why for you.
http://support.microsoft.com/kb/272723

To get access to the folders you will have to take ownership od the folders and change the permissions. Consider changing the policy as well.

0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 33549242
This is intentional with 2008 and caused by the "Grant the user exclusive rights to My Documents " being checked in the folder redirection policy. In theory it is to give the end user some degree of privacy. If necessary you can change using aoakeley's link or during the migration (to late I assume) un-check the box. The option was there in 2003 but disabled by default.
0
 

Author Comment

by:Michael Green
ID: 33549276
I can't find anything in the 'Migrate to Windows Small Business Server 2008 from Windows Small Business Server 2003' document from Microsoft that mentions turn this setting on or off.
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 33549326
I don't think it is in there because they feel it should be enabled, and I don't know at what point you can do so as I have never used the Microsoft documentation. I have set up SBS's and unchecked the policy before creating the user accounts and thus there MyDoc folders and it works there. After the fact I think you have to follow aoakeley's link if the user's folders have already been created/imported. You can un-check after the fact, and wait for the policy to apply, but I think it will only change folders created after the policy edit.
0
Scale it in WD Gold

With up to ten times the workload capacity of desktop drives, WD Gold hard drives employ advanced technology to deliver among the best in reliability, capacity, power efficiency and performance.

 
LVL 17

Expert Comment

by:aoakeley
ID: 33551377
What RobWill says is correct. if you have a lot of users you will have to do a lot of taking ownershio and then setting permissions back....

Andy
0
 

Author Comment

by:Michael Green
ID: 33552243
the link from aoakeley's post is old :
http://support.microsoft.com/kb/272723

Its only applicable to Windows 2000 and the dialogs have changed.  Does anyone have a Windows 2008 link or one specifically for SBS2008 ?
0
 
LVL 17

Accepted Solution

by:
aoakeley earned 500 total points
ID: 33552332
Basic premis is the same, but here is a link specific to win7/Server 2008 R2
http://technet.microsoft.com/en-us/library/cc753659.aspx

Also
1. find the folder you want to change owner.
2.. Right-click on it and select properties.
3. select security and click Advanced button
4. select Owner tab, edit and change the owner as you wish.
5. click OK to confirm.
0
 

Author Comment

by:Michael Green
ID: 33555325
6. Critical to also select 'select Replace owner on subcontainers and objects' - otherwise you are only going to get access to the top level of the directory structure under that person's my documents
0
 
LVL 17

Expert Comment

by:aoakeley
ID: 33555328
Yes
0

Featured Post

Give your grad a cloud of their own!

With up to 8TB of storage, give your favorite graduate their own personal cloud to centralize all their photos, videos and music in one safe place. They can save, sync and share all their stuff, and automatic photo backup helps free up space on their smartphone and tablet.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

The articles for turning off the Client firewall policy on the internet are for SBS 2008 and don't really help for SBS 2011. They actually moved the Client firewall policy. In 2011, the client firewall policy has moved to the SBS computers conta…
You may have discovered the 'Compatibility View Settings' workaround for making your SBS 2008 Remote Web Workplace 'connect to a computer' section stops 'working around' after a Windows 10 client upgrade.  That can be fixed so it 'works around' agai…
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …
In this video I am going to show you how to back up and restore Office 365 mailboxes using CodeTwo Backup for Office 365. Learn more about the tool used in this video here: http://www.codetwo.com/backup-for-office-365/ (http://www.codetwo.com/ba…

895 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now