Solved

iis images not showing in a wordpress sub directory

Posted on 2010-08-28
20
864 Views
Last Modified: 2013-12-13
I have wasted a good half of a day on this... woudl welcome any ideas ... it has to be something very simple.

I am running iis 6 on win2k2003 64 bit, with php / mysql installed.

Ihave installed a word press blog on IIS6  on its own domain.i.e. blog.com It works 100% perfectly.

I then install a word press blog on an existsing site i.e. site.com/blog it all works 100% except none of the images show up.

Firstly I assumed it was a paths problem.... checked... it is fine if I rightlcik the missing image the path is fine and correct. I then try linking directly to the file in a browser.. I get the page cannot be found error. Then I think it may be permissions., have they propogated correctly... they have and they are exactly the same as the rest of the site. Then I create a new directory in the root (outside of the wordpress directory) and stiock the image there ... the image shows up just fine.

For some reason the images if they are located in the wordpress directory will just not show up... I really cannot think why.

Look forward to your ideas.



0
Comment
Question by:alexealden
  • 11
  • 7
  • 2
20 Comments
 
LVL 20

Expert Comment

by:woolnoir
ID: 33549656
whats your IIS log file saying when you try and access the files ? Thats the first place to look.
0
 
LVL 23

Expert Comment

by:jeremyjared74
ID: 33549670
Have you checked the permissions for the folder?
0
 

Author Comment

by:alexealden
ID: 33549675
2010-08-28 15:17:54 W3SVC1059761940 xx.xx.xx.xx GET /images/rss.png - 80 - 188.28.143.30 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+6.1;+Trident/4.0;+GTB6.5;+SLCC2;+.NET+CLR+2.0.50727;+.NET+CLR+3.5.30729;+.NET+CLR+3.0.30729;+Media+Center+PC+6.0;+InfoPath.2;+.NET4.0C;+Tablet+PC+2.0) 404 0 2

this is the log reading - I have take out the ip address.. yes permissions for teh folder have been propgated many times and are exactly the same as a word press blog running in its own domain
0
 
LVL 20

Expert Comment

by:woolnoir
ID: 33549699
What are the permission differences between a specific image file in the dedicated domain and the folder off the existing website. And, what are the permissions differences between the parent folder of the image files in the same two situations.

Also are there any website (in iis) permission differences between the two sites.
0
 

Author Comment

by:alexealden
ID: 33549720
I really cannot see any difference between the permissions.. also cannot find any difference in permissions from within IIS... yet if I create a folder and copy the image into it on the existing site it works fine ...



0
 
LVL 20

Expert Comment

by:woolnoir
ID: 33549724
The existing site, and the new site you talk about, same installation of IIS ? Same server?
0
 

Author Comment

by:alexealden
ID: 33549738
Yes same installation / server ... its exactly the same problem on more than one site I can install to a root directory with its own domain and its fine have done this twice .... and  I have tried installing into subfolders of two fully functioning sites and this issue occurs... At first I thought it was a worpress problem, but basically the images are not showing up even though permissions are the same...

I have one idea I will try removing and readding the permissions and seei if that works..

0
 

Author Comment

by:alexealden
ID: 33549768
tried that and same issue
0
 
LVL 20

Expert Comment

by:woolnoir
ID: 33549770
so is it only the images folder in wordpress directory ? if you made a images2 folder, in the wordpress folder, and copy an image inside, does that work ?
0
 

Author Comment

by:alexealden
ID: 33549793
Same issue... what I have noticed is that existing permission tick boxes are greyed out, iI cannot untick. However I can tick new ones which are solid black colour.
0
Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

 
LVL 20

Expert Comment

by:woolnoir
ID: 33549801
Ok then the issue is that its inheriting bad permissions potentially, try editing the images folder, setting permissions not to inherit from the parent and set it to keep the existing assigned ones. Then you might want to add a permission so that the IIS user can read, or everyone can read, either should work.

It makes some sense.. since it may be a permission thats coming from ABOVE the wordpress folder level, thats why on a new domain it works fine. So maybe look at the permissions assigned to the folder above wordpress and check if you can spot anything odd.
0
 

Author Comment

by:alexealden
ID: 33549959
I have never experienced anythign as quirky as this  with permissions... this is madness.

I create a folder /blog . make sure no permisions are being inherited. Set my own permissions.

take an image from the WP installation folder and chuck it in.... it works

take the entire WP folder it doesn't ... so set the child objects to recieve the new permissions ... its still doesn't work :(

0
 
LVL 20

Expert Comment

by:woolnoir
ID: 33549968
I think its something inheriting INTO your wordpress folder, perhaps something wrong with the parent permissions i.e

whateverdirthisiscalled/wordpress/images

The 'whateverdirthisiscalled' may have something thats inheriting all the way down to images.

Maybe try removing all permissions from images, set inherit to NO, and then assign your working permissions.
0
 

Author Comment

by:alexealden
ID: 33550043
I cannot see anything wrong with the permissiions above...

I have tried on a development version of the site and removed all of the user permissions. re-taken owenership added all new permissions and re-propagated. Still the same problem ...

I am at my wits end here I have been doing this all day.



0
 

Author Comment

by:alexealden
ID: 33550104
OK removed all permissions at the site root level and then just kept IUSR and Administrator and repropped.. same issue. There is something horribly wrong here, I don;t think this is to do with permissions. All of the permissions are there.

I even tried using a virtual folder to go through to a working WP blog - and it's the same no images. But If I use the domain for it it works.


0
 
LVL 20

Expert Comment

by:woolnoir
ID: 33550207
there aren't that many other things it could be. The server is running as a specific user, but you have already said that other virtual servers work fine, and they use the same user. Other folders within wordpress have the same issues, yet folders further up don't... again suggesting an inheritance issue.

Let me have a think about it, but if other experts have any other ideas please pitch in.

Is it only images that are a problem ?if you put a text file in the images folder, can you read it ?
0
 
LVL 23

Expert Comment

by:jeremyjared74
ID: 33550552
There have been many posts, so if this has been suggested, sorry.

I would try disabling all plug-ins. Then see if they show up. If it does, start enabling 1 at a time until you discover which it is.

If that doesn't work, try re-installing Wordpress by clicking on the Dashboard tab in the left side administrator panel and select updates. It will say you have the most recent, update anyway. Maybe it will work?
0
 

Author Comment

by:alexealden
ID: 33550602
Thanks Woolnoir, it seems random, some of the sub directories are readable... i.e. I can stick a text file in there and view ... yet others aren't. Again, I have compared permissions side by side and they are identical.


Apart from this Wordpress works flawlessly, I can create posts etc ... so the php side of it seems to be working fine.

0
 

Accepted Solution

by:
alexealden earned 0 total points
ID: 33550819
OK. I found it...

It was the .htaccess file (mod rewrite / I sapi rewrite) as the blog directory did not have one it was defaulting to the parent .htaccess file in the root directory.

what a waste of a day...Thanks Woolnoir for all  your help. ... but where are all the other experts .. ?? I could have used a few more ideas on this one !
0
 

Author Comment

by:alexealden
ID: 33550823
As I said at the beginning it had to be something so simple.
0

Featured Post

Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
delete database record with modal 21 34
Wordpress Body Class 5 13
sql sentence 2 13
Why does my array not "dump?" 5 19
Running classic asp applications under Windows Server 2008 R2 (x64) and IIS 7 is not as easy as one may think. It took me a while to figure it out while getting error 8002801d a few times. After you install the OS you will need to install the fol…
If you don't have the right permissions set for your WordPress location in IIS, you won't be able to perform automatic updates. Here's how to fix the problem.
Learn how to match and substitute tagged data using PHP regular expressions. Demonstrated on Windows 7, but also applies to other operating systems. Demonstrated technique applies to PHP (all versions) and Firefox, but very similar techniques will w…
The viewer will learn how to look for a specific file type in a local or remote server directory using PHP.

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now