Solved

Autoconnect to wireless in Windows 7 x64?

Posted on 2010-08-28
13
819 Views
Last Modified: 2012-06-27
My company has six identical Dell Latitude E4200 computers. all are running preinstalled Windows 7 x64. I've installed updates and the same software on each and distributed all but one of them to users.

The first five will not automatically connect  to any wireless network. The sixth will automatically connect to the office wireless network (WPA-2)  but will not automatically connect to another wireless network (WEP) when I tested it. If I export the office wireless network connection settings of the sixth to a USB key and then import it on one of the first five, that one then automatically connects. So it seems to be some property of the connection.

On all six:

 The WLAN Auto Config service is set to Automatic and is started.

In the connection properties, "Connect automatically when this network is in range" is checked. I tried checking "Connect even if the network is not broadcasting its name".

The logged-in user is a local administrator.

WTF?
0
Comment
Question by:JonFleming
  • 4
  • 4
  • 2
  • +2
13 Comments
 
LVL 12

Expert Comment

by:naykam
ID: 33550922
First up I would try stripping the authentication to see if that is the issue
0
 

Author Comment

by:JonFleming
ID: 33550935
I dunno ... it happens with WPA and WEP networks. I'm told none of the users can autoconnect at home. I don't know if any of them are without authentication...
0
 
LVL 12

Expert Comment

by:naykam
ID: 33550952
Have you got the latest wireless card drivers? - and not just from windows update

Either from here: http://goo.gl/RrYU or the manufactures website (ie, broadcom or intel)
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 33551222
If the computers are relatively new and came pre-loaded, then ask Dell.

Also, has Dell provided its own wireless tool? IBM does and I use it. If so, the Dell application may be taking precedence over Windows and so needs to be configured.

... Thinkpads_User
0
 
LVL 4

Expert Comment

by:Amnonm
ID: 33551595
My suggestion is to delete the configured connection and try to search for it and connect instead of setting it up manually(in case it's not hidden).
in addition it will help installing dell wireless wireless utility
http://support.dell.com/support/edocs/network/p70008/en/utility.htm
0
 
LVL 15

Expert Comment

by:Russell_Venable
ID: 33551705
You will have to upload  from USB the configuration of your "computer 6" to all of the W7 machines you wish to auto connect. So they have the same configuration so on. I did this with my network and its running fine.
0
Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 
LVL 15

Expert Comment

by:Russell_Venable
ID: 33551707
Oh yeah forgot! Make sure the user groups are all the same too!
0
 

Author Comment

by:JonFleming
ID: 33553916
"You will have to upload  from USB the configuration of your "computer 6" to all of the W7 machines you wish to auto connect. So they have the same configuration so on. I did this with my network and its running fine."

That works for the office network. I need a solution that works for all networks, including ones they add themselves on the road.

"Ask Dell"

Not a bad idea.

"has Dell provided its own wireless tool"

No.

"in addition it will help installing dell wireless wireless utility"

I'll try that.

"Have you got the latest wireless card drivers? - and not just from windows update"

Yes, from Dell (and never from Windows Update ... I use WSUS and don'u download drivers).
0
 
LVL 15

Expert Comment

by:Russell_Venable
ID: 33556463
Check the connections using the built-in wireless utility from the intel proset. If it can't connect using the current configuration I would strip the configuration and try doing it manually to make sure everything works. Also It has a diagnostics tool that allows you to manually run diagnostics.

Things to keep in mind are:

- Firewall blocking connections
- bad wireless configuration
- Authentification key is rejected. (Make sure the key is same key as the one you are attempting to auto-connect too)
- Signal strength is too low. (How far are they from the signal? Are they in a building with a lot of metal?)

Dell has this guide for Manually running Wireless Diagnostics.
http://support.dell.com/support/edocs/network/R196253/en/diagnovi.htm

Also to strip authentification go to:

Control Panel ->Network and Internet->Manage Wireless Networks

Right-Click the network that it is trying to auto-connect too. Right click on it and select properties. Then click on security tab.

Look at the following

Security type:
Encryption type
Network key:

select Security type: and choose "No Authentification(Open)"

If Security type shows "No Authentification(Open)" already it has no authentification. Easy enough right? Also you can check the priority of the wireless network  on the "Manage Wireless Networks" Folder if its not at the top of the list that might be why its not automatically connecting. To fix that specific issue you would select the wireless network that you want to be the primary wireless network to connect to and click and drag it to the top of the list.

If none of these helped come back and post your results.
0
 

Author Comment

by:JonFleming
ID: 33561158
It connects just fine when I click the "Connect" button. The issue is that I have to click the "Connect" button, even though "Automatically connect" is selected. I tried stripping the authentication (the path to which is a little different in Windows 7) and got a prompt to enter the network key when I clicked the "Connect" button. I did so, and made "Connect automatically " was checked. It still won't connect automatically, I have to click the "Connect" button. See attached screeenshot of the Dell wireless utility:
Dell-WLAN-utility.png
0
 
LVL 4

Expert Comment

by:Amnonm
ID: 33562601
one more thing did you try resetting the network controller configuration from device manager and set the channel to auto?
0
 
LVL 15

Expert Comment

by:Russell_Venable
ID: 33570030
Try unchecking the auto-connect , reboot and recheck it. W7 automatically checks the auto-connect to on. If the problem persists you should reinstall the driver and check to see if its auto-connect is on by default if it is uncheck and reboot.
0
 

Accepted Solution

by:
JonFleming earned 0 total points
ID: 33603088
Ok, how do I do this? Lots of good suggestions. thinkpads_user was close, so I'd like to give him some points.

The problem was Dell ControlPoint Connection Manager, which was running the card although it looked as if WIndows was running the card. Uninstall ControlPoint Connection Manager and all is peaches and cream.

I've often wondered why OEMS make utilities to run wireless cards. Ever since XP WIndows has been better than any OEM's utility.
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Need WiFi? Often, there are perfectly good networks that don't have WiFi capability - and there's a need to add it.  - Perhaps you have an Ethernet port into a network but no WiFi nearby. - Perhaps you have a powerline extender and no WiFi at the…
Working settings for French ISP Orange "Prêt à Surfer" SIM cards for data connections only. Can't be found anywhere else !
This Micro Tutorial will teach you how to the overview of Microsoft Security Essentials. This is a free anti-virus software that guards your PC against viruses, spyware, worms, and other malicious software. This will be demonstrated using Windows…
The viewer will learn how to successfully download and install the SARDU utility on Windows 7, without downloading adware.

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now