Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 704
  • Last Modified:

Belkin Pre-N Router Virtual Servers, NAT routing

I can access the control panel of my Belkin router from the WAN. I am trying to get it so I can access my Sharepoint website that is on a virtual machine on my LAN. I can access the Sharepoint with the LAN address, however when I create a virtual server on my Belkin router that is supposed to route traffic to my sharepoint servers web page (port 80 or port 8888), I still only get the control panel of the Belkin router, instead of the Sharepoint services.
0
mrmyth
Asked:
mrmyth
  • 5
  • 4
  • 2
1 Solution
 
PirtatePeteCommented:
Do they both have the same ip address?
0
 
mrmythAuthor Commented:
the router is .2 on the internal network and the server is .100

0
 
brettkmCommented:
Try changing the port of the router control panel.  To 8080 or something.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
PirtatePeteCommented:
There seems to be a lot of posts around various sites that relate to these routers having difficulties with the ports 80,88,8000,8080,8888
There are a lot of complaints about this, and numerous people awaiting a firmware update to fix.
brettkm is correct, but I think you need to use ports that do not have combinations of 0 or 8 in them.
0
 
mrmythAuthor Commented:
I tried various ports and they didn't work. Do you have a suggestion for a port?

Should the inbound and private port on the server be the same? or if internally get to the server by going say 192.1689.1.50:80, should the private port be 80 and the inbound port be something else?
0
 
brettkmCommented:
So you have tried setting the routers in built web page to a different port?  What's probably happening is when you browse to the external IP address port 80, rather than the share point page loading, the router control panel loads up.  So you need to change this port.  Once that is done, if you have forwarded port 80 to the share point server correctly it should work.

What's the router model number?
0
 
mrmythAuthor Commented:
Unfortunately I can't see any way to change the built in web page port number. It is a F5D8230-4
0
 
brettkmCommented:
It's surprising that you can't.  Under the Utilities menu there's a System Settings option, have you tried in there?  If you're prepared to give me access to your router I can have a look for you.
0
 
mrmythAuthor Commented:
I emailed Belkin and they could only show me a way to put the server outside the firewall. I can't give out access to the router unfortunately, but thanks for the offer. The Belkin recommendation seems the only way with this router.
0
 
brettkmCommented:
Version v1001ea of you router is compatible with DD-WRT which definitely allows you to change the web interface port.  If you haven't heard of it, DD-WRT is a custom linux firmware that is very stable and has heaps of features.

http://www.dd-wrt.com/site/support/router-database

Type Belkin F5D8230 in the box and you'll see 2 routers listed, version v1001ea  is compatible but version v1002 isn't.

Read the instructions carefully as it's easy to brick your router. You could even just shell out $100 and by a new router.
0
 
mrmythAuthor Commented:
That is great news. I've been hoping to use Tomato but it's not compatable. I'll flash the firmware and see what happens.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 5
  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now