Dotnetnuke Friendly Url Settings

Have installed DotNetNuke Community Edition  5.4.3
After finishing developing a website under portal 0 and turned Friendly Url Settings on
I get url's like

Made a template with content from portal 0 and installed a new portal (2) with the template.
(copy from portal 0 )

Now I get url's like
on the new portal 2
Any idea how to fix this so my new webpage shows the same url's ?
LVL 10
TomMicrosoft ISV PartnerAsked:
Who is Participating?
paololabeConnect With a Mentor Commented:
I had a similar problem but my memory fail, the problema in't child portal, but multilanguage support.
To confirm this i've tried to enable multilanguage support in a dnn 5.4 portal with human friendly ulr activate and with a single languga enabled, enablinf another language human friendly url disappear.

Searching around I found this post


It seems the domain is the same (may be is only an example), consider that in child portal friendly url doesnt't work.

TomMicrosoft ISV PartnerAuthor Commented:
domain name is different. It is not a child portal, so this should work.
TomMicrosoft ISV PartnerAuthor Commented:
Thank you so much for a great find ! Looks like I'm not the only one :-) lets hope they fix this bug in the next issue.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.