Solved

You do not have permission to access \\[Computer]\[Drive]

Posted on 2010-08-29
55
1,620 Views
Last Modified: 2012-05-10
I get the above message when I try to access a shared network drive between two newly installed Win7 Pro machines.  

I can see the drive, it is a permissions problem.

These are on a "Work" network, so I can't use Homegroups-which I am trying to stay away from anyway.

All Network settings are set per Windows help.
0
Comment
Question by:JohnGalt22
  • 21
  • 20
  • 10
  • +1
55 Comments
 
LVL 7

Expert Comment

by:GridLock137
ID: 33553309
Have you checked the UAC - User Access Control and tried to disable that feature?
0
 

Author Comment

by:JohnGalt22
ID: 33553329
Do you mean set the slider to the bottom (least secure), or disable it entirely?
0
 
LVL 20

Expert Comment

by:woolnoir
ID: 33553333
you have two sets of permissions, the share permissions and the file level permissions, are both set appropriately to grant access ?
0
 
LVL 11

Expert Comment

by:mattibutt
ID: 33553370
common cause of this error due to authentication if you try to setup a share location did it ask you for a password of the other computer have supplied correct login details
0
 

Author Comment

by:JohnGalt22
ID: 33553374
I assume "share" permissions are set in the "Network  and Sharing" center?

Where are "file level" permissions set?  For EACH Drive or Folder in Windows Explorer?  Oh, brother.......
0
 
LVL 7

Expert Comment

by:GridLock137
ID: 33553377
I agree with with 33553333 those would need to be checked as well. Windows 7/2008 are built on tighter security where you would have to remove the security features you don't want to user versus XP where you have to add the security features you want. Out the box these OSs are kind of strict on security so the UAC and the share an file level permissions would have to be check. try disabling the UAC all the way as well as checking the permissions on the share and file level.
0
 
LVL 11

Expert Comment

by:mattibutt
ID: 33553378
you can access another computer drive unless it is setup as shared and their a share path also from other computer you need to say share with everyone
0
 

Author Comment

by:JohnGalt22
ID: 33553384
No it did not even get to the point of asking me for a Password.

Regarding passwords, I have used blank passwords for years with no problems across my networks.

Is 7 going to finally force me to change this?
0
 
LVL 7

Expert Comment

by:GridLock137
ID: 33553385
go to the machine you are trying to access over the network and check the share permission on that share folder/drive
0
 
LVL 11

Expert Comment

by:mattibutt
ID: 33553390
i setup a network with ms virtual pc on windows 7 it asked me for a password
0
 
LVL 20

Expert Comment

by:woolnoir
ID: 33553398
File permissions are defined on the folders, do a right click , properties on the folder you are trying to share and see what user permissions are defined. Remember just because you add user X to the share, they still need to have READ rights on the files as a minimum. On the plus side, generally if you add userX to READ on folder Y, then all the files in folder Y will also have those rights.
0
 

Author Comment

by:JohnGalt22
ID: 33553399

mattibutt:
you can access another computer drive unless it is setup as shared and their a share path also from other computer you need to say share with everyone

####

Yes, I made those basic settings under the Advanced options in Network Control Center.  Again this is a Permissions problem- the drive is showing up as Shared already.
0
 

Author Comment

by:JohnGalt22
ID: 33553408
"go to the machine you are trying to access over the network and check the share permission on that share folder/drive"



######

Full Control/Read/Change all checked as "allowed" for "Everyone" on shared network drive
0
 

Author Comment

by:JohnGalt22
ID: 33553413
I am already quite familiar with all of these network/sharing settings from years of 2000/XP/Vista.

Is this a blank password problem?

My user account on both machines is using a blank password.
0
 
LVL 20

Expert Comment

by:woolnoir
ID: 33553414
Dont get confused between the SHARE permissions, and the FILE permissions. The share permissions only apply to the people accessing over the network, but DONT avoid the need for file permissions. Ensure that the user has rights to the folder which youre trying to share (as in permissions on the FOLDER, ignore share for now). Once this is true (i.e EVERYONE read permissions to the folder) -> then add the share, and ensure everyone can read ( if you want everyone to that is).
0
 
LVL 7

Expert Comment

by:GridLock137
ID: 33553415
I've ran in to the same issue before, if all else fails dis-join the machine from the domain and re-join it again, make sure you leave all sharing settings as they are but as mittibutt said you have to make sure that the everyone group has full permission, if only certain users are to have access add those users individually and grant the full permission to each.
0
 
LVL 20

Expert Comment

by:woolnoir
ID: 33553421
@JohnGalt22 ok then, sorry it just seemed that replies were getting vague between file and share.
0
 
LVL 20

Expert Comment

by:woolnoir
ID: 33553427
Do either of the machines have the firewall enabled ? is there an entry in there to allow file&print sharing through ?
0
 
LVL 20

Expert Comment

by:woolnoir
ID: 33553429
And do you have a local account created on the machine you're trying to access with the name youre logged onto the local machine as, or are you trying something else in the username and password box ? If you want no username and password you may need the guest user.

Also do you have network discovery turned on in sharing centre ?
0
 
LVL 11

Expert Comment

by:mattibutt
ID: 33553431
restart the both computers please
0
 
LVL 20

Expert Comment

by:woolnoir
ID: 33553432
http://social.answers.microsoft.com/Forums/en-US/w7network/thread/14c9cf97-ac52-48bc-a730-284de284d353 <-- make sure you have followed all info in this article .. it seems complete and will ensure your all setup as per best practise.
0
 

Author Comment

by:JohnGalt22
ID: 33553446
Firewalls disabled, and yes both PCs have been rebooted multiple times.
0
 
LVL 20

Expert Comment

by:woolnoir
ID: 33553450
and network discovery is on ? and you have a local account on the other machine to connect with ?
0
 

Author Comment

by:JohnGalt22
ID: 33553456
woolnoir:
And do you have a local account created on the machine you're trying to access with the name youre logged onto the local machine as, or are you trying something else in the username and password box ? If you want no username and password you may need the guest user.

####

As mentioned above, it does not even get to the point of asking me for passwords.

0
 

Author Comment

by:JohnGalt22
ID: 33553462
and you have a local account on the other machine to connect with ?

####

I'm not sure I understand what you mean here.
0
 
LVL 20

Expert Comment

by:woolnoir
ID: 33553468
Who are you adding permission as, on the remote share, and local file system who are you allowing access ?
0
 

Author Comment

by:JohnGalt22
ID: 33553472
One basic setting that I have different from the cited article is that I have "Password Protected sharing" set to OFF.

Intuitviely, one would think that would make sharing a drive, EASIER.
0
Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

 

Author Comment

by:JohnGalt22
ID: 33553474
"Who are you adding permission as, on the remote share, and local file system who are you allowing access ?"


"Everyone"
0
 
LVL 20

Expert Comment

by:woolnoir
ID: 33553475
http://www.home-network-help.com/simple-file-sharing.html

so you have done as the article here suggets, setting guest permissions and everyone permissions ?
0
 

Author Comment

by:JohnGalt22
ID: 33553481
"so you have done as the article here suggets, setting guest permissions and everyone permissions ?"


####

"Everyone" has FULL control (All three options checked as "ALLOW")

I thought that was about as wide open as you could set it.

I have not ADDED a "guest" account.
0
 
LVL 20

Expert Comment

by:woolnoir
ID: 33553484
Is the guest user on or off ? try enabling it http://www.sevenforums.com/tutorials/7412-guest-account-turn-off.html see if that makes a difference.
0
 

Author Comment

by:JohnGalt22
ID: 33553490
That article is showing menus and screens I am not seeing.

Is it because it is discussing sharing a FOLDER, when I am trying to share a DRIVE?
0
 
LVL 11

Expert Comment

by:mattibutt
ID: 33553491
can you share a folder instead of a drive please and see what happens
0
 

Author Comment

by:JohnGalt22
ID: 33553527
Enabling Guest account did not help.

Sharing a folder results in the eexact same problem.

Folder is visible in the Network folder of the computer from which I am trying to access the folder, but I get the same permissions error.
0
 
LVL 20

Expert Comment

by:woolnoir
ID: 33553529
show me a screen shot of your FILE permissions for the drive youre trying to share.
0
 
LVL 11

Expert Comment

by:mattibutt
ID: 33553554
i think your network is not successfully setup and thats why its happening if the both pc on different groups then its likely that you will not be able to access the files
0
 

Author Comment

by:JohnGalt22
ID: 33553576
Screenshot per request.
Winows-7.png
0
 
LVL 20

Expert Comment

by:woolnoir
ID: 33553583
And the share permissions (sorry just checking)

Also - if you do a \\localmachine\sharename from the actual machine the share is on, does it allow you access ?
0
 
LVL 11

Expert Comment

by:mattibutt
ID: 33553584
john you need to put them in permission again in the image first one from right
0
 
LVL 20

Expert Comment

by:woolnoir
ID: 33553587
Actually they are the share permissions, not the file permissions... we need the actual permissions on the drive....
0
 
LVL 11

Expert Comment

by:mattibutt
ID: 33553589
you know in advance sharing window add everyone there
0
 
LVL 20

Expert Comment

by:woolnoir
ID: 33553592
I'm needing the file permissions as in the attached image ....
permissions.JPG
0
 
LVL 20

Expert Comment

by:woolnoir
ID: 33553597
Your screenshot looked very much like the file permissions -they look correct, but you need to add everyone to the C:\ permissions too... else they wont have any access to the drive. By default the EVERYONE user has no rights, so check the security tab....
0
 

Author Comment

by:JohnGalt22
ID: 33553602
"Actually they are the share permissions, not the file permissions... we need the actual permissions on the drive...."




These are from the drive.

Right click on C drive/Properties/Sharing.

These are the menus and sub-menus that result.

Is FILE sharing accessed somewhere else?
0
 
LVL 20

Accepted Solution

by:
woolnoir earned 500 total points
ID: 33553606
FILE permissions are accessed by right click drive -> Security, they are the file permissions i have been talkign about and they override anything on the share. By default everyone doesnt have access, only local users and authenticated users do, which could explain why your remote user cant get access.

go to the drive -> security -> and you will see permissions, add everyone as read if you want, but keep in mind the security concerns.
0
 

Author Comment

by:JohnGalt22
ID: 33553629
go to the drive -> security -> and you will see permissions, add everyone as read if you want, but keep in mind the security concerns.


#####


There is no "Everyone" in the security tab listing-just like your screenshot above.  USERS is already configured to READ, but I can't even do that.

Additionally, I am trying to log in as an Administrator from the other PC.  Administrators have FULL rights.

This is contradictory and confusing.
0
 
LVL 20

Expert Comment

by:woolnoir
ID: 33553638
Right thats the issue though, Users is LOCAL users on the machine your trying to access - why your not one of. Authenticated users is people who login, which your not. And admin your also not a member off.

There needs to be a everyone entry on the FILE permissions to allow you access.. thats why your having issues, traditionally only the admin accesses root drive shares like this... you need an extra permissions entry.

0
 
LVL 11

Expert Comment

by:mattibutt
ID: 33553639
did you do what i asked you to do if you click on advance sharing and then give permission there to everyone and tick all the boxes
0
 
LVL 20

Expert Comment

by:woolnoir
ID: 33553643
@mattibutt he has done that, check his screenshot.
0
 

Author Comment

by:JohnGalt22
ID: 33553646
did you do what i asked you to do if you click on advance sharing and then give permission there to everyone and tick all the boxes


####

It has been set that way since the beginning.

Did you not see the Screenshot above?
0
 
LVL 20

Expert Comment

by:woolnoir
ID: 33553653
John - a few questions

your logged into machine1 as admin, and accessing a share on machine2 with password sharing switched off.. therefore your NOT logging into machine2( where the share is) as admin.

If you add a everyone permission to C that should fix your issue. Its an unusual thing though,  generally when your using an admin (or know the admin details) you login as \\machine\c$ which is the admin share ?
0
 

Author Comment

by:JohnGalt22
ID: 33553694
"If you add a everyone permission to C that should fix your issue."


It did, and you will be getting the points.  Thanks very much.  I cannot remember the last time I had to dig around in those settings?  New to Vista/XP???

However, I am confused as to what is so unusual about what I am trying to do, and/or my configuration.

I log into both PCs as "Michael" with a blank Password.  I know using blank passwords is a a major no-no among IT Pros, but it has always been no problem for me with my micro (<20 PCs) networks.  Under XP, sharing was always simple.

So blank passwords and sharing entire drives is really THAT off the beaten path these days?

I am unsure as to what else I am doing wrong, and no I am not really too keen on doing the Everyone/Full Access sharing.
0
 
LVL 20

Expert Comment

by:woolnoir
ID: 33553704
You have turned password sharing off, the fact that you dont have a login box means that ( AFAIK ) it will be trying to use no authentication i.e the standard C drive permissions wont work.

Also... you might want to try password sharing on, that might allow you to authenticate as michael on the remote machine...in which case you will evaluate as a member of the local users & admin groups and be given access... either way its worth a try :)

That or adding everyone :)
0
 

Author Comment

by:JohnGalt22
ID: 33553769
So in summary, if I understand you correctly, most of my "walk on the wild side" is from abstaining from the use of Passwords.  I mean I don't think I can " authenticate as michael on the remote machine" without one.

Basically, I should do like the rest of the PC universe, and should log in with a password and turn ON Password Sharing??

In any case, thanks for your stalwart assistance.
0
 
LVL 11

Expert Comment

by:mattibutt
ID: 33554722
i thought you were using the passwords lol anyhow
0

Featured Post

Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Suggested Solutions

So many times I have seen the words written in a question "if only I could show you" or " I know how hard it is for you since you can't see it" in any zone. That has inspired me to write about this tool in windows 7 called "Problem Steps Recorder…
Article by: Lee
Windows 7 Ultimate and Enterprise (and 2008 R2) introduced a new feature you may not be aware of - Boot from VHD.   Boot from VHD (or what Microsoft refers to asNative Boot allows you to install Windows to a VHD (Virtual Hard Disk) file that is t…
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
This Micro Tutorial will teach you the basics of configuring your computer to improve its speed. It will also teach you how to disable programs that are running in the background simultaneously. This will be demonstrated using Windows 7 operating…

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now