Trixbox/Asterisk Polycom 501e MWI

I'm running the latest Polycom Firmware available through Trixbox 2.8.0.4, and I notice that the MWI isnt working.  I read a lot on a number of sites and this one seems to make the most sense:

sip.cfg:
up.oneTouchVoiceMail="1"

phone1.cfg:
<msg msg.bypassInstantMessage="1">
   <mwi msg.mwi.1.subscribe="" msg.mwi.1.callBackMode="contact" msg.mwi.1.callBack="8500"/>
</msg>

The problem is that its manyally setting global configs for one extension, how do I put a wildcard in there that will fill in its own value?

I know I can manually enter this information on the Phones GUI, rather not have to do it for 400+ phones.
LVL 1
TestMonkeyAsked:
Who is Participating?
 
DrDamnitCommented:
When you change the callback mode to "registration" (not the number, but the WORD) it will use whatever the phone has been registered with as the callback.

So, extension 224 will call 224, extension 215 will call 215, etc...
0
 
DrDamnitCommented:
I am assuming that 8500 is the extension for that phone. If that is the case, then you don't use the "contact" callback mode. Use "registration" instead. When set to "registration", a call will be placed using this registration to the contact registered (i.e., the phone will call itself).

These are the default values, so you really shouldn't have to change them. If you do need to make modifications, then remove the lines from "phone1.cfg" and enter then into sip.cfg, which will propagate to all 400 phones.

sip.cfg is the "foundation" settings and phone1.cfg overrides (and adds to)  those settings. If you remove them from phone1.cfg, and add them to sip.cfg then all 400+ phones will have the same, centralized, universal configs for these settings.
<msg msg.bypassInstantMessage="1">
   <mwi msg.mwi.1.subscribe="" msg.mwi.1.callBackMode="registration" msg.mwi.1.callBack=""/>
</msg>

Open in new window

0
 
TestMonkeyAuthor Commented:
8500 is an example extension

msg.mwi.1.callBackMode="registration"

Right now its set to "224" which seems to be what trixbox sets it as, so change that to registration and it should work?
0
 
DrDamnitCommented:
Do you have an update? Did you get your answer?
0
 
TestMonkeyAuthor Commented:
I havent had a chance :(

Ill do it up tonight, I hope changing from 224 to registration works lol :)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.