IE8 will not delete browsing history on Windows 7 OS

I have windows7 premium operating system and IE8 as my browser.

I have tried to delete my browsing history by clicking Internet Options, delete all forms, password , history
I also tried to turn off all the AutoComplete checkboxes off and delete all the browsing history.
I have also set the days to keep history = 0

So if I delete the history using the above methods and then if I type in the URL I just visited that it stores the links that I have visited on that page.
How do I delete the browsing history
LVL 1
countrymeisterAsked:
Who is Participating?
 
Justin Pierce, CEH, CNDAConnect With a Mentor Cybersecurity EngineerCommented:
Hi,

 Please try this Start/Control Panel/System And Maintenance/Indexing Options/ Click Internet Explorer History/ click advanced/ click restore defaults.
0
 
ctpmn1Commented:
Download and run killbox.

The Recent URL's are saved in a different location than most of the other temp files.

Go to  www.killbox.net download it on the left hand side.
Run it, go to tools > delete temp files

Problem solved!

0
 
countrymeisterAuthor Commented:
MacGuy47
I managed to navigate to Indexing Options/ IE History
but In Windows7 there is no option to restore defaults. I have an option to delete and rebuild
So I clicked delete and rebuild

Not sure where restore defaults is, could not find it under the Advanced settings
There was also an option to change the location of the index, the current location is c:\ProgramData|Microsoft

Should I be deleting he history again
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
ctpmn1Commented:
If you want to do a full clear of all your temp files use killbox.
Windows builtin tools do skip some of the temp files you want to purge.
0
 
Justin Pierce, CEH, CNDACybersecurity EngineerCommented:
Hi Countrymeiser,

    Don't worry you have done the right thing, since there are really no differences for IE 8 on XP and Win7. Killbox is good to use, as the experts have posted, because it "kills" "in-use" services with IE 8. If you haven't already cleared our your "InPrivate" settings go to:  Safety on the browser/Delete Browsing History/ and selecting "InPrivate Blocking data"/ Click the Delete button on the bottom of the screen. Hope this helps.
0
 
jcimarronCommented:
Countrymeister--"So if I delete the history using the above methods and then if I type in the URL I just visited that it stores the links that I have visited on that page."
You have to reboot before finally deleting the History.
0
 
countrymeisterAuthor Commented:
jcimarron:

I never had to reboot before I could delete all my history and then hit on a page.
For example if I went to craigslist and then wen to the cities new york, new jersey, they show highlighted
If I delete the brosing history and hit the page agin those links that I visted should not be highlighted

This was working fine before, now it is not. Not sure how to fix this
0
 
jcimarronCommented:
countrymeister--"You have to reboot before finally deleting the History"
When you set the days to maintain History at 0, you have to reboot.  Otherwise History is keeping the info from the current day's activity.
Have you tried that?
0
 
countrymeisterAuthor Commented:
Killbox only deletes the files
0
All Courses

From novice to tech pro — start learning today.