Solved

Exchange 2007 Anti-Spam not working after RecoverServer Install

Posted on 2010-08-29
6
480 Views
Last Modified: 2012-05-10
I performed an Exchange 2007 RecoverServer Install after losing our server.  The install carried over the Anti-Spam agent settings from the old server.  I tried disabling and re-enabling everything.  I set up the server to receive the anti-spam updates and have restarted the transport service. I checked the event log and confirmed that the updates were downloaded and installed.   I also checked off "Block messages sent to recipients not in the Global Address List" on the Blocked Recipients tab of the Recipient Filtering Properties.  I have content filtering set up to delete messages with an SCL higher than 7.  

Yet I am still getting many spam emails and some of them from my own email address.  Can somebody please tell me what I am missing?
0
Comment
Question by:carilou
  • 4
  • 2
6 Comments
 
LVL 34

Expert Comment

by:Shreedhar Ette
ID: 33555524
Hi,

- Change the SCL Higher to 8.
- Restart the MSExchange Transport service.

After above changes,if it is working. Then revert the changes and check again.

Hope this helps,
Shree
0
 

Author Comment

by:carilou
ID: 33558738
I think you mean to reduce the SCL level, correct? Anyway I tried it and it did not work.  I then tried raising it, dropping it again, applying, disabling then re-enabling content filtering, and then again restarting the transport service. No luck.
0
 

Author Comment

by:carilou
ID: 33568040
I changed the content filter settings yesterday and I set it to:
Delete messages that have a SCL rating greater than or equal to 9
Reject messages that have a SCL rating greater than or equal to 7
Quarantine messages that have a SCL rating greater than or equal to 5 (I set up a mailbox specifically to receive the quarantined messages)

I am still getting a huge number of spam emails.
I have yet to receive a single email in the mailbox set up to receive quarantined messages.  

These are the content filter configuration details that I get when I do a get-contentfilterconfig from the shell:

Name                                           : ContentFilterConfig
RejectionResponse                     : Your message was rejected due to content it contained
OutlookEmailPostmarkValidationEnabled : True
BypassedRecipients                    : {}
QuarantineMailbox                     : spamadmin@domain.com
SCLRejectThreshold                    : 7
SCLRejectEnabled                      : True
SCLDeleteThreshold                    : 9
SCLDeleteEnabled                      : True
SCLQuarantineThreshold                : 5
SCLQuarantineEnabled                  : True
BypassedSenders                       : {}
BypassedSenderDomains                 : {}
Enabled                               : True
ExternalMailEnabled                   : True
InternalMailEnabled                   : False
AdminDisplayName                      :
ExchangeVersion                       : 0.1 (8.0.535.0)
DistinguishedName                     : CN=ContentFilterConfig,CN=Message Hygie
                                        ne,CN=Transport Settings,CN=First Organ
                                        ization,CN=Microsoft Exchange,CN=Servic
                                        es,CN=Configuration,DC=domain,DC=co
                                        m
Identity                              : ContentFilterConfig
Guid                                  : 105e63f9-b743-4af4-bb82-90fa3ab11326
ObjectCategory                        : domain.com/Configuration/Schema/ms-
                                        Exch-Message-Hygiene-Content-Filter-Con
                                        fig
ObjectClass                           : {top, msExchAgent, msExchMessageHygiene
                                        ContentFilterConfig}
WhenChanged                           : 8/30/2010 10:26:59 AM
WhenCreated                           : 2/29/2008 7:11:12 PM
OriginatingServer                     : domaincontroller.domain.com
IsValid                               : True

Can somebody please tell me if I'm missing something???
0
Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

 
LVL 34

Accepted Solution

by:
Shreedhar Ette earned 500 total points
ID: 33573828
Uninstall and reintall the Anti-Spam

http://www.petri.co.il/install-anti-spam-exchange-2007.htm
0
 

Author Comment

by:carilou
ID: 33586644
Thank you very much shreedhar! I don't know why it wasn't working before since everything looks exactly the same after the uninstall/reinstall as it did before.  But after I did the reinstall it starting working right away!
0
 

Author Closing Comment

by:carilou
ID: 33586647
Thanks!
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Disabling the Directory Sync Service Account in Office 365 will stop directory synchronization from working.
This article explains in simple steps how to renew expiring Exchange Server Internal Transport Certificate.
In this video we show how to create a Resource Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: Navigate to the Recipients >> Resources tab.: "Recipients" is our default selection …
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question