Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Problem with Frame Relay, i can't ping !!!

Posted on 2010-08-29
16
Medium Priority
?
730 Views
Last Modified: 2012-05-10
Hi,

I have setup 3 routers in a frame relay could in Boson, everything is good and i can get the "show frame-relay map" etc but i can't ping between the routers using RIP:

here is my configuration:

============================================
Router 1 :

!
Version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R1
!
!
!
ip subnet-zero
!
!
!
!
!
!
!
!
!
!
interface Serial1/0
 ip address 200.1.1.1 255.255.255.0
 bandwidth 1544
 encapsulation frame-relay
 frame-relay lmi-type CISCO
!
interface Ethernet1/0
 no ip address
 no ip directed-broadcast
 bandwidth 10000
 shutdown
!
interface FastEthernet0/0
 no ip address
 no ip directed-broadcast
 bandwidth 100000
 shutdown
!
!
router rip

 version 2
 network 200.1.1.0
 network 200.2.2.0
 network 200.3.3.0
!
ip classless
no ip http server
!
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
!
no scheduler allocate
end

=========================================

Router 2 :


!
Version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R2
!
!
!
ip subnet-zero
!
!
!
!
!
!
!
!
!
!
interface Serial1/0
 ip address 200.2.2.1 255.255.255.0
 bandwidth 1544
 encapsulation frame-relay
 frame-relay lmi-type CISCO
!
interface Ethernet1/0
 no ip address
 no ip directed-broadcast
 bandwidth 10000
 shutdown
!
interface FastEthernet0/0
 no ip address
 no ip directed-broadcast
 bandwidth 100000
 shutdown
!
!
router rip

 version 2
 network 200.1.1.0
 network 200.2.2.0
 network 200.3.3.0
!
ip classless
no ip http server
!
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
!
no scheduler allocate
end

==============================================

Router 3:


!
Version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R3
!
!
!
ip subnet-zero
!
!
!
!
!
!
!
!
!
!
interface Serial1/0
 ip address 200.3.3.1 255.255.255.0
 bandwidth 1544
 encapsulation frame-relay
 frame-relay lmi-type CISCO
!
interface Ethernet1/0
 no ip address
 no ip directed-broadcast
 bandwidth 10000
 shutdown
!
interface FastEthernet0/0
 no ip address
 no ip directed-broadcast
 bandwidth 100000
 shutdown
!
!
router rip

 version 2
 network 200.3.3.0
 network 200.2.2.0
 network 200.1.1.0
!
ip classless
no ip http server
!
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
!
no scheduler allocate
end

======================================================
0
Comment
Question by:david875
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 5
  • 3
  • +2
16 Comments
 

Author Comment

by:david875
ID: 33555766
anyone can help please?
0
 
LVL 4

Expert Comment

by:andrewglendean
ID: 33555874
I use BOSON too, I will see if I can replicate this. hold on dude.
0
 
LVL 4

Expert Comment

by:andrewglendean
ID: 33555895
if you type in "debug ip rip" what info do you get?
0
Get your Disaster Recovery as a Service basics

Disaster Recovery as a Service is one go-to solution that revolutionizes DR planning. Implementing DRaaS could be an efficient process, easily accessible to non-DR experts. Learn about monitoring, testing, executing failovers and failbacks to ensure a "healthy" DR environment.

 
LVL 4

Expert Comment

by:andrewglendean
ID: 33555901
also looking at your config, what's your interconnecting device?
0
 

Author Comment

by:david875
ID: 33556142
I have attached Screenshots for R1 R2 & R3, I'm using Router Series 3600 Model 3640

thank you
R1.GIF
R2.GIF
R3.GIF
0
 
LVL 12

Expert Comment

by:acl-puzz
ID: 33557052
Hi

i cant see frame-relay interface-dlci command there

on serial interfaces ru using multi-point FR or not?iam studying for CCNA i use Packet tracer and GNS3 i found them better than boson try them also :)

0
 
LVL 50

Accepted Solution

by:
Don Johnston earned 2000 total points
ID: 33558574
Your IP addressing is wrong. All the frame-relay interface need to be on the same network.

Try this:

Router 2
int s1/0
 ip address 200.1.1.2 255.255.255.0

Router 3
int s1/0
 ip address 200.1.1.3 255.255.255.0




0
 
LVL 4

Expert Comment

by:nuttytech
ID: 33561709
Ip addressing needs to be the same subnet and there is missing DLCI info in your config. Your provider should give you the DLCI info for each site and the ip subnetting is up to you.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 33561981
>...and there is missing DLCI info in your config

The DLCI does not have to be configured on the router. The router will discover any DLCI's when it receives the full status message from the Frame-Relay switch.
0
 

Author Comment

by:david875
ID: 33563583
Hi it WORKED when puting the router in the same subnet, i have some questions please:

1. Frame Relay plays like a LAN right ?
2. If it is like LAN, Can I put just Private IP address and Not public ?
3. if I let the configuration as it is, why the routers didn't find other networks using RIPv2?

@donjohnston:what DLCIs that are missing?

Thank you

0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 33563742
1)  not really.
2) yes, you can use private addresses.
3) you don't have any networks to advertise.

You're not missing any DLCIs.
0
 

Author Comment

by:david875
ID: 33563908
@donjohnston:

1) this is what a guy in test out videos said, he said frame relay looks like a private network in some sorts
2) but what about if i there a router in New york and another in Tokyo? how these routers can be attached by the service provider? and maybe private addresses will not work right ? because of distance we will need public addresses?
3) But already i had different networks 200.1.1.0/24 & 200.2.2.0/24 & 200.3.3.0/24 RIPv2 should put them in its routing table no?
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 33563973
1) Well, it is a private network. I just wouldn't say it was like a LAN.
2) Frame-Relay is a layer 2 protocol. IP addresses aren't part of service. Think of it like a really cheap leased line.
3) Routing protocols are used to advertise a network that is behind a router to other routers. If there was a network connected to the ethernet interface of router 1, you could use RIP to advertise that network to router 2 and/or 3. Your previous config was irrelevant since your IP addresses were wrong.

0
 

Author Comment

by:david875
ID: 33564055
and how the service provider in the USA for exemple can attach a router in newyork and a router in tokyo and another in Russia in a frame relay switch??
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 33564156
Because the provider has frame-relay switches that span the globe or they have interconnects with other frame-relay providers in other countries.

The point is this: Frame-Relay is a layer 2 carrier service that provides point-to-point service between locations. As the customer, all you (need to) know is that your office in New York has a PVC that connects to your office in Tokyo. What you do with that PVC (IP, IPX, Appletalk, IPv6) is entirely up to you. The carrier doesn't know (or care) what layer 3 protocol you're sending over that PVC. And likewise, you have no knowledge of exactly how they're getting your traffic from New York to Tokyo.
0
 

Author Closing Comment

by:david875
ID: 33564539
thank you alot for your information, very helpful
0

Featured Post

 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you are thinking of adopting cloud services, or just curious as to what ‘the cloud’ can offer then the leader according to Gartner for Infrastructure as a Service (IaaS) is Amazon Web Services (AWS).  When I started using AWS I was completely new…
Load balancing is the method of dividing the total amount of work performed by one computer between two or more computers. Its aim is to get more work done in the same amount of time, ensuring that all the users get served faster.
There's a multitude of different network monitoring solutions out there, and you're probably wondering what makes NetCrunch so special. It's completely agentless, but does let you create an agent, if you desire. It offers powerful scalability …
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …
Suggested Courses

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question