Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

How do I fix the DCOM error on all my workstations?

Posted on 2010-08-29
4
Medium Priority
?
885 Views
Last Modified: 2012-05-10
Hello All,

I keep getting the system event below on all my site workstations.

The application-specific permission settings do not grant Local Launch permission for the COM Server application with CLSID
{24FF4FDC-1D9F-4195-8C79-0DA39248FF48}
 to the user NT AUTHORITY\SYSTEM SID (S-1-5-18).  This security permission can be modified using the Component Services administrative tool.

I'd like to know if I missed something with the setup of my site server?
I only have on SCCM 2007 server on Windows 2003.
The SCCM service pack 2 has been installed.

Is there a way I can allow this server to launch applications remotely with the correct DCOM rights?

I have read loads of threads and know how to fix this error by going to the Component services and fixing the rights for the applications, but I can't do this for all my workstations.
This is frustrating the living daylights out of me...

Please help.
Thanks.
Ampletrix
PS - I can't find the SCCM 2007 Zone for this question?
0
Comment
Question by:Ampletrix
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
4 Comments
 
LVL 4

Expert Comment

by:netF
ID: 33555622
I am not very familiar with SCCM but why can't you just give the "Domain Computers" group DCOM rights?
0
 

Author Comment

by:Ampletrix
ID: 33555657
Hello netF,
Thanks for the reply.
I'm not sure I follow? Do I add the "Domain Computers" group into the Builtin / Distributed COM users group?
Ampletrix
0
 
LVL 4

Accepted Solution

by:
netF earned 1500 total points
ID: 33555684
I apologize I misread the original question.  If you are needing to set the DCOM permissions on all workstations then you can do this by GPO.

The path to the setting is  Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options that start with DCOM.
0
 

Author Closing Comment

by:Ampletrix
ID: 33563646
Thanks. I did point me in a direction. However - I think I need to put this question in the correct zone and also try and find out exactly why I need this to work or to get a work around.
0

Featured Post

Veeam Disaster Recovery in Microsoft Azure

Veeam PN for Microsoft Azure is a FREE solution designed to simplify and automate the setup of a DR site in Microsoft Azure using lightweight software-defined networking. It reduces the complexity of VPN deployments and is designed for businesses of ALL sizes.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Organizations create, modify, and maintain huge amounts of data to help their businesses earn money and generally function.  Typically every network user within an organization has a bit of disk space to store in process items and personal files.   …
ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
Video by: ITPro.TV
In this episode Don builds upon the troubleshooting techniques by demonstrating how to properly monitor a vSphere deployment to detect problems before they occur. He begins the show using tools found within the vSphere suite as ends the show demonst…
In this video, Percona Solution Engineer Dimitri Vanoverbeke discusses why you want to use at least three nodes in a database cluster. To discuss how Percona Consulting can help with your design and architecture needs for your database and infras…

670 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question