Packet Loss Between XP and Server 2008

Hello All.

I have recently deployed a new server running Server 2008. It is a DC as well as a File Server. It is running DNS as well as DHCP. The enviroment has another server in it running server 2003 which is also a DC as well as a Terminal Server. This client uses a VoIP set up that uses a client on the PC and a USB headset to answer the calls. The phone server software is installed on an XP machine.

After installing the new server, the PCs are apparently dropping calls and experincing lag in the software. The only thing in between the PCs and the server is a dumb 48 port switch.

Does anybody have any ideas as to a possible solution?
jmbowles01Asked:
Who is Participating?
 
GridLock137Connect With a Mentor Commented:
that could be your problem. usually you need to put voice traffic on a different vlan than your data traffic. i gether these are VoIP phones?
0
 
fluk3dCommented:
Try updating the NIC drivers to the latest ones, you can also try forcing the duplex speed to 100MB full/1GiG full

Please post back with updates.
0
 
MidnightOneCommented:
It's possible the hub is overloaded with broadcasts.
Given you've got a hub, hooking up a system and loading up Wireshark (http://www.wireshark.org) to get a look at the traffic should show what's going on.

In any event, I'd recommend changing to a smart switch just as a matter of course; where you're dealing with VoIP traffic the network's infrastructure has to be solid, and a hub can't provide that.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
kaskhedikar_tusharCommented:
Hello,

Check for the physical network connectivity & physical network devices.
Check from the server side, if any network related setting.

Regards,
Tushar Kaskhedikar
0
 
jmbowles01Author Commented:
Hello Guys. Thanks for the responses. The NIC drivers are up to date, and the server is set to 1GB Full. Purchasing a new switch is not an option.
0
 
GridLock137Commented:
try the following:

swap out the patch cable, swap out the ethernet cable at the PC and try setting the nic to auto-negotiate if on the switch side its set to auto. also try putting it on another port on the switch <-- try this first before the above. if it works then the port could be bad.
0
 
jmbowles01Author Commented:
This problem is on multiple PCs. None of the NICs are bad. The issue occured as soon as i deployed an new WIndows Server 2008 R2 DC.
0
 
jezwebCommented:
maybe you should really try to replace your hub with a switch. this is what we did from my previous job. we were using a hub then and replaced it with a switch and everything was fine.
0
 
GridLock137Commented:
i agree with jezweb you want to move to a switch instead of a hub, on a hub layer 1 device you have one broadcast domain and one collision domain meaning csma/cd is being used, machines literaly have to wait for their turn to transmit, which could result in dropped packets due to latency.
0
 
jmbowles01Author Commented:
We are runing a layer 2 switch. I do not see any packet loss between the DC and the PCs. Just between the Phone Server and the clients.
0
 
jmbowles01Author Commented:
It is a 48 port D-Link switch. It was purchased less than 2 months ago.
0
 
GridLock137Commented:
are they on different VLANs?
0
 
jmbowles01Author Commented:
They are on the same subnet, on the same LAN.
0
 
jmbowles01Author Commented:
The system includes VoIP phones which work great. The system also includes client software that can be installed on a PC and utilize a USB headset. The units with the USB headset are the ones dropping packets.
0
 
GridLock137Commented:
i had a similar issue with voip phones we recently got that were not designed to work on a different vlan than our data vlan, the phones are from Panterra networks, my users had the same problem with the usb head sets. if they use the phones directly they work well but if they attempt to make a call from the PC using the software and head set they experience dropped packets. unfortunately they do not work like the traditional voip phones using UDP, they work via our PCs using TCP. are your PCs connected to a VoIP phone like a cisco or avaya to request an IP and access the internet?
0
 
jmbowles01Author Commented:
They PCs are part of the domain, and recieve IPs and DNS from the 2008 Server. They have software from Altigen installed on each client, pointing back to the IP address of the Altigen server. All the information is supposed to just be routed via IP. Nothing fancy, which is why im at a loss for the packet loss. No pun intended.
0
 
GridLock137Commented:
ok so let's get a little more info here:

is the altigen software installed on a windows os server?
are the PCs connected to a voip phone or directly to the rj-45 connector on the wall?
is the d-link switch a managed switch, can you get into it via a web interface a see why it's dropping packets?
what are the ports set to on the switch: full or half duplex/100 or 10, auto-negotiate?
0
 
jmbowles01Author Commented:
The Altigen software is installed on a "server" running Xp Pro SP3.
The PCs are attached to via a cat5 to the wall which is ran to a patch ran to the switch.
the d-link is a dumb switch. Not managed.
Each port on the switch is a full gig. That being said, this problem was occuring before the switch was replaced.
0
 
GridLock137Commented:
are the machine's interfaces set to the same, 1gb?
0
 
jmbowles01Author Commented:
They are set to their maximum. Most are set to 100MB Full Duplex which is all they support. It does NOT appear to be a bandwidth issue.
0
 
GridLock137Commented:
put the switch down to full/100
0
 
GridLock137Commented:
save that config and reboot the switch
0
 
jmbowles01Author Commented:
I just took another look at the switch and it IS a managed switch. Sorry for that misinformation. I am going to try to decrease the switch down to 100 MB full.
0
 
jmbowles01Author Commented:
If it is any help, the switch is a DGS-1248T
0
 
GridLock137Commented:
shouldn't matter, they all operate at either 1gb, 100 or 10 - full, half or auto.
0
 
jmbowles01Author Commented:
It looks like all except for the 3 servers are running 100 MB Full
0
 
GridLock137Commented:
ther server's interfaces support 1gb yes?
0
 
jmbowles01Author Commented:
Yes. They are hard set at 1 GB Full as well.
0
 
GridLock137Commented:
ok, so now that all that's been done, can you test one of the PCs?
0
 
jmbowles01Author Commented:
It will have to wait until tomorrow. I will update it before lunch.
0
 
GridLock137Commented:
not a problem. i will look for you post. have a good one.
0
 
jmbowles01Author Commented:
You to man. THanks for your time.
0
 
jmbowles01Author Commented:
None of that did any good. Still losing packets. Anyone have any input?
0
 
GridLock137Commented:
thinking about it... i will post up tomorrow.
0
 
jmbowles01Author Commented:
Thanks Gridlock. I am looking forward to your post. As a side note, i did do what you asked to the switch. I also changed a few settings regarding anti-port flood utilities built into the switch and stuff. It made a huge difference. I am awarding you the points for the question, but if you have more ideas that might clear up the issue 100% please repost.

Thanks!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.