Solved

Exchange 2010 Management Console: Initialization failed

Posted on 2010-08-30
46
2,034 Views
Last Modified: 2012-05-10
I had Exchange 2010 Server installed fine, then a few weeks later I decided to install Terminal Server RDP, then after I restarted now I get "Exchange 2010 Management Console: Initialization failed"

Can anyone help.
0
Comment
Question by:NWCCSteve
  • 27
  • 18
46 Comments
 

Author Comment

by:NWCCSteve
ID: 33559185
Sorry I should have mentioned the OWA doesnt work now, which was working fine and the Exchange 2010console wont open up without the "Exchange 2010 Management Console: Initialization failed" error
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33559233
go into iis admin console and ensure your default web site is up and running
0
 
LVL 34

Expert Comment

by:Shreedhar Ette
ID: 33559259
0
 

Author Comment

by:NWCCSteve
ID: 33559273
It has a question mark next to it, then when I click start it comes up with an error saying "The website cannot be started, another website may be using the same port. I think it maybe something to do with the RDP Terminal server i setup, when I tried setting up RDPWeb which didnt work
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33559291
yes, look at all the sites configured
if there are any sites other than "Default Web Site", stop that site and start your Default and see if the issue goes away

you most likely need to modify the settings for one, the host header name is an option
0
 

Author Comment

by:NWCCSteve
ID: 33559322
There are 4 in total
Default             Stopped
Office scan     started
Smart Scan      started
SMEX Web site started
0
 

Author Comment

by:NWCCSteve
ID: 33559327
Stopped all and tried starting default still same error
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33559356
highlight Default Web Site and select Bindings from the action window
highlight http and select Edit
make sure that the values for this are unique (enter a hostname value used for OWA access)

you can also compare the values from the other three sites to ensure it is unique
0
 

Author Comment

by:NWCCSteve
ID: 33559381
We use https://server/owa is that what I typr or do I put in the FQDN, also should I be in the https and not the http
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33559420
you should be in the http
you'll want to do both, so have the first with server and add a second http binding with server.domain.com
0
 

Author Comment

by:NWCCSteve
ID: 33559439
I just noticed ther are 2 https sites in the bindings one has a * next to it
0
 

Author Comment

by:NWCCSteve
ID: 33559456
Actually the http has a * next to it, although there is only one http site in the bindings list though
0
 

Author Comment

by:NWCCSteve
ID: 33559482
The 2 https point to my SSL, and they both are the same SSL
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33559487
yes, and if multiple sites are configured with this binding config only one will start
by assigning a host header name, the binding becomes unique and will start
0
 

Author Comment

by:NWCCSteve
ID: 33559497
The https also say IP address unassigned although there is a drop down box and I can choose my servers IP which is in the list
0
 

Author Comment

by:NWCCSteve
ID: 33559631
Sort of progressed, the default starts, the OWA works internally but not from Outside, but the Exchange console still has the Initialization failed error
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33559632
0
 

Author Comment

by:NWCCSteve
ID: 33559687
Also get a OWA "There is a problem with the websites security certificate" which we werent  be getting before as we a have a UCC Cert installed, it does allow you to continue to the web page
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33559738
you'll need to add a second https for the fqdn
0
 

Author Comment

by:NWCCSteve
ID: 33559808
Ok, nearly done.

My error has gone from the Exchange Management console, all looks good.

My internal https://servername/owa works without the cert error.

Just one bit not working which is the Outside OWA https://domainname.com/owa, whereas it was before
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33559868
you'll want to have a host header name for https for both the internal url and external url configuration

run the following
Get-OwaVirtualDirectory -Server servername | fl *URL

make sure both values are created in IIS
0
 

Author Comment

by:NWCCSteve
ID: 33559899
I think I may have misunderstood the command as see below error

[PS] C:\Windows\system32>Get-OwaVirtualDirectory -Server servername | fl *URL
The term 'Get-OwaVirtualDirectory' is not recognized as the name of a cmdlet, function, script file, or operable
m. Check the spelling of the name, or if a path was included, verify that the path is correct and try again.
At line:1 char:24
+ Get-OwaVirtualDirectory <<<<  -Server servername | fl *URL
    + CategoryInfo          : ObjectNotFound: (Get-OwaVirtualDirectory:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33559937
from the exchange management shell on the server
Get-OwaVirtualDirectory -Server ServerName | fl *URL
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 

Author Comment

by:NWCCSteve
ID: 33559991
Still not quite right I typed in the management shell Get-OwaVirtualDirectory -Server server | fl *URL
as our server is called "server"

I also just tried Get-OwaVirtualDirectory -Server servername | fl *URL

both give the same error as before

The term 'Get-OwaVirtualDirectory' is not recognized as the name of a cmdlet, function, script file, or operable progra
m. Check the spelling of the name, or if a path was included, verify that the path is correct and try again.
At line:1 char:24
+ Get-OwaVirtualDirectory <<<<  -Server server | fl *URL
    + CategoryInfo          : ObjectNotFound: (Get-OwaVirtualDirectory:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException
0
 

Author Comment

by:NWCCSteve
ID: 33560047
Not sure if this means anything, from the event log.

Log Name:      System
Source:        Microsoft-Windows-HttpEvent
Date:          30/08/2010 11:54:05 PM
Event ID:      15301
Task Category: None
Level:         Warning
Keywords:      Classic
User:          N/A
Computer:      Server.tecservices.com.au
Description:
SSL Certificate Settings created by an admin process for Port : 0.0.0.0:443 .
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33560069
try typing get-owa
then hitting the <tab> key

if it doesn't autocomplete wth get-owavirtualdirectory then you are logged in with an account that doesn't have permissions
0
 

Author Comment

by:NWCCSteve
ID: 33560180
Not sure why, but I logged in under another Domain Admin users and it sort of worked the command came back with the following text, which is the correct domain and
Get-OwaVirtualDirectory -Server ServerName | fl *URL
Url             : {}
Exchange2003Url :
InternalUrl     : https://tecservices.com.au/owa
ExternalUrl     : https://tecservices.com.au/owa

     
 
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33560210
what error are external connections getting? with the fqdn configured for an https binding should do it
0
 

Author Comment

by:NWCCSteve
ID: 33560240
Just the normal Internet Explorer cannot display the webpage error
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33560265
look in the iis logs for error codes
make sure the traffic is hitting the site
0
 

Author Comment

by:NWCCSteve
ID: 33560271
I did notice the Powershell says "exchange 2003"

Exchange2003Url :
InternalUrl     : https://tecservices.com.au/owa
ExternalUrl     : https://tecservices.com.au/owa
0
 

Author Comment

by:NWCCSteve
ID: 33560286
Where do I find the iIS Logs
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33560313
c:\inetpub\logfiles\logs\w3svc1

you need to get the site number from iis, but default should be 1
0
 

Author Comment

by:NWCCSteve
ID: 33560341
Dont have a C:\inetpub folder
0
 

Author Comment

by:NWCCSteve
ID: 33560376
Sorry, i must be getting tired. I found the logfiles and there are heaps of them,
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33560386
in iis manager
highlight the default web site and double-click logging
it should show the path
0
 

Author Comment

by:NWCCSteve
ID: 33560394
I have todays open, but there is a lot of text in it
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33560395
go with the current log yymmdd
0
 
LVL 32

Accepted Solution

by:
endital1097 earned 500 total points
ID: 33560410
search for /owa until you find an external ip as the source
0
 

Author Comment

by:NWCCSteve
ID: 33560528
Hard work, all I can seem to find is internal IPs
0
 

Author Comment

by:NWCCSteve
ID: 33560578
Cant find my ip in any of the log, i searched for 208 which was part of my ip, i did find another user from earlier today who had a 208 in his ip, but not my own, what might that mean
0
 

Author Comment

by:NWCCSteve
ID: 33560606
Not sure if this is relevent, but earlier I was reading that Exchange 2010 on Server 2008 should have the Firewall disabled which I did about 4 hours ago, just thought I would mention it.
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33560727
the original issue was the default web site being offline
now it is trying to connect by using the host headers

i would guess that your external connections are going to another site on that server
is it possible to stop the Office scan, Smart Scan, and SMEX Web sites and remove the host headers from Default

i want to see this Default site work as expected
0
 

Author Comment

by:NWCCSteve
ID: 33560736
endital1097:

Thankyou so much for everything you have advised me on. It has been a real experience and a pleasure receiving you advice. I just hope one day I can repay you.

I turned the Firewall back on and all is good.

I am so releived as I have end users that would have been on the phone to me tomorrow.

Thankyou once again
0
 

Author Closing Comment

by:NWCCSteve
ID: 33560753
An absolute champion, who new exactly what he was talking about.

Thanks Again
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33560765
great news and thanks for the compliment
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

Disabling the Directory Sync Service Account in Office 365 will stop directory synchronization from working.
Marketers need statistics and metrics like everybody else needs oxygen. In this article we explain how to enable marketing campaign statistics for Microsoft Exchange mail.
In this video we show how to create a Contact in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Contact ta…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now