Time Synchronization on Hyper-V VM DC

Scenario:
HOST- IBM x3550 server
Server 2008 R2 w/ Hyper-V role only

VM- Server 2008 R2 DC (the only DC)

All clients in the network are accurately sync'ing time with the DC. The issue is that the DC keeps falling behind. Loses about 1 sec/min. I edited the registry to tell the DC to sync with an internet time source, but it was still falling behind. Then I de-selected the Time Synchronization option the the VM in the host Hyper-V manager, since I thought that might be a conflict, but it seemed to get worse.

Currently, w32tm status on each is:
Host-
C:\Users\administrator.[domainname]>w32tm /query /status
Leap Indicator: 3(last minute has 61 seconds)
Stratum: 0 (unspecified)
Precision: -6 (15.625ms per tick)
Root Delay: 0.0312500s
Root Dispersion: 16.0100000s
ReferenceId: 0x00000000 (unspecified)
Last Successful Sync Time: 8/18/2010 2:03:09 PM
Source: Free-running System Clock
Poll Interval: 10 (1024s)

Open in new window


VM-
C:\Users\administrator.[domainname]>w32tm /query /status
Leap Indicator: 3(last minute has 61 seconds)
Stratum: 0 (unspecified)
Precision: -6 (15.625ms per tick)
Root Delay: 0.0312500s
Root Dispersion: 16.0100000s
ReferenceId: 0x00000000 (unspecified)
Last Successful Sync Time: 8/18/2010 2:03:09 PM
Source: Free-running System Clock
Poll Interval: 10 (1024s)

Open in new window


What is the best (most reliable) configuration for this scenario?
LVL 3
wmcdon7160Asked:
Who is Participating?
 
Darius GhassemConnect With a Mentor Commented:
The time sync with the Host computer should not be checked this will cause the time issues.

Import this reg file this will configure all settings for you.

http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/2003_Server/Q_23630502.html
0
 
geniphConnect With a Mentor Commented:
On my virtual DCs, I turned off both the time service in the Integration services, and also disabled the Hyper-V Time Synchronization, then I stopped getting time service errors and the VDC's quit losing or gaining time.
0
 
wmcdon7160Author Commented:
Thanks to both of you. I left the integration services enabled , but also left the VM to get time from an internet source. It seems to be working now.
0
 
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
Are any of your DCs on physical boxes? If they are then set them up to pull time from pool.ntp.org. Then set up your hosts and guests to pull from that DC. Allow firewall exceptions for NTP inbound on that DC.

If all DCs are VMs then set up one of the physical hosts to poll pool.ntp.org for time and then set the VMs to poll the host. Again set the firewall accordingly.

http://blog.mpecsinc.ca/2011/01/hyper-v-preparing-high-load-vm-for-time.html

We have had a lot of pain over the time skew situation for VMs.

The above methods work for us. In some cases we drop in an HP MicroServer with Win2K8 R2 running as a DC and set it up to poll pool.ntp.org and then have all VMs poll it for time.

The problem has to do with the polling frequency needed as indicated in the blog post. Do that to ntp.org's servers and they will pass along the Kiss-Of-Death packets basically killing the ability to poll their servers for time.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.