Solved

Alcatel IP phones (IP Touch 4028) working on Cisco PoE Switch

Posted on 2010-08-30
12
8,202 Views
Last Modified: 2012-05-10
Our company is using Alcatel IP phones and Alcatel switches, however, we have some spare Cisco PoE switches. I would like to reuse those switches in our network.

It looks like this:
                                                                            Trunk                                           Trunk
PC->Alcatel IP Phone->Cisco 2960 PoE switch --------->Alcatel Access switch----------->Core switch->PBX server

Data VLAN: 800
VoIP VLAN: 202

Below is the config on Cisco 2960 PoE switch:

interface FastEthernet0/24
 description Alcatel IP Phone + PC
 switchport access vlan 800
 switchport mode access
 switchport voice vlan 202
 spanning-tree portfast
 spanning-tree bpdufilter enable
 spanning-tree bpduguard enable
!
interface GigabitEthernet0/1
 switchport trunk native vlan 800
 switchport trunk allowed vlan 202,800
 switchport mode trunk
 switchport voice vlan 202
 spanning-tree portfast

Open in new window


If I maunally change the VLAN ID to 202 on IP Phone, everything is working fine. However, I would like to use DHCP for those IP phones. Phones should pick up IP from the PBX server. I try to setup option 176 on Cisco, but it doesn't work. IP phones are always getting IP from Data VLAN, not from VoIP VLAN? Any ideas how to get VoIP IPs for Alcatel IP phones?

Much appreciated!
0
Comment
Question by:JoeZ7
  • 6
  • 4
12 Comments
 
LVL 9

Accepted Solution

by:
Alex Bahar earned 500 total points
ID: 33566450
As I know, the port supports voice Vlan only when it detects Cisco IP phones via CDP. With a Cisco IP phone the port automatically turns into a dot1q trunk.
Unfortunately I couldn't find detailed info about 4028 on Alcatel site. But it says the phone has internal switch and VLAN management. So I assume it supports VLANS. So you need to set these switchports in static dot1q trunk mode.
In VLAN management menus, can you select the VLAN for PC port? That will be your access VLAN. If you cannot select it, I assume it goes untagged (native VLAN). The following configuration covers both cases.
Only trunk ports can carry multiple VLANs. Try the following>
switchport trunk encapsulation dot1q ! enable .1q tagging
switchport mode trunk ! tag frames with .1q tags
switchport trunk native vlan 800 ! untagged frames are in Vlan 800
switchport trunk access vlan 800 ! tagged data frames are in Vlan 800
switchport voice vlan 220 ! tagged voice frames are in Vlan 220
mls qos trust cos ! if it is marking COS bits, otherwise trust DSCP
Hope it works. Please let me know what you experience.
0
 

Author Comment

by:JoeZ7
ID: 33567654
Thanks for your reply, abahar:

I tried to re-configure on the C2960 as below, but it still doesn't work. The IP phone has been assigned a data IP address on it.

[code]
Thales_C2960#sh run int f0/24
Building configuration...

Current configuration : 264 bytes
!
interface FastEthernet0/24
 switchport access vlan 800
 switchport trunk native vlan 800
 switchport mode trunk
 switchport voice vlan 202
 mls qos trust cos
 spanning-tree portfast
 spanning-tree bpdufilter enable
 spanning-tree bpduguard enable
end
[/code]

Note: I cannot configure "switchport trunk encapsulation dot1q", since my Cisco switch only supports dot1q which is the default encapsulation protocol.
0
 
LVL 9

Expert Comment

by:Alex Bahar
ID: 33568164
Hmm.. Somewhere it says that voice vlan command is ignored on explicitly configured trunk ports. Can you try "switchport access vlan 202" instead?
Have you created those VLANS ? A VLAN does not become active until you put a switchport into this VLAN. Can you make sure the voice VLAN is UP ? Also verify the output of show interface xxx switchport command is showing the vlan 220 on that port..
I wish Alcatel had provided technical specs for this phone. We do not know how it works. On the 4028 >
  1. Have you enabled VLAN/trunk?
  2. Which VLAN did you configure for PC port?
  3. Which VLAN did you configure for Voice?
The best way to understand what 4028 sends to network is capturing the packets using a sniffer like wireshark in promiscous mode. Do you want to give it a try? You need to configure port monitoring (SPAN) and use wireshark to capture packets 4028 is sending for DHCP. Hopefully we wil be able to see the ethernet frame header and whether 4028 is really tagging the ethernet frames as dot1q or just sending everything in the native access VLAN (untagged).
0
 

Author Comment

by:JoeZ7
ID: 33569369
Once I do the command:  "switchport access vlan 202", the phone is working but PC connected to IP phone doesn't work any more.

--------------------------------------
Have you enabled VLAN/trunk?
--------------------------------------
Yes, manually change the VLAN ID on IP Phone, both IP phone and PC are working perfectly.
==============================================================================

-----------------------------------------------------
Which VLAN did you configure for PC port?
-----------------------------------------------------
VLAN ID (for data) is 800

interface FastEthernet0/24
 switchport access vlan 800
 switchport mode access
 switchport voice vlan 202
 mls qos trust cos
==============================================================================

-----------------------------------------------------
Which VLAN did you configure for Voice?
-----------------------------------------------------
VLAN ID (for VoIP) is 202
0
 
LVL 9

Expert Comment

by:Alex Bahar
ID: 33572993
Hi I am somewhat lost now. But I feel we are getting there.
>Once I do the command:  "switchport access vlan 202", the phone is working but PC connected to IP phone doesn't work any more.
>Yes, manually change the VLAN ID on IP Phone, both IP phone and PC are working perfectly.
 Based on your last configuration:
interface FastEthernet0/24
 switchport access vlan 800
 switchport mode access
 switchport voice vlan 202
 mls qos trust cos
What is working, what is not working?
If your phone is working in VLAN 202 as expected, but your PC is not working, then configure the PC port VLAN (on your phone) for VLAN 800.
If your phone does not allow you to configure the PC port VLAN, then on your Cisco switch configure the native Vlan 800.
switchport trunk native vlan 800
0
Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

 

Author Comment

by:JoeZ7
ID: 33577332
Based on below configuration:
==========================
interface FastEthernet0/24
switchport access vlan 800
switchport mode access
switchport voice vlan 202
mls qos trust cos
==========================
PC is working, IP phone is not working.

Based on below configuration as your suggestion:
==========================
interface FastEthernet0/24
switchport access vlan 202
switchport mode access
switchport voice vlan 202
mls qos trust cos
==========================
Phone is working, but PC doesn't work, since the data VLAN (800) is not configured on the interface.

Based on below configuration:
==========================
interface FastEthernet0/24
switchport trunk native vlan 800
switchport trunk allowed vlan 202,800
switchport mode trunk
switchport voice vlan 202
mls qos trust cos
==========================
PC is working, but IP phone is not working.

I tried different configs on Cisco switch. Without manually changing the VLAN ID on IP hone, I cannot make both phone and PC working at the same time.
0
 
LVL 9

Assisted Solution

by:Alex Bahar
Alex Bahar earned 500 total points
ID: 33577770
> Without manually changing the VLAN ID on IP hone, I cannot make both phone and PC > working at the same time.
Automatic configuration of phone voice Vlan works only with Cisco phones. The switch tells the Cisco phone to use Voice VLAN XXX using CDP protocol. Your Alcatel phone Voice VLAN has to be manually configured on the phone.
0
 

Author Comment

by:JoeZ7
ID: 33579881
One of my friends sent me an Email: "I did some research and there is a way to set up an auto vlan assignment on alcatel pcx,on the cisco switch the ip helper has to be setup on the default vlan as well"
0
 
LVL 9

Expert Comment

by:Alex Bahar
ID: 33667649
Why is this question marked as "no answer"?
The original question is about getting Alcatel voip phones working on Cisco switch.
I thought we agreed that manual configuration works. The asker confirmed in his second last question "Without manually changing the VLAN ID on IP hone, I cannot make both phone and PC working at the same time.".

My first commented started with "the port supports voice Vlan only when it detects Cisco IP phones via CDP." and my last comment ended with "Your Alcatel phone Voice VLAN has to be manually configured on the phone.".
In his last email he is referring to one of his friend's claim that  "there is a way to set up an auto vlan assignment on alcatel pcx". Asker did not provide the working configuration. The question is not about how to get automatic VLAN assignment working.
Additional note> His friend's both claims are incorrect.
  1. "cisco switch the ip helper has to be setup on the default vlan as well ".  No. ip helper is required only when crossing the L2 boundary for DHCP. In a switched network it is not required, and it is nothing to do with automatic voice  VLAN configuration. IP helper is configured on a router's default gateway interface, it is not configured on a switch. If manualling configuring the VLANs work fine, this means IP helper is not required anyway. His friend's suggestion has too many mistakes to believe.
  2. " there is a way to set up an auto vlan assignment on alcatel pcx" . In order to achieve that Alcatel phone has to run Cisco proprietary protocol CDP and it has to understand the Voice VLAN configuration it receives from Cisco switch. In his first reply he already had the automatic VLAN configuration command "switchport voice vlan 202" and it didn't work.
The asker did not follow my advice either. He didn't provide the output of "show interface xxx switchport" and "Wireshark captured DHCP packets" to let us understand what exactly is hapenning on the switchport.
I am disappointed and annoyed with the result.
0
 
LVL 9

Expert Comment

by:Alex Bahar
ID: 33667968
Also the ZONE for this question is incorrect. Instead of zone Windows 2000, it should be in somewhere like Networking>Telecommunications>IP Telephony>Voice Over IP.
0

Featured Post

Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

Join & Write a Comment

Hey there Heard about jingle, the add on for XMPP that enables point to point audio between two XMPP clients. No server config necessary. Actually quite a cool feature. However, how good is it if you can not use those voice capabilities to do a P…
Security is one of the biggest concerns when moving and migrating your data from your on-premise location to the Public Cloud.  Where is your data? Who can access it? Will it be safe from accidental deletion?  All of these questions and more are imp…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now