Solved

SBS 2008 exchange SMTP connector issue

Posted on 2010-08-30
38
1,149 Views
Last Modified: 2012-06-27
I have an SBS 2008 server set up to retrieve POP3 email from an outside domain. The POP3 works fine on receive and the workstations Outlook is working perfectly to retrieve the email.

I don't think I have the SMTP connector set up right. They get emails back with this below when they send from their workstations.

#550 4.4.7 QUEUE.Expired; message expired in unreachable destination queue. Reason: A matching connector cannot be found to route the external recipient ##

Thank you in advance for your help!

I should mention that I do not believe I need a smart host.  When I configure the POP3 email right on the workstation only I do not need anything to do with the ISP.
0
Comment
Question by:dgrenda
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 17
  • 15
  • 3
  • +1
38 Comments
 
LVL 11

Expert Comment

by:mattibutt
ID: 33560195
is your pop service running is your firewall allowing port 110
0
 

Author Comment

by:dgrenda
ID: 33560222
they need 995 and the pop service is running. They can receive email fine through exchange.
0
 
LVL 4

Expert Comment

by:Jamie_Wilson
ID: 33560224
If your exchange server is pop collecting, how are you linking the workstations to exchange? via the exchange button in outlook or via pop3?
0
Guide to Performance: Optimization & Monitoring

Nowadays, monitoring is a mixture of tools, systems, and codes—making it a very complex process. And with this complexity, comes variables for failure. Get DZone’s new Guide to Performance to learn how to proactively find these variables and solve them before a disruption occurs.

 
LVL 11

Expert Comment

by:mattibutt
ID: 33560233
have enabled exchange anywhere
0
 

Author Comment

by:dgrenda
ID: 33560259
Jamie - I set up the email account in outlook using the exchange server option and it set up successfully.  I do not have POP3 set up on the workstations.

matt - Why is that important?  I am asking.
0
 
LVL 13

Expert Comment

by:markusdamenous
ID: 33560263
The POP3 connector is being used to download mail into Exchange from an externally hosted POP3 account.  Exchange 2007 does not know by default how to route outgoing email.  You need to create a SEND connector - this could either be a SMARTHOST to your ISP SMTP servers, direct to the internet via DNS.
0
 
LVL 4

Expert Comment

by:Jamie_Wilson
ID: 33560264
Disable it for now, and connect directly to exchange internaly, see if you get the same problem

also, can nslookup the domain you are trying to send mail to on the exchange server?
0
 
LVL 11

Expert Comment

by:mattibutt
ID: 33560267
just ruling out all the possiblities the last one is not that relevant
0
 
LVL 13

Expert Comment

by:markusdamenous
ID: 33560282
0
 
LVL 4

Expert Comment

by:Jamie_Wilson
ID: 33560283
@markusdamenous

SBS has a default send connector
0
 

Author Comment

by:dgrenda
ID: 33560295
Mark - Yes I think I just need to set up the SMTP side....I don't need the smart host thing I don't think.  Where do you do this?

Jamie - can you explain nslookup?  Sorry.
0
 
LVL 4

Expert Comment

by:Jamie_Wilson
ID: 33560328
by nslookup, i meant to make sure your exchange server can find the mx record of the domain you are trying to send to as the default SBS send connector uses DNS to find the domain

and to test it, here is a link:

http://surf11.com/entry/84/how-to-do-mx-lookup-windows

0
 

Author Comment

by:dgrenda
ID: 33560616
Ok, in the Hub Transport section I see the default Internet Send connector and I have the "*" in the address.

Do I need to set up a seperate specific SMTP connector for the SMTP computer I want to route outbound email through?
0
 
LVL 4

Expert Comment

by:Jamie_Wilson
ID: 33560757
You shouldn't need a separate SMTP connector.

Will nslookup work for MX?  
0
 

Author Comment

by:dgrenda
ID: 33560762
Jamie it does see the MX record of the domain.
0
 

Author Comment

by:dgrenda
ID: 33560820
Ok, so the default SMTP connector should be the only one I need? The seperate one I set up is not necessary?

And "*" is in the address space?

How does Exchange know which SMTP server I want my email routed through then?

Maybe tell me how to set up the default send connector.
0
 
LVL 4

Expert Comment

by:Jamie_Wilson
ID: 33561195
no, there is no need for a 2nd one.

the default one should look like:

Address Space:

Type:
SMTP

Address:
*

Cost:
1

Network:
Use DNS "MX" Records to rout mail automatically with Enable Domain Security not ticked

Sorce server;

Should be its self

as for your question on which smtp will be used, that is what the address space is for, but as it is * everything will go through it
0
 

Author Comment

by:dgrenda
ID: 33561223
Ok I understand. But the SMTP server their email should be going through belongs to an outside domain. So the SMTP server name is  smail.xxx.com

So if the user sends an email to joe@abc.com  how does Exchange know to route that outbound email through the specific SMTP server smail.xxx.com?

Isn't there someplace I should be specifying smail.xxx.com?


Sorry for all this. I REALLY appreciate the help.
0
 
LVL 13

Expert Comment

by:markusdamenous
ID: 33561945
The * in the SMTP connector your end, is the only connector in place.  Therefore, the xxx.com domain fits into the scope of that connector.  That connector is configured to use DNS to route email, so it does the MX lookup and sends it there.

I didnt realise that Exchange 2007 under SBS 2008 auto creates a send connector, apologies.
0
 
LVL 4

Expert Comment

by:Jamie_Wilson
ID: 33562254
did you go through the setup your internet address section of the sbs wizard?
0
 

Author Comment

by:dgrenda
ID: 33562345
Jamie - no I did not.

Why is that important?  
0
 
LVL 4

Expert Comment

by:Jamie_Wilson
ID: 33562369
That configures half of exchange for you.

I recommend you run through that and see if you have the same issues
0
 

Author Comment

by:dgrenda
ID: 33562426
They use a completely outside domain for their email that is hosted someplace else.

I do not have control of the domain. I only know the email account settings and domain mailbox usernames and paswords.

DO I still run the wizard?  And do I pick "manage myself"  or  "let server manage"
0
 
LVL 4

Expert Comment

by:Jamie_Wilson
ID: 33562464
You will need to run the wizard to add the domain into exchange, this is for the 'reply to' email address if nothing else

pick manage myself (this will assume that the mx record will point to the server but will be receiving mail via a pop collect so doesn't really matter)
0
 

Author Comment

by:dgrenda
ID: 33562633
I rant the wizard and got all good except a warning about SBS not being able to open ports 80, 25, 443, 987. I opened them on the linksys router and re-ran the wizard but still get the warning.

suggestions?


thanks for hanging in with me.
0
 
LVL 4

Expert Comment

by:Jamie_Wilson
ID: 33562639
Dont worry about that (its allways said that for me)

do you get the same problems when sending mail now?
0
 

Author Comment

by:dgrenda
ID: 33562721
Yes. I can send the email from the workstation and it appears to go. It just never shows up at the destination.

I am not getting kick back messages any more. It just doesn't show up. I am emailing my own email account at my own domain from the workstation on the network. I am logged in remotely.
0
 

Author Comment

by:dgrenda
ID: 33562776
This whole thing sucks green donkey nuts.
0
 
LVL 4

Expert Comment

by:Jamie_Wilson
ID: 33562805
Try rebooting the server now you have made the change (stop the information store 1st)

I whould RDP on to the server instead of using outlook anywhere as that could be causing the problem?
0
 

Author Comment

by:dgrenda
ID: 33562828
I am using LogMeIn. So it's not outlook anywhere.

I appreciate all your help man.  What time do you have to quit helping me for the day?  I am in Phoenix, AZ  it is 2PM here.

I will restart the server.
0
 
LVL 4

Expert Comment

by:Jamie_Wilson
ID: 33562862
log me in onto the server its self?
0
 
LVL 4

Expert Comment

by:Jamie_Wilson
ID: 33562869
And i have around 20 min
0
 

Author Comment

by:dgrenda
ID: 33562906
The product LogMeIn  is how I support the machines. I am at my office and can have all the machines in front of me at once.

THank you very much. I will keep working on this and update you with what I find.

I wish I could hand out more than the 500 points.
0
 
LVL 4

Expert Comment

by:Jamie_Wilson
ID: 33565048
How did it go?
0
 

Author Comment

by:dgrenda
ID: 33566436
Well, I could not get that connector to work. I left it a single connector, configured as you said ( "*", etc) . I ran the internet address wizard successfully except for the router errors.  When I send an email from the workstation it just leaves the Outlook outbox and never goes anywhere.

Curiously, when I change the connector to use an INVALID smarthost, I get relay reject kick back emails for ALL the emails I had previously sent but didn't go anywhere. It's like they were sitting in the outbound queue the whole time not getting sent...and then they all try an go with the invalid test smart host.

I ended up configuring each workstation to get it's own POP3 email while still using Exchange for the calendar, etc. It all looks the same to the user.

Any more ideas?
0
 
LVL 4

Accepted Solution

by:
Jamie_Wilson earned 500 total points
ID: 33567734
You should be able to set your ISP's smtp server as the smart host, try that
0
 

Author Comment

by:dgrenda
ID: 33567906
Yeah that was my next idea. I tried just using their SMTP server as the smart host but it was rejected. Around here the ISP are super uptight about spam so I need to track down the username and password for the settings.

I'm going to give you the points anyway because I appreciate the value of your advice and I did learn a lot.

If you don't mind my asking, I'm always interested in knowing what part of the world the folks who help me are from?  Are you in the US?

And one more thing I'm not sure I understand:

So you are saying that the connector is supposed to use the xxx.com DNS resolution of the SMTP server to know where the outbound email server is?  I did the telnet mx 25 thing for the DNS name of the mail server and it DID reply back that it found it.  So strange that the mail just isn't going.

0
 

Author Closing Comment

by:dgrenda
ID: 33568643
Thank you for your patience and assistance on multiple angles with this issue. Excellent work.
0

Featured Post

Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How to resolve IMCEAEX NDRs in Exchange or Exchange Online related to invalid X500 addresses.
Unified and professional email signatures help maintain a consistent company brand image to the outside world. This article shows how to create an email signature in Exchange Server 2010 using a transport rule and how to overcome native limitations …
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…

729 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question