[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

Mac cannot empty trash

Posted on 2010-08-30
10
Medium Priority
?
2,265 Views
Last Modified: 2012-08-13
When I try to empty the Trash, I get the following error message:

The operation can't be completed because an unexpected error occurred (error code -8003).

Individual items can be deleted from the Trash. However when doing so, even though the Trash then has smaller content, the available space on the disk does not increase.
0
Comment
Question by:jasimon9
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
10 Comments
 
LVL 1

Expert Comment

by:djadambomb
ID: 33561689
check the console right after you get the error and post it. how are you emptying the trash? did you try a secure erase?

I dont know how advisable it is, but have you tried deleting items from the terminal?
navigate to >cd /HD_volume/Users/<yourusername>/.Trash

From here you can do a  >rm -R *
to completely clear out the trash bin.

If you dont want to do that just yet, you can test the waters by listing the contents of the trash folder and picking a single file to delete, or using some regex to select particular files and see how that effects the amount of space the mac is reporting you have left on the volume.
0
 
LVL 10

Expert Comment

by:EdTechy
ID: 33561798
Try these directions and see if it solves it.
http://forums.cnet.com/5208-6126_102-0.html?threadID=365518
0
 

Author Comment

by:jasimon9
ID: 33561803
I guess I am too much a Mac newbie. Don't know what "check the console" means. Is there an error log or interface? Or do you mean a shell? I am a long-time shell user, so not afraid to try things there.

Before just rm -r, I would prefer to understand what the error is. I have tried a bit of searching on the web, and nothing jumps out easily.

For example, http://support.apple.com/kb/HT1618 and the pages linked at the bottom gives info on various error codes, but not on -8003.

Since I have AppleCare, I could open a ticket there, but I thought I would learn more by posting a question here.
0
[Webinar] Lessons on Recovering from Petya

Skyport is working hard to help customers recover from recent attacks, like the Petya worm. This work has brought to light some important lessons. New malware attacks like this can take down your entire environment. Learn from others mistakes on how to prevent Petya like worms.

 
LVL 22

Expert Comment

by:Sigurdur Armannsson
ID: 33561833
Here is one that will help you:


http://support.apple.com/kb/ht2963

Shows where Trash is and the commands you need to use.
0
 
LVL 18

Assisted Solution

by:jmeggers
jmeggers earned 300 total points
ID: 33563580
Did you play around with Time Machine and delete some files perhaps?  I've run into that myself.  Try an application called "Trash It".  That helped me.  http://www.macupdate.com/info.php/id/8214/trash-it!   Also http://discussions.apple.com/thread.jspa?threadID=2138034&tstart=30.
0
 

Author Comment

by:jasimon9
ID: 33568267
As I said above, I was hesitating to just simply rm -r to delete the files in Terminal until I found out what error -8003 meant. I finally opened a ticket with AppleCare. They escalated to a specialist, who had to do research and call me back, after consulting with her more technical resources. Turns out nobody in AppleCare knows what error -8003 is either, and they recommended the rm -r approach.

So I did that and naturally the files are gone from the Trash.

Regarding Time Machine: I did not to anything with Time Machine. However the problem does have a somewhat related aspect. I keep archival copies of Virtual Machines on the same external drive where the Time Machine backups are stored. I had deleted about 8 such 20GB files, which appeared in the Trash. When I tried to delete them from the Trash, instead of disappearing for good, in fact they were simply back on the external drive.

This suspicious behavior was also explained to AppleCare, but they did not have any explanation. But an obvious next step is to try to delete them again, which I have not done yet. So trying that yields the same situation. File is moved to Trash, but Empty Trash gives error -8003. I am going to check the information in the link for "Trash-It" to see if that sheds any light. If not, will call back on the AppleCare ticket and see if this helps them to know what is going on. As a final alternative, I may just use the shell to rm -r the files on the external drive, as that should blow them away, even if it does not explain exactly what is going on with the Trash failures.
0
 

Author Comment

by:jasimon9
ID: 33568733
I read the entire thread, and it was very interesting. Some people having the exact same experience, and nobody able to say what error -8003 is.

Since I have Onyx on my system, I tried the following as a test:
  1. Trash folder is empty at start of test, and the files I want to delete are on the external drive.
  2. Delete one file (a 21GB VM).
  3. The file appears in the Trash.
  4. Empty Trash gives the error -8003.
  5. Use Onyx to empty the Trash. It reports on many files being deleted, but in the Trash, the VM package file is still shown, but now with Zero KB size.
  6. Empty Trash normally, but file remains there.
  7. Repeating the Onyx Trash Empty function does not help.
  8. Next tried Trash-It to get rid of the Zero-KB file in the Trash. While it displayed some progress messages, it did not help on the Zero-KB file in the Trash.
  9. I wanted to try with another file, to see what happens to the reported disk space used. However, when trying to delete another file, I get error -1407. Natrually, this error code is not listed either on http://support.apple.com/kb/HT2237?viewlocale=en_US.
I am thinking I should Verify the external drive. So I will next use Disk Utility to Verify/Rebuild the drive and or volume. Will report back on that.
0
 
LVL 53

Accepted Solution

by:
strung earned 700 total points
ID: 33572099
Try doing a safe boot by booting while holding down the shift key. Then try to empty the trash and reboot normally.
0
 

Author Comment

by:jasimon9
ID: 33572624
The disk verify in Disk Utility said after running for 3-4 hours that "the disk appears to be OK."

Am in the middle of a long operation on a server, so when that finishes, I will try the safe boot.
0
 

Author Comment

by:jasimon9
ID: 33572753
The Safe Boot seems to have fixed it. I am guessing that corrective functions that are part of the Safe Boot were the key (although i had already done Rebuild Permissions, etc).

In any case, the ZeroKB file was gone.

So I decided to delete another file while in Safe Mode, then Empty the Trash. Worked fine, so I deleted 2 more this way and empited Trash. Still fine. Reboot into normal mode, and delete one and empty, then delete two and empty. Still all fine.

Plus, the expected recovery of disk space occurs.

Have to add this method to my arsenal of tricks. And strung gets credit for the answer, and partial points elsewhere for the useful information.
0

Featured Post

Enroll in October's Free Course of the Month

Do you work with and analyze data? Enroll in October's Course of the Month for 7+ hours of SQL training, allowing you to quickly and efficiently store or retrieve data. It's free for Premium Members, Team Accounts, and Qualified Experts!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Deploystudio is a system which can be used to deploy OSX clients and servers within the small/medium or large business environments. The system is built onto of the OSX Server NetBoot system and uses images & workflows as its core assets. While work…
Syslogd is a utility that traps and logs messages sent by running processes. It is configured with the syslog.conf file, which consists of lines containing a pair of fields: "the selector field which specifies the types of messages and priorities to…
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …
In this video, Percona Solution Engineer Rick Golba discuss how (and why) you implement high availability in a database environment. To discuss how Percona Consulting can help with your design and architecture needs for your database and infrastr…

656 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question