Solved

Not receiving "Password Expires in x days" message when logging into Windows Server 2008 R2 RDS Hosts.

Posted on 2010-08-30
5
3,355 Views
Last Modified: 2012-08-14
When I log into my Windows XP computer or any Windows Server 2003 machine with my domain account, I get a warning saying my password will expire in so many days. However, any Windows Server 2008 R2 computer does not display the warning when I log in. I use Windows Server 2008 R2 for Remote Desktop Services for my users so when they log in, I want it to allow them to change their password if it is close to expiring. Any idea why I might not be getting this message when I log into Windows Server 2008 R2 machines?
0
Comment
Question by:CanyonTech
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
5 Comments
 
LVL 3

Expert Comment

by:flubbard
ID: 33562820
Do you know if the passwords are set to expire in Active Directory?

  - flub
0
 
LVL 5

Expert Comment

by:DanMar
ID: 33567270
Check this key in group policy:
Computer Configuration>Windows Settings>Security Settings>Local Policies>Security Options>Interactive Logon: Prompt user to change password before expiration

0
 

Author Comment

by:CanyonTech
ID: 33568299
flubbard,
I know they are set to expire in A/D because when I log into a Windows XP or Windows Server 2003 machine, it warns me and asks me if I want to change it now. But Windows Server 2008 machines do not.

DanMar,
The Policy setting you mentioned is not defined, which from what I can tell, means it is defaulted to 14 days. As mentioned to flubbard, it doesn't appear to be a GPo issue since it works properly on 2003 and XP machines.
0
 
LVL 5

Expert Comment

by:DanMar
ID: 33574652
This setting may not activate on W2K8 without the GPO defined.  You can enable it & test.
0
 

Accepted Solution

by:
CanyonTech earned 0 total points
ID: 33685747
The local policies on the servers were set to 5 days by default, which is fine. Apparently, that's the default for W2k8. Thanks for the help.
0

Featured Post

Optimizing Cloud Backup for Low Bandwidth

With cloud storage prices going down a growing number of SMBs start to use it for backup storage. Unfortunately, business data volume rarely fits the average Internet speed. This article provides an overview of main Internet speed challenges and reveals backup best practices.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

No single Antivirus application (despite claims by manufacturers) will catch or protect you from all Virus / Malware or Spyware threats. That doesn't stop you from further protecting yourself however - and this article is to show you how.
The Windows functions GetTickCount and timeGetTime retrieve the number of milliseconds since the system was started. However, the value is stored in a DWORD, which means that it wraps around to zero every 49.7 days. This article shows how to solve t…
Windows 8 came with a dramatically different user interface known as Metro. Notably missing from that interface was a Start button and Start Menu. Microsoft responded to negative user feedback of the Metro interface, bringing back the Start button a…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…

742 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question