• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 876
  • Last Modified:

Excahnge 2007 Outlook Anywhere (RPC over HTTP) test fails

Hi,

I am getting the following error:
       The HTTP authentication test failed.
       
      Additional Details
       Exception details:
Message: The underlying connection was closed: The connection was closed unexpectedly.
Type: System.Net.WebException
Stack trace:
at System.Net.HttpWebRequest.GetResponse()
at Microsoft.Exchange.Tools.ExRca.Tests.HttpAuthMethodsTest.GetSupportedHttpAuthMethods()
at Microsoft.Exchange.Tools.ExRca.Tests.HttpAuthMethodsTest.PerformTestReally()

Using: testexchangeconnectivity.com

Initially I have enabled outlook anywhere without installing rpc over proxy then I installed it and started to get this error.

How can I resolve this. Using server 2003 R2.
Thanks
0
masdf123
Asked:
masdf123
  • 9
  • 4
  • 3
  • +2
4 Solutions
 
endital1097Commented:
review this article to ensure you have the autodiscover service configured appropriately
http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_3585-Exchange-Autodiscover-Service-OOF-and-OAB.html
0
 
masdf123Author Commented:
The autodiscover test is passing fine
0
 
BusbarSolutions ArchitectCommented:
after installing the RPC you need to reconfigure outlook anywhere
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
masdf123Author Commented:
You mean disable and reenable? I have done that.
0
 
endital1097Commented:
you need to run the Enable-OutlookAnywhere cmdlet (or from GUI)
0
 
BusbarSolutions ArchitectCommented:
ok do you have the public name used to configure the outlook anywhere in the certificate assigned to the IIS
0
 
masdf123Author Commented:
Problem is similar to this:
http://terenceluk.blogspot.com/2010/07/outlook-anywhere-message-underlying.html

But the solution doesn't seem to work.

Currently, Anonymous is enabled and basic authentication. I have tried enabling Integrated Windows Authentication, that does fix either.
0
 
endital1097Commented:
post the results for Get-OutlookAnywhere | fl
0
 
masdf123Author Commented:
yes, I assigned, owa.domain.com and thats in the SSL, and I use that for OWA as well.
0
 
masdf123Author Commented:
[PS] C:\Documents and Settings\Administrator>Get-OutlookAnywhere | fl


ServerName                 : EXH1
SSLOffloading              : False
ExternalHostname           : owa.domain.com
ClientAuthenticomtionMethod : Basic
IISAuthenticomtionMethods   : {Basic}
MetabasePath               : IIS://exh1.domain.LOcomL/W3SVC/1/ROOT/Rpc
Path                       : C:\WINDOWS\System32\RpcProxy
Server                     : EXH1
AdminDisplayName           :
ExchangeVersion            : 0.1 (8.0.535.0)
Name                       : Rpc (Default Web Site)
DistinguishedName          : CN=Rpc (Default Web Site),CN=HTTP,CN=Protocols,CN=
                             EXH1,CN=Servers,CN=Exchange Administrative Group (
                             FYDIBOHF23SPDLT),CN=Administrative Groups,CN=First
                              Organization,CN=Microsoft Exchange,CN=Services,CN
                             =Configuration,DC=domain,DC=LOcomL
Identity                   : EXH1\Rpc (Default Web Site)
Guid                       : 29653comd-a7da-40bb-9eba-7d738606b25c
Objectcomtegory             : domain.LOcomL/Configuration/Schema/ms-Exch-Rpc-Http
                             -Virtual-Directory
ObjectClass                : {top, msExchVirtualDirectory, msExchRpcHttpVirtual
                             Directory}
WhenChanged                : 8/30/2010 2:46:05 PM
WhenCreated                : 8/30/2010 2:46:05 PM
OriginatingServer          : exh1.domain.LOcomL
IsValid                    : True
0
 
masdf123Author Commented:
This is the correct one:
[PS] C:\Documents and Settings\Administrator>Get-OutlookAnywhere | fl


ServerName                 : EXH1
SSLOffloading              : False
ExternalHostname           : owa.domain.com
ClientAuthenticationMethod : Basic
IISAuthenticationMethods   : {Basic}
MetabasePath               : IIS://exh1.domain.LOCAL/W3SVC/1/ROOT/Rpc
Path                       : C:\WINDOWS\System32\RpcProxy
Server                     : EXH1
AdminDisplayName           :
ExchangeVersion            : 0.1 (8.0.535.0)
Name                       : Rpc (Default Web Site)
DistinguishedName          : CN=Rpc (Default Web Site),CN=HTTP,CN=Protocols,CN=
                             EXH1,CN=Servers,CN=Exchange Administrative Group (
                             FYDIBOHF23SPDLT),CN=Administrative Groups,CN=First
                              Organization,CN=Microsoft Exchange,CN=Services,CN
                             =Configuration,DC=domain,DC=LOCAL
Identity                   : EXH1\Rpc (Default Web Site)
Guid                       : 29653cad-a7da-40bb-9eba-7d738606b25c
ObjectCategory             : domain.LOCAL/Configuration/Schema/ms-Exch-Rpc-Http
                             -Virtual-Directory
ObjectClass                : {top, msExchVirtualDirectory, msExchRpcHttpVirtual
                             Directory}
WhenChanged                : 8/30/2010 2:46:05 PM
WhenCreated                : 8/30/2010 2:46:05 PM
OriginatingServer          : exh1.domain.LOCAL
IsValid                    : True
0
 
BusbarSolutions ArchitectCommented:
can you try www.testexhcangeconnectivity.com and post the report here
0
 
masdf123Author Commented:
I had posted that in the question:

      Testing Http Authentication Methods for URL https://owa.domain.com/rpc/rpcproxy.dll
       The HTTP authentication test failed.
       
      Additional Details
       Exception details:
Message: The underlying connection was closed: The connection was closed unexpectedly.
Type: System.Net.WebException
Stack trace:
at System.Net.HttpWebRequest.GetResponse()
at Microsoft.Exchange.Tools.ExRca.Tests.HttpAuthMethodsTest.GetSupportedHttpAuthMethods()
at Microsoft.Exchange.Tools.ExRca.Tests.HttpAuthMethodsTest.PerformTestReally()


Everything passes except the above (Last test in the RPC over http test)
0
 
endital1097Commented:
why you attempt to browse to that URL from your client do you get the login prompt (no cert warnings or errors)
0
 
masdf123Author Commented:
I was getting a login prompt, but think since i reinstalled rpc i just get a blank page without the login prompt.

Have tried after clearing cache as well.
0
 
sunnyc7Commented:
this might be rlated to the RPC/HTTPS issues you are having in your other post.
0
 
masdf123Author Commented:
What would be the solution?
0
 
v_9mhdrfCommented:
Lets try this.
Will remove RPC component from Add remove program and also disable Outlook Anywhere (OA).
Then will go ahead and Re-install RPC component from Add remove windows features and give Basic Authentication in IIS manager.
Enable Outlook Anywhere in EMC. Then try to browse https://owa.domain.com/rpc/rpcproxy.dll you should get a prompt for credentials and after entering your credentials you should get a blank page.
If this works.. please check for following registries once again in Exchange 2003.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem
Value name: Rpc/HTTP Port
Value type: REG_DWORD
Value data: 0x1771 (Decimal 6001)

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters
Value name: HTTP Port
Value type: REG_DWORD
Value data: 0x1772 (Decimal 6002)

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters
Value name: Rpc/HTTP NSPI Port
Value type: REG_DWORD
Value data: 0x1774 (Decimal 6004)

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Rpc\RpcProxy
Check for the Valid Port entries and it should be like this:-
ServerNETBIOSName:6001-6002;ServerFQDN:6001-6002;ServerNetBIOSName:6004;ServerFQDN:6004;

However in Exchange 2007 all the above registries will be present but make sure that you have the valid port entries correctly.
Once you get this, please try configuring Outlook client again, via Autodiscover or RPC over HTTPs.
If you are using Internal Certificate make sure that you install the certificates in the client machines.

And also make sure that ASP pages is allowed in Web Service Extensions in IIS manager.

Please check this out and revert back if you have any issues.

Thanks,
Mohammed


0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 9
  • 4
  • 3
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now