Using multiple databases in Crystal Reports 11

I have created a report in Crystal 11.  I have connected 2 different databases using a common field to connect them. The first set of tables pulls from the main database and they are working correctly.  I am also trying to create a chart within the report that pulls information from the 2nd database. I have tried the sub report option and I still can not get it to work correctly.  I don't know if this just can't be done or if I have placed the sub-report in the wrong place (report footer).  I have also tried to add a new Group to the report and then add the chart in that area to pull from the second different databse but the information in the chart never appears corretly.  
erkootooAsked:
Who is Participating?
 
mlmccConnect With a Mentor Commented:
Crystal doesn't play well with multiple data sources like that in a single report except by using a subreport.

Can you build the chart in its own report so it shows what you want?
If so then we can work out the linking and placement in the main report.,

mlmcc
0
 
erkootooAuthor Commented:
I have built the chart in it's own report and it is displaying the information accurately.  What I was trying to acheive was to keep it all on one page so it will print front and back. When I do it as a subreport that is where I don't think I may be placing it correctly.
0
 
mlmccCommented:
Where did you place it?

Did you link the subreport to the main report using the group field?

mlmcc
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 
erkootooAuthor Commented:
I placed it in the report footer.  I don't know how to link it to the main report other than placing it in the Report Footer.  Is there something else I need to do?
0
 
mlmccConnect With a Mentor Commented:
You can place it in the group header or footer
Right click it
Click CHANGE SUBREPORT LINKS
Choose the group field from the top box
In the lower right box choose the same field in the subreport

mlmcc
0
 
erkootooAuthor Commented:
Ok this worked....almost. Report shows correctly on 1st page is correct, then the 2nd page just shows a box which I beleive is the sub-report linked field. Then there is a third page that shows my chart which has CORRECT info in it. YEAH!!!!!!!  And then there is a 4th blank page like page 2. Is there a way I can get rid of the 2nd & 4th pages?
0
All Courses

From novice to tech pro — start learning today.