Solved

ORA-12545: Connect failed because target host or object does not exist

Posted on 2010-08-30
6
1,988 Views
Last Modified: 2012-05-10
Hi experts,

I have been trying to investigate issue related ORA-12545. The strange thing is whenever I tried to connect oracle 10G R2 RAC database(devsrv) through TOAD then it throws ORA-12545 error. After attempting 3 or 4 times, it will connect to the database. we have several databases are there on these hosts meaning all host IPs in the TNSNAMES.ORA file are same and only service name will be different. When I try to connect database (qasrv) then it never allows me to login to this database.

here is the TNSNAME I'm using to connect database.

AEQASRV=
  (DESCRIPTION=
    (LOAD_BALANCE=yes)
    (ADDRESS_LIST=
      (ADDRESS=
        (PROTOCOL=TCP)
        (HOST=10.100.100.120)
        (PORT=1521)
      )
      (ADDRESS=
        (PROTOCOL=TCP)
        (HOST=10.100.100.121)
        (PORT=1521)
      )
      (ADDRESS=
        (PROTOCOL=TCP)
        (HOST=10.100.100.123)
        (PORT=1521)
      )
    )
    (CONNECT_DATA=
      (FAILOVER_MODE=
        (TYPE=select)
        (METHOD=basic)
        (RETRIES=180)
        (DELAY=5)
      )
      (SERVER=dedicated)
      (SERVICE_NAME=aeqasrv)
    )
  )

One more thing, we have a developer who is accesing same QA database from his machine with out any issues. Is there any network settings do I need to adjust or tweek in order to connect to database? Any help would be appreciated.
 
0
Comment
Question by:KuldeepReddy
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
6 Comments
 
LVL 2

Expert Comment

by:j_coreil
ID: 33563852
Check the sqlnet files on both machines and compare them. Another thing to check, I've encountered this in 11g not 10g, is that the problem PC's dns settings are correct. In 11g, there is a known bug where if you cannot get to the primary DNS entry, it will have to timeout first before it attempts the secondary DNS entry. This process can take upwards to 2 minutes per request to the DNS server. So each session you try to open could possibly take forever.
0
 
LVL 29

Expert Comment

by:sammySeltzer
ID: 33563866
hi,

can you try pinging <SERVER_NAME>

If you do not get a response from the server this is your problem. try the same ping with the IP address of the server.

assuming you get a response when you specify the IP address but not the server name then you have a simple problem with DNS names resolution,

Also, check to see if you have virus scanner on that server. It is often guilty of interferring.
0
 
LVL 2

Expert Comment

by:j_coreil
ID: 33563877
Windows Firewall can sometimes be causing this problem. I would only disable it temporarily for testing.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 7

Expert Comment

by:sumit2906
ID: 33564051
This could be issue with the client, sometimes having multiple homes could cause issues like this. Also, you can use tnsping <alias> command to know whether your tns settings are fine.
0
 
LVL 6

Expert Comment

by:tangchunfeng
ID: 33564112
1. use hostname not IP address in your oracle tnsnames.ora
2. set hostname/ip pairs in c:\windows\system32\drivers\etc\hosts
0
 
LVL 13

Accepted Solution

by:
riazpk earned 500 total points
ID: 33565137
I just faced this issue recently. We were getting the same error while trying to connect our RAC Database. The solution is to add vip host name in the DNS (or in the hosts file but i prefer adding it in DNS because you can have more than one client trying to connect to this db and adding entries in DNS will avoid adding entries in hosts file of each client).
Once we did this, everything was perfectly ok.
0

Featured Post

PeopleSoft Has Never Been Easier

PeopleSoft Adoption Made Smooth & Simple!

On-The-Job Training Is made Intuitive & Easy With WalkMe's On-Screen Guidance Tool.  Claim Your Free WalkMe Account Now

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
ORA-02288: invalid OPEN mode 2 124
error doing substr 3 51
Oracle Query to Find number of process consumed by a session 15 67
SQL Syntax Question 9 54
Introduction A previously published article on Experts Exchange ("Joins in Oracle", http://www.experts-exchange.com/Database/Oracle/A_8249-Joins-in-Oracle.html) makes a statement about "Oracle proprietary" joins and mixes the join syntax with gen…
How to Unravel a Tricky Query Introduction If you browse through the Oracle zones or any of the other database-related zones you'll come across some complicated solutions and sometimes you'll just have to wonder how anyone came up with them.  …
This video shows information on the Oracle Data Dictionary, starting with the Oracle documentation, explaining the different types of Data Dictionary views available by group and permissions as well as giving examples on how to retrieve data from th…
This video shows how to Export data from an Oracle database using the Datapump Export Utility.  The corresponding Datapump Import utility is also discussed and demonstrated.

738 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question