My Documents folder redirection

Hi there

I'm trying to configure folder redirection on a Server 2008 R2 domain controller. In a test OU, I've been able to set the My Documents to redirect to \\server\share\Clair\My Documents

This test OU only has Windows 7 PCs in it and a test user.

A couple of staff will now be piloting Windows 7, so I need to enable the redirection again. This time, however, the preview shows up as \\server\share\Clair\Documents (note the absence of 'My ').

Each user already has their Documents backed up to \\server\share\%user%\My Documents using SecondCopy 2000, which is why I want the Windows 7 folder redirection to match.

Any ideas how to achieve this?
LVL 15
Ryan_RIT Systems AdministratorAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Ryan_RConnect With a Mentor IT Systems AdministratorAuthor Commented:
I got it working (somehow) - not exactly sure what it was that fixed it.

I tried changing the setting from Create folder to Use this folder, and typed \\Server\Share\%USERNAME%\My Documents. I don't think it liked that. What I did next was remove all Document-related folders of mine from my folder on the server and log in. The local Documents library was still there and synced from before, but when I tried to create a new folder in there, it gave me the error Path not Found. I think it might've been at this point that the server automatically changed the setting to \My Documents, but I cannot be sure.

Thanks for your assistance in the meantime.
0
 
Krzysztof PytkoSenior Active Directory EngineerCommented:
In previous OS versions like XP was "My Documents" folder. From Vista and above is only "Documents". Each "My" from XP disappeared in new OSes. So, you don't need to add it. Now, there is no My Documents, My Computer, only Documents and Computer.
0
 
Ryan_RIT Systems AdministratorAuthor Commented:
Erm, yeah I already know that.  =)

If a user logs onto Windows 7 with things as they are, their Documents folder/library will be empty.

However, if I move that user into the Win7Test OU that I created earlier, and they log on, the Documents folder is redirected to \\server\share\user\My Documents, which means it's already populated with their existing files. This is the outcome that I want, but I can't seem to get the production OU to use '\My Documents'.

Folder Redirection was not used in Server 2003/XP. The current GPOs that I have set have the 'Also apply to Server 2003, etc...' box unticked.

Staff who have laptops have 3rd party that backs up their documents to the location above. The fact that my test OU has it set to \My Documents indicates that it must also be possible to get it working on the productions OU.
0
 
jesajaCommented:
What is the redirected path set in GPO

Is is set like this

\\server\redirectedfoldershare

If it is set like and target is set to create a folder for each user ...this windows will redirect and automatically create a user name and the documents folder and name it as default documents and redirects the my documents form XP or 2000 clients. You have to enable this for 2000 XP clients under settings in the Folder redirection Properties

Hier is a like from ms

http://download.microsoft.com/download/3/b/a/3ba6d659-6e39-4cd7-b3a2-9c96482f5353/managing%20roaming%20user%20data%20deployment%20guide.doc
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.