Solved

Event ID 10016 on 2003 R2 SP2 Server

Posted on 2010-08-31
2
656 Views
Last Modified: 2012-08-13
I'm getting a lot of 10016 events on my computer. Here is the event log text:

Event Type:      Error
Event Source:      DCOM
Event Category:      None
Event ID:      10016
Date:            31/8/2010
Time:            12:46:45 PM
User:            NT AUTHORITY\NETWORK SERVICE
Computer:      xxxxxxx-xxx
Description:
The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID
{BA126AD1-2166-11D1-B1D0-00805FC1270E}
 to the user NT AUTHORITY\NETWORK SERVICE SID (S-1-5-20).  This security permission can be modified using the Component Services administrative tool.

I try and find the name of the CLSID and it is --> Network Connection Manager Class
I also try to find it in the console root\componet services\computers\my computer\DCOM Config\  to change permissions but i cant.
I only find Network Crawel and Network Provisioning Service.

Any ideas on how to deal with this?

0
Comment
Question by:johnf23
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 20

Accepted Solution

by:
woolnoir earned 500 total points
ID: 33565604
have you tried this ? taken from http://support.microsoft.com/kb/931355

To resolve this issue, grant the permissions that are mentioned in the "Cause" section to the netman component in DCOM. To do this, follow these steps:
Click Start, click Run, type dcomcnfg, and then click OK.
In Component Services, double-click Component Services, and then double-click Computers.
Expand My Computer, expand DCOM Config, and then click netman in the DCOM Config node.
Right-click netman, and then click Properties.
In the netman Properties dialog box, click the Security tab.
Under Launch and Activation Permissions, click Edit.
In the Launch Permission dialog box, click Add.
In the Enter the object names to select box, type Network Service, and then click OK.
While Network Service is selected, click to select the Allow check boxes for the following items:
Remote Launch
Local Activation
Remote Activation
Click OK two times.

0
 

Author Closing Comment

by:johnf23
ID: 33676270
OK
0

Featured Post

Free NetCrunch network monitor licenses!

Only on Experts-Exchange: Sign-up for a free-trial and we'll send you your permanent license!

Here is what you get: 30 Nodes | Unlimited Sensors | No Time Restrictions | Absolutely FREE!

Act now. This offer ends July 14, 2017.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Have you ever had a hard drive that you can't boot into, but need to change the registry? Here is the solution! This article guides you through accessing and editing a registry of a non-primary drive. To read registry information on a non-prim…
Scenerio: You have a server running Server 2003 and have applied a retail pack of Terminal Server Licenses.  You want to change servers or your server has crashed and you need to reapply the Terminal Server Licenses. When you enter the 16-digit lic…
This video Micro Tutorial explains how to clone a hard drive using a commercial software product for Windows systems called Casper from Future Systems Solutions (FSS). Cloning makes an exact, complete copy of one hard disk drive (HDD) onto another d…
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question