Cannot add distribution group to Outlook permissions tab on inbox folder.

Hi everyone,

We have a few email adresses which are used bij several people, i.e. info@domain.com. We add this mailbox as an extra mailbox within Outlook of the user and that always worked. In the old days with Exchange 2003 and Outlook 2003 we used to add rights to these mailboxes by creating a distribution group and adding members to that group within AD. Then we added the distribution group to de permissions tab in Outlook on de inbox folder and gave this distribution group the owner rights.

Now we have Exchange 2007 and Outlook 2007. We do exactly the same, but when adding the distribution group in de permissions tab of inbox there is a forbidden symbol throught the distribution groups, when CAN add users, nut no groups.

Anyone any ideas?
AgrippaSenior IT ConsultantAsked:
Who is Participating?
 
MrN1c3Connect With a Mentor Commented:
http://support.microsoft.com/kb/941318

To work around this issue, create security groups instead of distribution groups. Then, set folder permissions or set delegate permissions for the security groups.
0
 
MrN1c3Commented:
Have you tried using a Mail Enabled Universal Security Group?


0
 
AgrippaSenior IT ConsultantAuthor Commented:
Hi MrN1c3,

yes, that is exactly what we have.

I also just tried to add a distribution group to the permissions of inbox in Outlook 2010 with Exchange 2003 and that works, so it is not a Outlook problem. Must be something with permissions on the server. Perhaps Microsoft thought that up to prevent regular users from adding distribution groups to Outlook folders.
0
Easily manage email signatures in Office 365

Managing email signatures in Office 365 can be a challenging task if you don't have the right tool. CodeTwo Email Signatures for Office 365 will help you implement a unified email signature look, no matter what email client is used by users. Test it for free!

 
duffman76Commented:
Exchange 2007 requires them to be universal groups in order to do what you are wanting.  2003 did not care.
0
 
AgrippaSenior IT ConsultantAuthor Commented:
They are universal groups.

Please see attachment for the "forbidden" mark in de groups, the users are ok (I erased the names).
Outlook.jpg
0
 
AgrippaSenior IT ConsultantAuthor Commented:
Hi MrN1c3,

GREAT, that is the solution...

I love it when Microsoft keeps changing things that already worked fine.
0
 
aarontheyoung1Commented:
Hmmm...sounds good, but I don't get it.  When I create a security group, it doesn't show up when I am trying to setup permissions.

I am running Exchange 2007 and my client is running Outlook 2010.

How exactly do you create a security group that Outlook will recognize to set permissions?
0
All Courses

From novice to tech pro — start learning today.