Solved

Cannot connect to sql instance after ugrading from 2008 express to 2008 full

Posted on 2010-08-31
7
385 Views
Last Modified: 2012-05-10
Hi,

We have been using a sql 2008 express edition connecting through management studio using webufcw\sqlexpress with windows auth.

This morning I used the upgrade advisor to upgrade from express to enterprise and now i get the following error when trying to connect using management studio
"A network-related or instance-specific error occured while establishing a connection to sql server. the server was not found or was not accessible. Verify that the instance name is correct and that sql server is configured to allow remote connections (provider named pipes provider, error: 40 - could not open a connect to sql server)"

I made sure tcp-ip and name pipes were enabled for the instance after the upgrade and i also tried turning off windows firewall and still can't connect

thanks in advance
 
0
Comment
Question by:UFCWIT
  • 4
  • 2
7 Comments
 

Author Comment

by:UFCWIT
ID: 33567096
p.s. - I am running windows server 2008
0
 
LVL 5

Expert Comment

by:jlanderson1
ID: 33567149
Did you verify all services are running?  Specifically, the SQL Browser?
Also, did you specify a service account for the SQL Services?
0
 

Author Comment

by:UFCWIT
ID: 33567181
the sql server (sqlexpress) is not running. When i try to start it it comes up with the following error message

"the request failed or the service did not respond in a timely fashion. Consult the event log or other applicable error logs for details"
0
Three Reasons Why Backup is Strategic

Backup is strategic to your business because your data is strategic to your business. Without backup, your business will fail. This white paper explains why it is vital for you to design and immediately execute a backup strategy to protect 100 percent of your data.

 

Author Comment

by:UFCWIT
ID: 33567201
the error it shows in event viewer when trying to start service is
"SQL Server could not spawn FRunCM thread. Check the SQL Server error log and the Windows event logs for information about possible related problems."
0
 

Accepted Solution

by:
UFCWIT earned 0 total points
ID: 33567266
I think i might have got it, I disabled the via in the protocols after reading a help article about it and i am able to connect now
0
 
LVL 5

Expert Comment

by:jlanderson1
ID: 33567369
That's good news.  You solved it yourself!
0
 
LVL 9

Expert Comment

by:shalabhsharma
ID: 33567418
Start the MSSQL Service  under the Local service account .
0

Featured Post

Free Tool: Postgres Monitoring System

A PHP and Perl based system to collect and display usage statistics from PostgreSQL databases.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

There have been several questions about Large Transaction Log Files in SQL Server 2008, and how to get rid of them when disk space has become critical. This article will explain how to disable full recovery and implement simple recovery that carries…
Use this article to create a batch file to backup a Microsoft SQL Server database to a Windows folder.  The folder can be on the local hard drive or on a network share.  This batch file will query the SQL server to get the current date & time and wi…
I've attached the XLSM Excel spreadsheet I used in the video and also text files containing the macros used below. https://filedb.experts-exchange.com/incoming/2017/03_w12/1151775/Permutations.txt https://filedb.experts-exchange.com/incoming/201…
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an antispam), the admini…

713 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question