Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Cannot get vpn shares on SBS 2008 to work from MAC

Posted on 2010-08-31
7
Medium Priority
?
1,172 Views
Last Modified: 2013-11-24
Got an SBS 2008 and any client with Windows pc from home can VPN in to it and access the shares just fine.  Will not seem to work from Mac, but I am not a Mac person.  I tried it from a Mac and so did other clients, and while it seems to connect just fine, that's as far as you get.
So, when I initially set up the shares on the SBS 2008, I do make sure that SMB shares are allowed.  I take all the defaults so the path to the share is \\Servername\foldername
I've tried it setting up the permissions different ways including everyone has full access.

Now, on the Mac, I go to finder->applications->internet connect
I choose vpn, pptp and enter the ip info, and the login info matching the login on the server, and it connects just fine.

Now, I do the following:

1. Go to Finder
2.  Click on "Go" menu
3.  Click on "Connect to server"
4.  Enter "smb://192.168.1.2" in the "Server Address" box  

192.168.1.2 is the NAS address of the SBS 2008 server

I am asked to re-enter the username and password, so I do, and then it gives me an authentication error.  
I've tried this same thing from different Macs and even to different SBS 2008 servers.  No luck.  I know I must be doing something wrong but I am mystified by what it could be.  The Macs are all newer OS, not sure exact O/S version, but I could find out if that's key.  I am NOT a Mac person, never used one in my life until I tried to set up the VPN,  so I need super simple instructions for the MAC side, thanks!
0
Comment
Question by:mignonnedavis
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 2
7 Comments
 
LVL 53

Expert Comment

by:strung
ID: 33577353
Your problem likely is that the local LAN you are trying to connect from uses the same 192.168.1.x subnet as the lan you are trying to connect to. This confuses the Mac as it thinks that 192.168.1.2 is a local not remote address.

Probably your user has a Linksys router which defaults to a 192.168.1.x subnet. If you change the subnet of the router to, say, 192.168.5.x that will solve your problem.

To do that, enter the Linksys Admin site at 192.168.1.1 and change the Linksys LAN IP address to 192.168.5.1 and the DHCP range to 192.168.5.100 - 192.168.5.150. You will then have to reboot the Mac to reconnect to the router (to reset the Mac's IP to the right subnet) and re-connect to the Linksys admin which is now located at 192.168.5.1.
0
 

Author Comment

by:mignonnedavis
ID: 33578818
Have tried from many remote locations, Dlink, linksys, and other routers.  I am surprised Macs get confused, PCs don't.  I thought Macs were supposed to do everything better !  Well, no harm in trying. I will try from my own house later today.  But out of curiosity, there's no other workaround?  I don't see how I'm going to get these clients to reconfigure their routers.  And I don't want to change the server IP.
0
 
LVL 53

Expert Comment

by:strung
ID: 33579340
There is a check box in the Mac VPN client to send all traffic through the VPN, but quite frankly, I have never been able to get that to make a difference. I don't know why Macs and PC's work differently in that regard, but the topic has been raised here several times and no one has found a work around that I know of.
0
Connect further...control easier

With the ATEN CE624, you can now enjoy a high-quality visual experience powered by HDBaseT technology and the convenience of a single Cat6 cable to transmit uncompressed video with zero latency and multi-streaming for dual-view applications where remote access is required.

 
LVL 53

Expert Comment

by:strung
ID: 33579509
0
 
LVL 53

Accepted Solution

by:
strung earned 2000 total points
ID: 33579552
According to: http://www.net.princeton.edu/mac/network-config-x/caveats.html


"The PPTP VPN client does not provide a way to tune certain parameters associated with the VPN connection.  Some of these parameters a security-conscious customer might have wished to have the ability to tune:
 
While the VPN connection is active, the Mac has an additional default IP route, via the VPN server. However, the Mac still has an interface route to each locally-attached network. (I.e. the IP subnet to which each interface is currently attached.)
 The Mac will still use those interface routes in preference to the default route that points to the VPN server.
 As a result, traffic between the Mac and other devices on the same IP subnet as any of its interfaces will not use the VPN connection, but instead will continue to travel directly between the Mac and the other devices.
"
0
 
LVL 53

Expert Comment

by:strung
ID: 33579567
0
 

Author Closing Comment

by:mignonnedavis
ID: 33638428
I haven't had a chance to try this yet, but it sure seems reasonable.  
0

Featured Post

Simple, centralized multimedia control

Watch and learn to see how ATEN provided an easy and effective way for three jointly-owned pubs to control the 60 televisions located across their three venues utilizing the ATEN Control System, Modular Matrix Switch and HDBaseT extenders.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How can this article save you time AND money?  In just a few minutes you may discover something you didn't know existed that is easy enough for you to fix yourself!
Will you be ready when the clock on GDPR compliance runs out? Is GDPR even something you need to worry about? Find out more about the upcoming regulation changes and download our comprehensive GDPR checklist today !
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…

721 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question