Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1941
  • Last Modified:

Exchange Configuration

We are currently running a Microsoft Exchange 2003 environment with a front end Server that sends mail to our Sonicwall Smarthost which in turn delivers the mail to the Internet. There are 2 back end servers that hold the Exchange mailboxes. We recently implemented an Exchange 2007 configuration in anticipation of migrating from the 2003 environment over a period of time. The implementation of the 2007 environment went perfectly and we are able to run both systems concurrently and transfer mail with no issue. Unfortunately, our Sonicwall Smarthost failed and we opted to go with an external provider (McAfee SaaS formerly MX Logic). This has created some transport issues. We would like to make the Exchange 2007 Hub Transport server the primary “gateway” to the McAfee service. We have made all of the configurations to do so and there are no issues when sending from the 2007 mailboxes. However, when sending from the 2003 environment to the 2007 hub transport server we experience the following error intermittently. - >> 

A configuration error in the e-mail system caused the message to bounce between two servers or to be forwarded between two recipients. Contact your administrator.

<RFGATEMAIL.RFEK.com #5.4.6 smtp;554 5.4.6 Hop count exceeded - possible mail loop>
On the 2003 FE Server there is a send connector that is configured as follows:

•      Forward all mail through this connector to the following smart hosts -> rfvhubcas.rfek.com (2007 Hub Transport Server)
•      Local Bridgeheads ->Server: RFGatemail Virtual Server:Default SMTP Virtual Server

Could someone assist in adjusting the configuration to eliminate this error?
Thank you in advance for your assistance.
0
RFEMHelpdesk
Asked:
RFEMHelpdesk
  • 13
  • 11
  • +1
1 Solution
 
Tomas ValentaCommented:
there is loop between your servers. If you look in Message tracking log you will see what is route of your message and what is making loop.
0
 
RFEMHelpdeskAuthor Commented:
You are correct hence the question. It is looping between the 2003 server and the 2007 server.
0
 
endital1097Commented:
disable link state on the 2003 server, these updates can cause looping in a mixed environment

http://technet.microsoft.com/en-us/library/aa996728.aspx
0
Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

 
endital1097Commented:
do you have a send connector configured on the 2007 server? I would only have the send connector on the 2007 server used for outbound mail (that will be the end result anyway)
0
 
endital1097Commented:
there should be a routing group connector between 2003 and 2007 that will route mail to the send connector
you should not use a smtp connector unless they are unique exchange organizations
0
 
RFEMHelpdeskAuthor Commented:
Your link points to Exchange server 2010. Is there a link for exchange 2003?
0
 
endital1097Commented:
i don't think the link state is the issue
re-reading your post, it is going to be the smtp connector routing mail to the 2007 hub transport
you want to use the native routing group connector to route the message to 2007 and then 2007 will handle delivery from that point
0
 
RFEMHelpdeskAuthor Commented:
That is what I believe is currently configured and yet periodically we get this bouncing back and forth from 2003 to 2007. There are 3 connectors in the connectors folder in the 2003 ESM.
1. FaxPress E2K Connector - This is for our faxserver
2. RFEMail - RFVHubcas - This is the default 2007 connector created when 2007 was installed
3. SMTP Traffic - This is the 2003 connector that existed prior to the 2007 install but, modified as indicated above.
0
 
endital1097Commented:
you need to remove the SMTP traffice connector, that is the piece that is causing routing issues
the 2003 servers should use the RGC not the SMTP
0
 
RFEMHelpdeskAuthor Commented:
Testing your theory now. I will let you know how it goes.
0
 
RFEMHelpdeskAuthor Commented:
This appears to have resolved the original issue however a new wrinkle has appeared. We are now receiving a large number of the following errors as the mail is now being routed correctly ->>

 
The following recipient(s) could not be reached:  
   
      Jayne@email.com on 9/4/2010 9:55 AM  
            This message is larger than the current system limit or the recipient's mailbox is full.  Create a shorter message body or remove attachments and try sending it again.  
            <RFVHUBCAS.RFEK.com #5.3.4 smtp;550 5.3.4 ROUTING.SizeLimit; message size exceeds fixed maximum size for route>  
   
      amy@email.com on 9/4/2010 9:55 AM  
            This message is larger than the current system limit or the recipient's mailbox is full.  Create a shorter message body or remove attachments and try sending it again.  
            <RFVHUBCAS.RFEK.com #5.3.4 smtp;550 5.3.4 ROUTING.SizeLimit; message size exceeds fixed maximum size for route>  

The size of the attachment is 8MB and if split is delivered?
0
 
endital1097Commented:
check the size limit restrictions

get-receiveconnector | ft name,maxmessage*
get-sendconnector | ft name,maxmessage*
get-transportconfig | fl max*
0
 
RFEMHelpdeskAuthor Commented:
[PS] C:\Windows\System32>get-receiveconnector | ft name,maxmessage*

Name                                    MaxMessageSize
----                                    --------------
Default RFVHUBCAS                       100MB
Client RFVHUBCAS                        100MB
RFPDD SMTP AutoSupport Transfer         10MB


[PS] C:\Windows\System32>get-sendconnector | ft name,maxmessage*

Name                                    MaxMessageSize
----                                    --------------
Outbound Connector                      10MB

[PS] C:\Windows\System32>Get-TransportConfig | fl max*


MaxDumpsterSizePerStorageGroup : 18MB
MaxDumpsterTime                : 7.00:00:00
MaxReceiveSize                 : 500000KB
MaxRecipientEnvelopeLimit      : 5000
MaxSendSize                    : 100MB
0
 
endital1097Commented:
you can also check
get-routinggroupconnector | fl max*

and
get-mailbox amy | fl max*

0
 
RFEMHelpdeskAuthor Commented:
OK new to this.....not the same as 2003. What adjustments need to be made based on what you see to allow a 100MB limit?
0
 
endital1097Commented:
for the routing group connector
get-routinggroupconnector | set-routinggroupconnector -MaxMessageSize 100MB
0
 
RFEMHelpdeskAuthor Commented:
This will eliminate the messages we are receiving above?
0
 
endital1097Commented:
it will allow messages to go out from 2003 that are up to 100MB
right now that connector is limiting
0
 
RFEMHelpdeskAuthor Commented:
I have changed per the command above we are going to test now to see if the issue is resolved. Thank you for your rapid responses!
0
 
RFEMHelpdeskAuthor Commented:
 
   
Diagnostic information for administrators:  
   
Generating server: RFVHUBCAS.RFEK.com  
   
schumdj2@hotmail.com
 #550 5.3.4 ROUTING.SizeLimit; message size exceeds fixed maximum size for route ##  
   
darcywired@hotmail.com
 #550 5.3.4 ROUTING.SizeLimit; message size exceeds fixed maximum size for route ##  
   
Original message headers:  
   Received: from RFVCCR.RFEK.com ([192.168.0.34]) by RFVHUBCAS.RFEK.com ([::1])
  with mapi; Tue, 7 Sep 2010 11:10:35 -0400
 Content-Type: application/ms-tnef; name="winmail.dat"
 Content-Transfer-Encoding: binary
 From: David J Schumacher <dschumacher@rothwellfigg.com>
 To: "'schumdj2@hotmail.com'" <schumdj2@hotmail.com>,
             "'darcywired@hotmail.com'" <darcywired@hotmail.com>
 Date: Tue, 7 Sep 2010 11:09:49 -0400
 Subject: FW: Testing Outbound Max Size
 Thread-Topic: Testing Outbound Max Size
 Thread-Index: ActOnSaNhTAbim1uTyWU/otxontsDgAAVhbg
 Message-ID: <9B4EE6761998AB4AA00F952FDE6A9456A46E7E079D@RFVCCR.RFEK.com>
 Accept-Language: en-US
 Content-Language: en-US
 X-MS-Has-Attach: yes
 X-MS-TNEF-Correlator: <9B4EE6761998AB4AA00F952FDE6A9456A46E7E079D@RFVCCR.RFEK.com>
 MIME-Version: 1.0
0
 
endital1097Commented:
your send connector is set to 10MB
0
 
RFEMHelpdeskAuthor Commented:
How do I change it to allow the 100MB limit we are attempting to setup?

0
 
endital1097Commented:
set-sendconnector "Outbound Connector" -MaxMessageSize 100MB
0
 
RFEMHelpdeskAuthor Commented:
Testing........
0
 
Glen KnightCommented:
Sorry, I meant to accept comment ID: http:#33618751
0
 
RFEMHelpdeskAuthor Commented:
This question was never fully resolved.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 13
  • 11
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now