• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 923
  • Last Modified:

How do I configure wireless router for max speed and distance, Dlink DIR-628 dual band

I just purchased a new Dlink Rangebooster Dual N DIR-628 wireless router.  Used auto setup settings.  The router is on the 3rd floor of an old CHarleston SC house and I have a laptop on the 1st floor.  According to the lapton signal indicator for the wireless (it's a new HP laptop with build in N wireless) the signal appears strong, but, the connection speed does not seem good.  We tried listening to a church sermon in video, and it was stilted with audio lagging and it stopping periodically. But when we put the laptop on the second floor, it works fine.  Thus it appears to be a range issue?

1.) Is there anything I can do to the configuration settings to help this situation, to improve speed and or distance.
2.) If I have to use a repeater, say another router, would I have to change the settings on this router I'm using.

Thanks for your help
Joe
0
JoeBoyd
Asked:
JoeBoyd
1 Solution
 
bpinningCommented:
Hey,

Have you checked out the laptops wireless card? Is it a wireless G or N?

If it is a G you should get yourself a wireless N USB or internal wireless card and that will greatly improve your wireless signal on the laptop
0
 
nikko06Commented:
try changing the channel on the wireless router. maybe something is interfering with it on the first floor
0
 
LaVaismCommented:
Here are some options I would suggest:

Like Nikko06 stated check the channel you are on, you might be getting interference from another device.  Also if you have a cordless phone that could be causing performance issues. So play with the channels

Make sure your security is turned on so you are not inadvertently sharing your internet with someone else.  WPA2 do NOT use WEP as it is not secure.  

If your home/business is a three story complex then I would suggest a repeater as walls will hamper signal strength.  With a repeater you do not have to reconfigure the router but you most have an Ethernet port that they have to plug into the router.  So you will have to run a cable.  

You might want to try putting the router on the second floor instead of the top floor if that is at all possible.  Also ensure the antennas are not blocked and are facing up.  

Here is a link to a d-link range extender that will attach to your router: http://www.dlink.com/products/?pid=741

You could try an external wireless card as the one in the laptop might be blocked by other components in the laptop.  But again it sounds like signal is just weak down stairs.  
0
 
JoeBoydAuthor Commented:
THank you for your input.  It did help.  I was also looking for whether there were any other specific router settings I needed to check.  However, checking the channel was good advice and so was the pointers ony the antennas.  I did end up moving the laptop to the 2nd floor, works good there.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now