Can't connect via PPTP from home

Posted on 2010-08-31
Last Modified: 2012-05-10
Hello all,

At home I use a Cisco WRT610N router.
I just recently installed a Dlink DIR130 at a client site. I enabled PPTP on the Dlink and configured some usernames etc...

I did a quick test while onsite and it appeared PPT was working internally.
I try from home and I cannot connect. It gets stuck on verifying username and password and eventually gives me an error 619.
I receive the same error from different machines at home.

After some researching I tried doing some testing with PPTPclnt.
I receive this error from my home machines...
Error 10054
WSAECONNRESET: connection reset by peer.

I can get into the DLINK via the web interace so I know the router is reachable on port 80 (I had enabled remote management previously)..
The customer site where the Dlink is has a T1 line from Cbeyond. I did contact them and they indicated there should be nothing blocking PPTP on their end, their router is also setup in bridge mode so all traffic is passed directly through to the Dlink which has the public IP address.

I am not sure if I need to make changes to my Cisco device or maybe the Dlink.

Any help would be greatly appreciated.
Question by:LA75
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 2

Expert Comment

ID: 33570209
Can you post if there is some attempt to the connection when you try to reach the PPTP?

At Windows command prompt you can execute (and try to establish the connection to collect the results...):
netstat -na 1 |find "syn" --> To see if there is an attempt to stablish a connection to a port in determined IP
netstat -na 1 |find "external_ip_address" --> to see all the ports that have connection stablished with your provider IP...

Author Comment

ID: 33570459
I think I am understanding your instructions correctly.
I started my PPTP connection and gave the username password.
While it was verifying username and Password I ran the netstat -na command
I noticed 1 connection to the public address i am trying to PPTP to.
It was on port 1723. Status was established
that was the only connections I found with the desired IP.

I am not sure what you meant by "syn"
I did not see any connections with that name or even similar to that.

Accepted Solution

thiagotietze earned 500 total points
ID: 33570702
Yes, the procedure was right...

By your answer, it appears that the port 1723 is connecting well.
i think there should be a problem on handling the GRE protocol (47) on one of the hops.

By this, you should verify if GRE protocol is bein handled by your  WRT610N router...
Don't know much about this specific router configuration but found some interesting comments at Cisco's forum:

Have you how to isolate the problem, trying to connect direcly by a DSL connection, to this PPTP server? Without any pre-configured router of yours?
Surfing Is Meant To Be Done Outdoors

Featuring its rugged IP67 compliant exterior and delivering broad, fast, and reliable Wi-Fi coverage, the AP322 is the ideal solution for the outdoors. Manage this AP with either a Firebox as a gateway controller, or with the Wi-Fi Cloud for an expanded set of management features


Author Comment

ID: 33572257
I saw that article but that seems to be related to the PPTP server being behind the Cisco router.

In my situation the PPTP server is the Dlink router. It is my home connection that it behind the Cisco device. So i was not sure if that issue directly related to me.

 I will try later tonight to connect my PC directly to my cable line without my Cisco router and see if I can get connected. I need to wait until my wife is done working for the day. She works from home so I can't disconenct her just yet.

I should post the results in the next couple of hours.

thanks for all the help.

Author Comment

ID: 33573858
I just connected my laptop directly to my cable modem and got connected to the customer site via PPTP with no problem. but when connected behind my router it fails as stated above.

Anyone have ideas on what I need to enable on this particualr router to allow me to connect via PPTP to this customer.

Again the model is a WRT610N.


Author Comment

ID: 33574152
Quick update.

I did some looking online and found this may be a known issue wih the WRT610N router.
Apparently when PPTP passthrough is enabled it stops the username/password authentication from working.
With PPTP passthrough disabled I cannot even get to the IP address.

So unless anyone else knows different I guess I have to get a new router or use IPSEC.
Anyone know of a good freee client I could use with the Dlink DIR-130 router that would also work with my WRT610N?


Author Comment

ID: 33629887
Closing this question.
I guess I need a new router.

Featured Post

Building an interactive eFuture classroom

Watch and learn how ATEN provided a total control system solution including seamless switching matrix switch, HDBaseT extenders, PDU, lighting control to build an interactive eFuture classroom.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
ASA 5520 problem with Failover in Active/Standby 8 132
Static route question 6 59
Setting up new vpn 15 74
SOHO Router with software VPN access 1 56
Preface Having the need * to contact many different companies with different infrastructures * do remote maintenance in their network required us to implement a more flexible routing solution. As RAS, PPTP, L2TP and VPN Client connections are no…
How to set-up an On Demand, IPSec, Site to SIte, VPN from a Draytek Vigor Router to a Cyberoam UTM Appliance. A concise guide to the settings required on both devices
After creating this article (, I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (, I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question