can't turn on/off windows firewall on server 2003.

Hi Experts,

  I have a windows 2008 server and i'm trying to turn off the firewall and I get the follow message:

  Windows firewall settins cannot be displayed because the associated service is not running. Do you want to start the windows firewall service?

  So I click on YES and I get this message

 Windows cannot start the windows firewall service.

Any help?
frankbustosAsked:
Who is Participating?
 
Greg HejlPrincipal ConsultantCommented:
the services I specified were for server 2003.  for 2008 the services need to be the base filtering engine and windows firewall authorization adapter.  also check the logon for the service - should be the local service for these services.

check the logs?  would it be a 1709 error?  was there a 3rd party firewall installed?

if so, the best solution is to reinstall the OS - most likely a virus stepped on the local service accounts.

2008 windows firewall is integrated with the OS - many windows applications are firewall aware and will not run correctly if the firewall service doesn't communicate with the app.
0
 
vanbarsounCommented:
Which is it, server2003 or 2008? Have you tried rebooting, if possible, then disabling? Are you trying to explicitly stop/disable the service via the Services page or elsewhere?
0
 
Jimmy AndrewsFounder, What2do.LiveCommented:
If this server is a member of a Domain, then you have to set up the firewall through a GPO or the local security settings.

Is this server joined to a domain, or is it still in a 'workgroup'?
0
WEBINAR: 10 Easy Ways to Lose a Password

Join us on June 27th at 8 am PDT to learn about the methods that hackers use to lift real, working credentials from even the most security-savvy employees. We'll cover the importance of multi-factor authentication and how these solutions can better protect your business!

 
Greg HejlPrincipal ConsultantCommented:
windows firewall/ICS has two service dependancies

Network Connections service and Windows Mangemnet Instrumentation

please make sure these to services are running

start>run>services.msc
0
 
frankbustosAuthor Commented:
vanbarsoun: its 2008 and yest i've tried rebooting. i'm just trying to disable the firewall.

JimmyITCS: it is part of the domain

Greg_Heil: I've checked both of those services and they are both running.

0
 
Greg HejlPrincipal ConsultantCommented:
type windows firewall>select wf with advanced> rightclick on windows firewall and turn them off for the three profiles.

since it is domain gpo may prevent this

0
 
frankbustosAuthor Commented:
i get the following error: windows firewall with advanced security snap-in failed to load
0
 
frankbustosAuthor Commented:
tried everything and was spending more time than it was worth it. So, i decided to re-install the OS. thanks.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.