Solved

exchange 2003 migration problem

Posted on 2010-08-31
6
391 Views
Last Modified: 2012-05-10
Thank you for taking the time to read my problem. I am half way through my swing migration of exchange 2003. I am moving exchange 2003 of an existing domain controller and moving this onto its own server. I am following this excellent article:

http://www.amset.info/exchange/migration.asp

So far I have moved half of the mail box;s across, the ones that are left are users that use mobile devices to connect to the corporate email system such as Nokia E71, HTC and iPhone.

So far I have,
1.      Moved non OWA and remote mobile mailboxes to new server.
2.      Replicated Public Folders
3.      Added the new server as a local bridgehead to allow emails to route between the servers.
4.      Pointed F-Secure MSG to point emails to the new internal server which works okay.
5.      Installed RPC over HTTPS on the new server, clients that have their mail box’s moved across to the new server, outlook httpc over rpc works fine.
6.      Ordered and installed a SSL certificate on the new server.

This is the problem, when I have altered the Firewall to redirect ports 443 and port 80 to the new email server, although the following works https:\\mail.companyname.co.uk\exchange. Remote Mobile devices such as iPhone and my Nokia E71 are unable to connect, on my Nokia E71 the error message we get is Error in Exchange Server, please try again. On the iphone we get, The connection to the server failed.  I can confirm that both these users have their mail box on the new server. If I move my mail box back and reset the firewall back to point to the main domain controller then both devices work

Can anyone shed some light on this problem, I’m stumped, as sending and receiving emails work within outlook and outlook web access, it’s just a problem with 3rd party mobile devices. I would be extremely grateful if I could get this issue resolved.
0
Comment
Question by:ranakular
  • 3
  • 3
6 Comments
 
LVL 15

Accepted Solution

by:
Dave_AND earned 500 total points
ID: 33572384
I had this problem when I put 2007 is, took me a while to find this again but here it is:

"A hidden fix for this is in active directory, under the persons 'advanced' security permissions. You must 'check' the "include inheritable permissions..." at the bottom of the window.

In Active Directory Users and Computers (be sure that View > Advanced Features is on) , you go into the user account that is having the problem (yours in this case), and right click, Properties.

Once you’re in the user account properties, click the Security tab, then the Advanced button. “Include inheritable permissions from this object’s parent” needs to be checked. This means top-level permissions from the Exchange server itself are able to propagate down to user account settings. "

From http://discussions.apple.com/thread.jspa?threadID=1728784
0
 

Author Comment

by:ranakular
ID: 33574493
Thanks for your help. I've tried what you have suggested but it has not worked. This is the error message that is displayed in the event viewer.

Event Type: Error
Event Source: Server ActiveSync
Event Category: None
Event ID: 3029
Description: The mailbox server [%1] has its [%2] virtual directory set to require SSL. Exchange ActiveSync cannot access the server if SSL is set to be required.
For information about how to correctly configure Exchange virtual directory settings, click the following article number to view the article in the Microsoft Knowledge Base:
817379  (http://support.microsoft.com/kb/817379/ ) Exchange ActiveSync and Outlook Mobile Access errors occur when SSL or forms-based authentication is required for Exchange Server 2003
0
 

Author Comment

by:ranakular
ID: 33574971
Since I have the information, I have located the following article:
http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_22147043.html?sfQueryTermInfo=1+10+30+3029+event+id

Following the last comment by Sembee: I am able to synchronise the Nokia E71s but unable to synch apple iPhones:

Don't confuse the setting "Require SSL" and your ability to use SSL.
On my deployments I put an SSL certificate in place, but I do not enable the option to require SSL anywhere. I can still use SSL as the certificate is there. What I don't do is allow any port 80 traffic in. The users have to put in https or they do not get connected. You get a few complaints when it is first deployed but they soon get used to it - plus I am rather stubborn.

Simon.
0
Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

 
LVL 15

Expert Comment

by:Dave_AND
ID: 33575094
That is strange then, as iPhones should pop up with a "this is not a trusted cert, are you sure you want to continue"  What happens when you setup the Iphones? does it just not connect or does it connect, but not sync?
0
 

Author Comment

by:ranakular
ID: 33575138
Just discovered the problem, the end user had an incorrect setting in their iPhone and it now works okay. Will reward you the points, as your first post set the ball rolling in getting to the route problem. A big thank you. I can now make a move in transferring the rest of user email box's across.
0
 
LVL 15

Expert Comment

by:Dave_AND
ID: 33575577
Ahh pesky users!! it would be a lot easier without them eh? ;)
0

Featured Post

What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

Join & Write a Comment

Check out this infographic on what you need to make a good email signature that will work perfectly for your organization.
Marketers need statistics and metrics like everybody else needs oxygen. In this article we explain how to enable marketing campaign statistics for Microsoft Exchange mail.
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
This video discusses moving either the default database or any database to a new volume.

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now